summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-03-15 08:34:59 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-03-15 08:34:59 +0000
commit21ca4b480d6540a7999647d05b07c7f646b7d433 (patch)
treef493801589e3cdfcdc08ae53d13c85d29eb9c66c /media-sound/sweep
parentnew version, some updates and fixes (diff)
downloadgentoo-2-21ca4b480d6540a7999647d05b07c7f646b7d433.tar.gz
gentoo-2-21ca4b480d6540a7999647d05b07c7f646b7d433.tar.bz2
gentoo-2-21ca4b480d6540a7999647d05b07c7f646b7d433.zip
New ebuild (~masked) closes #15894
Diffstat (limited to 'media-sound/sweep')
-rw-r--r--media-sound/sweep/ChangeLog12
-rw-r--r--media-sound/sweep/files/digest-sweep-0.8.11
-rw-r--r--media-sound/sweep/sweep-0.8.1.ebuild38
3 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/sweep/ChangeLog b/media-sound/sweep/ChangeLog
new file mode 100644
index 000000000000..097dcd8cb760
--- /dev/null
+++ b/media-sound/sweep/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for media-sound/sweep
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sweep/ChangeLog,v 1.1 2003/03/15 08:34:58 jje Exp $
+
+*sweep-0.8.1 (15 Mar 2003)
+
+ 15 Mar 2003; jje <jje@gentoo.org> sweep-0.8.1.ebuild:
+ Initial revision. Not building experimental code so alsa support currently
+ diabled.
+
+ Submitted by: Caleb Shay and Ole Johnny Gauteplass.
+
diff --git a/media-sound/sweep/files/digest-sweep-0.8.1 b/media-sound/sweep/files/digest-sweep-0.8.1
new file mode 100644
index 000000000000..eb91486625d9
--- /dev/null
+++ b/media-sound/sweep/files/digest-sweep-0.8.1
@@ -0,0 +1 @@
+MD5 748ef8234814bedcd2eae86cf562a128 sweep-0.8.1.tar.gz 776247
diff --git a/media-sound/sweep/sweep-0.8.1.ebuild b/media-sound/sweep/sweep-0.8.1.ebuild
new file mode 100644
index 000000000000..80c46033f162
--- /dev/null
+++ b/media-sound/sweep/sweep-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sweep/sweep-0.8.1.ebuild,v 1.1 2003/03/15 08:34:58 jje Exp $
+
+DESCRIPTION="Sweep is an audio editor and live playback tool for GNU/Linux, BSD and compatible systems."
+HOMEPAGE="http://www.metadecks.org/software/sweep/"
+SRC_URI="mirror://sourceforge/sweep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~mips ~alpha"
+
+IUSE="alsa oggvorbis"
+
+DEPEND=">=x11-libs/gtk+-1.2
+ >=media-libs/libsndfile-1.0
+ media-libs/libsamplerate
+ dev-libs/tdb
+ dev-util/pkgconfig
+ oggvorbis? ( >=media-libs/libvorbis-1.0-r2 media-libs/libogg )
+ media-sound/mad
+ media-libs/speex
+ alsa? ( >=media-libs/alsa-lib-0.9.0_rc1 )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="--enable-alsa"
+ use oggvorbis || myconf="${myconf} --disable-oggvorbis"
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ einstall
+}
+