summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-19 17:50:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-19 17:50:23 +0000
commit7e87b6da0eefa57f5d91ba0a290a7b204b1b7345 (patch)
tree3a74dacda8f01c9bf54166617d0b18d370cfe51e /media-sound/streamixer/streamixer-1.19.0-r1.ebuild
parentMarked ~hppa (bug #240425). (diff)
downloadgentoo-2-7e87b6da0eefa57f5d91ba0a290a7b204b1b7345.tar.gz
gentoo-2-7e87b6da0eefa57f5d91ba0a290a7b204b1b7345.tar.bz2
gentoo-2-7e87b6da0eefa57f5d91ba0a290a7b204b1b7345.zip
Honour ldflags/cflags/cxxflags/cc/cxx, bug #240830, fix gcc 4.3 build, bug #251258
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'media-sound/streamixer/streamixer-1.19.0-r1.ebuild')
-rw-r--r--media-sound/streamixer/streamixer-1.19.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-sound/streamixer/streamixer-1.19.0-r1.ebuild b/media-sound/streamixer/streamixer-1.19.0-r1.ebuild
new file mode 100644
index 000000000000..5e136818a098
--- /dev/null
+++ b/media-sound/streamixer/streamixer-1.19.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamixer/streamixer-1.19.0-r1.ebuild,v 1.1 2008/12/19 17:50:23 aballier Exp $
+
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Various audio stream handling tools (non-interactive)"
+HOMEPAGE="http://bisqwit.iki.fi/source/streamixer.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+#-sparc: 1.19.0: bad assembly
+KEYWORDS="~amd64 -sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="sys-apps/sed"
+IUSE=""
+
+INSTALLPROGS="resample mixer mixwrite mixeridle ecat hum mixerscript"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s:BINDIR=/usr/local/bin:BINDIR=${D}usr/bin:" \
+ -e "s:^\\(ARGHLINK.*-L.*\\):#\\1:" \
+ -e "s:^#\\(ARGHLINK=.*a\\)$:\\1:" \
+ -e "s:\$(CXX):\$(CXX) \$(CXXFLAGS) -I${S}/argh:g" \
+ Makefile
+
+ sed -i \
+ -e 's:CPPFLAGS=:CPPFLAGS=-I/var/tmp/portage/erec-2.2.0.1/work/erec-2.2.0.1/argh :' \
+ Makefile.sets
+
+ echo "" > .depend
+ echo "" > argh/.depend
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -C argh libargh.a || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${INSTALLPROGS} || die
+}
+
+src_install() {
+ dobin ${INSTALLPROGS}
+ dohard /usr/bin/mixwrite /usr/bin/mixmon
+ dodoc README
+ dohtml README.html
+}