summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-19 09:40:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-19 09:40:22 +0000
commit3015e4127a659c9e438ec87bd17e70173a71a5f2 (patch)
tree058e351cdf9a0c1b78570990eb5f157a6a7f5775 /media-sound/splay
parentVersion bump. Remove old. (diff)
downloadgentoo-2-3015e4127a659c9e438ec87bd17e70173a71a5f2.tar.gz
gentoo-2-3015e4127a659c9e438ec87bd17e70173a71a5f2.tar.bz2
gentoo-2-3015e4127a659c9e438ec87bd17e70173a71a5f2.zip
fix build with gcc 4.3, by Yaroslav Gorbunov, bug #251255
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'media-sound/splay')
-rw-r--r--media-sound/splay/ChangeLog6
-rw-r--r--media-sound/splay/files/splay-0.9.5.2-gcc43-2.patch42
-rw-r--r--media-sound/splay/splay-0.9.5.2.ebuild3
3 files changed, 49 insertions, 2 deletions
diff --git a/media-sound/splay/ChangeLog b/media-sound/splay/ChangeLog
index 6dab448b6589..a7792eeb0a24 100644
--- a/media-sound/splay/ChangeLog
+++ b/media-sound/splay/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/splay
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/ChangeLog,v 1.16 2008/08/06 22:36:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/ChangeLog,v 1.17 2008/12/19 09:40:22 aballier Exp $
+
+ 19 Dec 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/splay-0.9.5.2-gcc43-2.patch, splay-0.9.5.2.ebuild:
+ fix build with gcc 4.3, by Yaroslav Gorbunov, bug #251255
06 Aug 2008; Alexis Ballier <aballier@gentoo.org>
+files/splay-0.9.5.2-gcc43.patch, splay-0.9.5.2.ebuild:
diff --git a/media-sound/splay/files/splay-0.9.5.2-gcc43-2.patch b/media-sound/splay/files/splay-0.9.5.2-gcc43-2.patch
new file mode 100644
index 000000000000..d07090743b5a
--- /dev/null
+++ b/media-sound/splay/files/splay-0.9.5.2-gcc43-2.patch
@@ -0,0 +1,42 @@
+diff -Nurpa splay-0.9.5.2.orig/apps/splay.cc splay-0.9.5.2/apps/splay.cc
+--- splay-0.9.5.2.orig/apps/splay.cc 2008-12-17 03:37:47.000000000 +0300
++++ splay-0.9.5.2/apps/splay.cc 2008-12-17 03:39:34.000000000 +0300
+@@ -150,16 +150,16 @@ ostream& operator<<(ostream& s, const ID
+ // Print just what we want...
+ s.setf(ios::left); // The filled fields get the text to the left
+ s <<
+- "Title : " << nn(ID3_GetTitle(tag)) << endl;
++ "Title : " << nn(ID3_GetTitle(tag)) << std::endl;
+ s <<
+- "Artist: " << setw(30) << nn(ID3_GetArtist(tag)) <<
++ "Artist: " << std::setw(30) << nn(ID3_GetArtist(tag)) <<
+ "Album: " << nn(ID3_GetAlbum(tag)) <<
+- endl ;
++ std::endl ;
+
+ s <<
+- "Genre : " << setw(18) << nn(ID3_gen_list[ID3_GetGenreNum(tag)]) <<
+- "Track: " << setw(5) << ID3_GetTrackNum(tag) <<
+- "Year: " << setw(6) << nn(ID3_GetYear(tag));
++ "Genre : " << std::setw(18) << nn(ID3_gen_list[ID3_GetGenreNum(tag)]) <<
++ "Track: " << std::setw(5) << ID3_GetTrackNum(tag) <<
++ "Year: " << std::setw(6) << nn(ID3_GetYear(tag));
+ // if ( ID3_GetComment(tag) ){
+ // s << endl << "Comment:" << nn(ID3_GetComment(tag)) <<
+ // nn(ID3_GetLyricist(tag)) << nn(ID3_GetLyrics(tag));
+@@ -180,13 +180,13 @@ static void play(char *filename)
+ try {
+ const ID3_Tag* mytag = new ID3_Tag(filename);
+ if ( mytag->HasV1Tag() || mytag->HasV2Tag() )
+- cout << mytag << endl;
++ std::cout << mytag << std::endl;
+ delete mytag;
+
+ }
+ // catch(ID3_Error &err){
+ catch(...){
+- cout << "Error found (GetError functions disabled)" << endl;
++ std::cout << "Error found (GetError functions disabled)" << std::endl;
+ // cout << err.GetErrorFile() << " (" << err.GetErrorLine() << "): "
+ // << err.GetErrorType() << ": " << err.GetErrorDesc() << endl;
+ }
diff --git a/media-sound/splay/splay-0.9.5.2.ebuild b/media-sound/splay/splay-0.9.5.2.ebuild
index 15ca152999b1..be6822fd8428 100644
--- a/media-sound/splay/splay-0.9.5.2.ebuild
+++ b/media-sound/splay/splay-0.9.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.18 2008/08/06 22:36:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.19 2008/12/19 09:40:22 aballier Exp $
inherit eutils
@@ -19,6 +19,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-gcc43.patch"
cd "${S}/apps"
epatch "${FILESDIR}/${P}-external-id3lib.diff"
+ epatch "${FILESDIR}/${P}-gcc43-2.patch"
}
src_compile() {