summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-04-04 17:00:34 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-04-04 17:00:34 +0000
commitc4feb20728fc6d54832422a7b23913a0a5fcfa3b (patch)
treeb738338b814eada84fb356967a8359db14d449a5 /media-sound/splay/splay-0.9.5.2.ebuild
parentdigest recommit (diff)
downloadgentoo-2-c4feb20728fc6d54832422a7b23913a0a5fcfa3b.tar.gz
gentoo-2-c4feb20728fc6d54832422a7b23913a0a5fcfa3b.tar.bz2
gentoo-2-c4feb20728fc6d54832422a7b23913a0a5fcfa3b.zip
added patch to fix compilation problems if an id3lib is installed. fixes #87597
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-sound/splay/splay-0.9.5.2.ebuild')
-rw-r--r--media-sound/splay/splay-0.9.5.2.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/media-sound/splay/splay-0.9.5.2.ebuild b/media-sound/splay/splay-0.9.5.2.ebuild
index 47261eb4d632..307acfa49153 100644
--- a/media-sound/splay/splay-0.9.5.2.ebuild
+++ b/media-sound/splay/splay-0.9.5.2.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.12 2004/09/14 07:43:59 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.13 2005/04/04 17:00:34 luckyduck Exp $
+
+inherit eutils
IUSE=""
DESCRIPTION="an audio player, primarily for the console"
HOMEPAGE="http://splay.sourceforge.net/"
-# Note non-standard sourceforge distribution location, so we can't use
-# mirror://sourceforge/...
SRC_URI="http://splay.sourceforge.net/tgz/${P}.tar.gz"
LICENSE="GPL-2"
@@ -16,6 +16,12 @@ KEYWORDS="x86 amd64"
DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}/apps
+ epatch ${FILESDIR}/${P}-external-id3lib.diff
+}
+
src_compile() {
# Force compilation to omit X support according to BUG #5856
# even when qt is present on the system.
@@ -27,5 +33,5 @@ src_compile() {
src_install() {
# Specify man-page to prevent xsplay.1 from being installed
einstall man_MANS=splay.1 || die "einstall failed"
- dodoc AUTHORS COPYING COPYING.LIB ChangeLog README README.LIB NEWS
+ dodoc AUTHORS ChangeLog README README.LIB NEWS
}