summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-08-18 20:43:52 +0000
committerMatt Turner <mattst88@gentoo.org>2011-08-18 20:43:52 +0000
commitcf113bcab12b62c3f15c71d6c222bb7b580b9c2c (patch)
tree06cb2206751f2dce951362ee91efc5dc6e6b0bfb /media-sound/sox
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo in bug... (diff)
downloadgentoo-2-cf113bcab12b62c3f15c71d6c222bb7b580b9c2c.tar.gz
gentoo-2-cf113bcab12b62c3f15c71d6c222bb7b580b9c2c.tar.bz2
gentoo-2-cf113bcab12b62c3f15c71d6c222bb7b580b9c2c.zip
Add openmp USE flag, bug 371549.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/sox')
-rw-r--r--media-sound/sox/ChangeLog6
-rw-r--r--media-sound/sox/sox-14.3.0.ebuild5
-rw-r--r--media-sound/sox/sox-14.3.1.ebuild5
-rw-r--r--media-sound/sox/sox-14.3.2.ebuild5
4 files changed, 14 insertions, 7 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index ae22b584f5f2..7b293d3b6017 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/sox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.126 2011/06/14 04:45:07 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.127 2011/08/18 20:43:52 mattst88 Exp $
+
+ 18 Aug 2011; Matt Turner <mattst88@gentoo.org> sox-14.3.0.ebuild,
+ sox-14.3.1.ebuild, sox-14.3.2.ebuild:
+ Add openmp USE flag, bug 371549.
14 Jun 2011; Matt Turner <mattst88@gentoo.org> sox-14.3.2.ebuild:
Added ~mips, bug 260095
diff --git a/media-sound/sox/sox-14.3.0.ebuild b/media-sound/sox/sox-14.3.0.ebuild
index 9393a898e73e..202896de89c2 100644
--- a/media-sound/sox/sox-14.3.0.ebuild
+++ b/media-sound/sox/sox-14.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.0.ebuild,v 1.12 2011/04/03 11:07:44 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.0.ebuild,v 1.13 2011/08/18 20:43:52 mattst88 Exp $
inherit flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/sox/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="alsa ao debug encode ffmpeg flac id3tag ladspa mad ogg oss png pulseaudio sndfile wavpack"
+IUSE="alsa ao debug encode ffmpeg flac id3tag ladspa mad ogg openmp oss png pulseaudio sndfile wavpack"
RDEPEND="alsa? ( media-libs/alsa-lib )
encode? ( media-sound/lame )
@@ -36,6 +36,7 @@ src_compile () {
econf $(use_with alsa) \
$(use_enable debug) \
+ $(use_enable openmp gomp) \
$(use_with ao) \
$(use_with oss) \
$(use_with encode lame) \
diff --git a/media-sound/sox/sox-14.3.1.ebuild b/media-sound/sox/sox-14.3.1.ebuild
index 3ae1f1b9a721..018c7ee110da 100644
--- a/media-sound/sox/sox-14.3.1.ebuild
+++ b/media-sound/sox/sox-14.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.1.ebuild,v 1.4 2011/04/03 11:07:44 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.1.ebuild,v 1.5 2011/08/18 20:43:52 mattst88 Exp $
EAPI=2
inherit eutils flag-o-matic
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/sox/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="alsa amr ao debug encode ffmpeg flac id3tag ladspa mad ogg oss png pulseaudio sndfile wavpack"
+IUSE="alsa amr ao debug encode ffmpeg flac id3tag ladspa mad ogg openmp oss png pulseaudio sndfile wavpack"
# libtool required for libltdl
RDEPEND="sys-devel/libtool
@@ -46,6 +46,7 @@ src_configure() {
econf \
$(use_with alsa) \
$(use_enable debug) \
+ $(use_enable openmp gomp) \
$(use_with ao) \
$(use_with oss) \
$(use_with encode lame) \
diff --git a/media-sound/sox/sox-14.3.2.ebuild b/media-sound/sox/sox-14.3.2.ebuild
index 33a0af5164bc..e5750f00d601 100644
--- a/media-sound/sox/sox-14.3.2.ebuild
+++ b/media-sound/sox/sox-14.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.2.ebuild,v 1.5 2011/06/14 04:45:07 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.2.ebuild,v 1.6 2011/08/18 20:43:52 mattst88 Exp $
EAPI=2
inherit eutils flag-o-matic
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/sox/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE="alsa amr ao debug encode ffmpeg flac id3tag ladspa mad ogg oss png pulseaudio sndfile wavpack"
+IUSE="alsa amr ao debug encode ffmpeg flac id3tag ladspa mad ogg openmp oss png pulseaudio sndfile wavpack"
# libtool required for libltdl
RDEPEND="sys-devel/libtool
@@ -46,6 +46,7 @@ src_configure() {
econf \
$(use_with alsa) \
$(use_enable debug) \
+ $(use_enable openmp gomp) \
$(use_with ao) \
$(use_with oss) \
$(use_with encode lame) \