summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-03-27 11:43:02 +0000
committerSamuli Suominen <drac@gentoo.org>2008-03-27 11:43:02 +0000
commit25e99f8c7dea9b1fab0667722ebfac5db5edcecf (patch)
tree150a3693a1e4b9a4e79616ec47ec8ddb9898d935 /media-sound/sooperlooper
parentBump patchset to backport a fix from upstream to fix bug #214809 (diff)
downloadgentoo-2-25e99f8c7dea9b1fab0667722ebfac5db5edcecf.tar.gz
gentoo-2-25e99f8c7dea9b1fab0667722ebfac5db5edcecf.tar.bz2
gentoo-2-25e99f8c7dea9b1fab0667722ebfac5db5edcecf.zip
Version bump wrt #212570, thanks to Arne Babenhauserheide for reporting. Upstream seems to have 1.6.3 also available, but they forgot to upload source package.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound/sooperlooper')
-rw-r--r--media-sound/sooperlooper/ChangeLog12
-rw-r--r--media-sound/sooperlooper/files/sooperlooper-1.6.2-asneeded.patch12
-rw-r--r--media-sound/sooperlooper/sooperlooper-1.6.2.ebuild46
3 files changed, 68 insertions, 2 deletions
diff --git a/media-sound/sooperlooper/ChangeLog b/media-sound/sooperlooper/ChangeLog
index e1662d371439..47be7aa0f24a 100644
--- a/media-sound/sooperlooper/ChangeLog
+++ b/media-sound/sooperlooper/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/sooperlooper
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sooperlooper/ChangeLog,v 1.9 2007/07/27 17:38:01 aballier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sooperlooper/ChangeLog,v 1.10 2008/03/27 11:43:02 drac Exp $
+
+*sooperlooper-1.6.2 (27 Mar 2008)
+
+ 27 Mar 2008; Samuli Suominen <drac@gentoo.org>
+ +files/sooperlooper-1.6.2-asneeded.patch, +sooperlooper-1.6.2.ebuild:
+ Version bump wrt #212570, thanks to Arne Babenhauserheide for reporting.
+ Upstream seems to have 1.6.3 also available, but they forgot to upload
+ source package.
27 Jul 2007; Alexis Ballier <aballier@gentoo.org>
+files/sooperlooper-1.1.0-asneeded.patch, sooperlooper-1.1.0.ebuild:
diff --git a/media-sound/sooperlooper/files/sooperlooper-1.6.2-asneeded.patch b/media-sound/sooperlooper/files/sooperlooper-1.6.2-asneeded.patch
new file mode 100644
index 000000000000..bcbd88271964
--- /dev/null
+++ b/media-sound/sooperlooper/files/sooperlooper-1.6.2-asneeded.patch
@@ -0,0 +1,12 @@
+diff -ur sooperlooper-1.6.2.orig/src/Makefile.in sooperlooper-1.6.2/src/Makefile.in
+--- sooperlooper-1.6.2.orig/src/Makefile.in 2008-03-12 06:15:44.000000000 +0200
++++ sooperlooper-1.6.2/src/Makefile.in 2008-03-27 13:33:37.000000000 +0200
+@@ -281,7 +281,7 @@
+ sooperlooper_SOURCES = \
+ sooperlooper.cpp
+
+-sooperlooper_LDADD = libsldrivers.a libslcore.a @JACK_LIBS@ @LOSC_LIBS@ @SIGCPP_LIBS@ @RUBBERBAND_LIBS@ @FFTW_LIBS@ @SNDFILE_LIBS@ @SAMPLERATE_LIBS@ @AUDIO_LIBS@ @XML_LIBS@
++sooperlooper_LDADD = libsldrivers.a libslcore.a @BASE_LIBS@ @JACK_LIBS@ @LOSC_LIBS@ @SIGCPP_LIBS@ @RUBBERBAND_LIBS@ @FFTW_LIBS@ @SNDFILE_LIBS@ @SAMPLERATE_LIBS@ @AUDIO_LIBS@ @XML_LIBS@
+ sooperlooper_LDFLAGS =
+ slconsole_SOURCES = slconsole.cpp
+ slconsole_LDADD = @LOSC_LIBS@ @NCURSES_LIBS@ -lpthread
diff --git a/media-sound/sooperlooper/sooperlooper-1.6.2.ebuild b/media-sound/sooperlooper/sooperlooper-1.6.2.ebuild
new file mode 100644
index 000000000000..7de8911e6d60
--- /dev/null
+++ b/media-sound/sooperlooper/sooperlooper-1.6.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sooperlooper/sooperlooper-1.6.2.ebuild,v 1.1 2008/03/27 11:43:02 drac Exp $
+
+EAPI=1
+
+inherit eutils wxwidgets
+
+DESCRIPTION="Live looping sampler with immediate loop recording"
+HOMEPAGE="http://essej.net/sooperlooper/index.html"
+SRC_URI="http://essej.net/sooperlooper/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.80
+ x11-libs/wxGTK:2.6
+ >=media-libs/liblo-0.18
+ dev-libs/libsigc++:1.2
+ media-libs/libsndfile
+ media-libs/libsamplerate
+ dev-libs/libxml2
+ media-libs/rubberband
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_compile() {
+ WX_GTK_VER="2.6"
+ need-wxwidgets gtk2
+ econf --disable-optimize --with-wxconfig-path="${WX_CONFIG}"
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc OSC README
+}