summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-07-27 18:36:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-07-27 18:36:58 +0000
commit2e7c3d5a8b79aa586a748f5815d64549c7848a5d (patch)
tree7d86cfe15edaec24457b8bd977f5c7a5b57c19d4 /media-sound/snd
parentDrop alpha keyword, doesn't work (diff)
downloadgentoo-2-2e7c3d5a8b79aa586a748f5815d64549c7848a5d.tar.gz
gentoo-2-2e7c3d5a8b79aa586a748f5815d64549c7848a5d.tar.bz2
gentoo-2-2e7c3d5a8b79aa586a748f5815d64549c7848a5d.zip
version bump
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'media-sound/snd')
-rw-r--r--media-sound/snd/ChangeLog7
-rw-r--r--media-sound/snd/files/digest-snd-9.23
-rw-r--r--media-sound/snd/snd-9.2.ebuild113
3 files changed, 122 insertions, 1 deletions
diff --git a/media-sound/snd/ChangeLog b/media-sound/snd/ChangeLog
index 137e4defaa1d..6503c681cfa1 100644
--- a/media-sound/snd/ChangeLog
+++ b/media-sound/snd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/snd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.34 2007/06/13 18:26:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.35 2007/07/27 18:36:58 aballier Exp $
+
+*snd-9.2 (27 Jul 2007)
+
+ 27 Jul 2007; Alexis Ballier <aballier@gentoo.org> +snd-9.2.ebuild:
+ version bump
*snd-9.1 (13 Jun 2007)
diff --git a/media-sound/snd/files/digest-snd-9.2 b/media-sound/snd/files/digest-snd-9.2
new file mode 100644
index 000000000000..642a2c6f1f70
--- /dev/null
+++ b/media-sound/snd/files/digest-snd-9.2
@@ -0,0 +1,3 @@
+MD5 c3940fffda7eba177764cf48cf353f6b snd-9.2.tar.gz 8569042
+RMD160 f612289d84dc1e9f994f945f3e046545568e0920 snd-9.2.tar.gz 8569042
+SHA256 5ec02c7852b0b35bdaa41d95d3cfad640a374acf6e7fdd1b869789ad1cd96870 snd-9.2.tar.gz 8569042
diff --git a/media-sound/snd/snd-9.2.ebuild b/media-sound/snd/snd-9.2.ebuild
new file mode 100644
index 000000000000..9c3958bf583e
--- /dev/null
+++ b/media-sound/snd/snd-9.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-9.2.ebuild,v 1.1 2007/07/27 18:36:58 aballier Exp $
+
+inherit multilib eutils
+
+S="${WORKDIR}/${P/\.*//}"
+DESCRIPTION="Snd is a sound editor"
+HOMEPAGE="http://ccrma.stanford.edu/software/snd/"
+SRC_URI="ftp://ccrma-ftp.stanford.edu/pub/Lisp/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa cairo esd fam fftw gsl gtk guile jack ladspa motif nls opengl oss ruby"
+
+RDEPEND="media-libs/audiofile
+ motif? ( x11-libs/openmotif )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ fam? ( virtual/fam )
+ fftw? ( sci-libs/fftw )
+ gsl? ( >=sci-libs/gsl-0.8 )
+ gtk? ( >=x11-libs/gtk+-2
+ opengl? ( x11-libs/gtkglext )
+ cairo? ( x11-libs/cairo ) )
+ guile? ( >=dev-scheme/guile-1.3.4 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( media-libs/ladspa-sdk )
+ nls? ( sys-devel/gettext )
+ opengl? ( virtual/opengl )
+ ruby? ( virtual/ruby )"
+
+pkg_setup() {
+ if ! use gtk && ! use motif; then
+ ewarn "Warning: no graphic toolkit selected (gtk or motif)."
+ ewarn "Upstream suggests to enable one of the toolkits (or both)"
+ ewarn "or only the command line utilities will be helpful."
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use opengl; then
+ if use guile; then
+ myconf="${myconf} --with-gl"
+ else
+ myconf="${myconf} --with-just-gl"
+ fi
+ else
+ myconf="${myconf} --without-gl"
+ fi
+
+ econf \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with esd) \
+ $(use_with fam) \
+ $(use_with fftw) \
+ $(use_with gsl) \
+ $(use_with gtk) \
+ $(use_with guile) \
+ $(use_with jack) \
+ $(use_with ladspa) \
+ $(use_with motif) \
+ $(use_enable nls) \
+ $(use_with ruby) \
+ $(use_with cairo) \
+ --with-float-samples \
+ ${myconf} || die
+
+ emake snd || die "emake snd failed"
+
+ # compiling command-line programs. See bug #112695
+ # do not compile ruby extensions for command line programs
+ # those fail to compile
+ if use ruby; then
+ econf \
+ $(use_with alsa) \
+ $(use_with esd) \
+ $(use_with fam) \
+ $(use_with fftw) \
+ $(use_with gsl) \
+ $(use_with gtk) \
+ $(use_with guile) \
+ $(use_with jack) \
+ $(use_with ladspa) \
+ $(use_with motif) \
+ $(use_enable nls) \
+ --without-ruby \
+ --with-float-samples \
+ ${myconf} || die
+ fi
+
+ for i in sndrecord sndinfo audinfo sndplay; do
+ emake ${i} || die "make ${i} failed"
+ done
+}
+
+src_install () {
+ dobin snd
+ dobin sndplay
+ dobin sndrecord
+ dobin sndinfo
+ dobin audinfo
+
+ insinto /usr/$(get_libdir)/snd/scheme
+ doins *.scm
+
+ dodoc README.Snd HISTORY.Snd TODO.Snd Snd.ad
+ dohtml -r *.html *.png tutorial
+}