summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-09-22 17:44:09 +0000
committerSteve Dibb <beandog@gentoo.org>2009-09-22 17:44:09 +0000
commit40df08377a94d9d111775f0e04e486f968e0ed9b (patch)
tree3a33d23d6f8cd22e5fba58136e502ce970626d84 /media-sound/shell-fm
parentStable for amd64 per bug #282159 (diff)
downloadgentoo-2-40df08377a94d9d111775f0e04e486f968e0ed9b.tar.gz
gentoo-2-40df08377a94d9d111775f0e04e486f968e0ed9b.tar.bz2
gentoo-2-40df08377a94d9d111775f0e04e486f968e0ed9b.zip
Version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/shell-fm')
-rw-r--r--media-sound/shell-fm/ChangeLog7
-rw-r--r--media-sound/shell-fm/shell-fm-0.7.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/media-sound/shell-fm/ChangeLog b/media-sound/shell-fm/ChangeLog
index 6c8fea2c5ee1..211647eb0443 100644
--- a/media-sound/shell-fm/ChangeLog
+++ b/media-sound/shell-fm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/shell-fm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.10 2009/05/09 14:40:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.11 2009/09/22 17:44:09 beandog Exp $
+
+*shell-fm-0.7 (22 Sep 2009)
+
+ 22 Sep 2009; Steve Dibb <beandog@gentoo.org> +shell-fm-0.7.ebuild:
+ Version bump
09 May 2009; Samuli Suominen <ssuominen@gentoo.org> shell-fm-0.6.ebuild:
Upload tarball instead of using unreliable github address wrt #269125
diff --git a/media-sound/shell-fm/shell-fm-0.7.ebuild b/media-sound/shell-fm/shell-fm-0.7.ebuild
new file mode 100644
index 000000000000..d688a79dc1b6
--- /dev/null
+++ b/media-sound/shell-fm/shell-fm-0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.7.ebuild,v 1.1 2009/09/22 17:44:09 beandog Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="A lightweight console based player for Last.FM radio streams"
+HOMEPAGE="http://nex.scrapping.cc/shell-fm/"
+# I couldn't get constant tarball from github so I've tarballed this myself.
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ao"
+
+RDEPEND="media-libs/libmad
+ ao? ( media-libs/libao )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-apps/sed"
+
+src_prepare() {
+ sed -i -e "s:-Os:${CFLAGS}:g" source/Makefile || die "sed failed"
+ use ao || sed -i -e "s:\$(LIBAO)::g" source/Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin source/${PN} || die "dobin failed"
+ doman manual/${PN}.1
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/{*.sh,*.pl,zcontrol} || die "doexe failed"
+}