summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-11-19 22:22:26 +0000
committerSamuli Suominen <drac@gentoo.org>2007-11-19 22:22:26 +0000
commit264073937a67b3e5bd8186642c031c4007cd5198 (patch)
tree5d2ff3feef5eefd8007937693bf2f5f750e48754 /media-sound/shell-fm
parentAdd a patch to use vncviewer instead of xvncviewer. (diff)
downloadgentoo-2-264073937a67b3e5bd8186642c031c4007cd5198.tar.gz
gentoo-2-264073937a67b3e5bd8186642c031c4007cd5198.tar.bz2
gentoo-2-264073937a67b3e5bd8186642c031c4007cd5198.zip
Version bump for bug 199658, thanks to Thomas M. for reporting.
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-sound/shell-fm')
-rw-r--r--media-sound/shell-fm/ChangeLog7
-rw-r--r--media-sound/shell-fm/files/digest-shell-fm-0.43
-rw-r--r--media-sound/shell-fm/shell-fm-0.4.ebuild35
3 files changed, 44 insertions, 1 deletions
diff --git a/media-sound/shell-fm/ChangeLog b/media-sound/shell-fm/ChangeLog
index 7da003880d95..e1a253b1996d 100644
--- a/media-sound/shell-fm/ChangeLog
+++ b/media-sound/shell-fm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/shell-fm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.6 2007/09/17 20:49:43 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.7 2007/11/19 22:22:25 drac Exp $
+
+*shell-fm-0.4 (19 Nov 2007)
+
+ 19 Nov 2007; Samuli Suominen <drac@gentoo.org> +shell-fm-0.4.ebuild:
+ Version bump for bug 199658, thanks to Thomas M. for reporting.
17 Sep 2007; Samuli Suominen <drac@gentoo.org> metadata.xml:
Add sound as herd.
diff --git a/media-sound/shell-fm/files/digest-shell-fm-0.4 b/media-sound/shell-fm/files/digest-shell-fm-0.4
new file mode 100644
index 000000000000..70cfb6dc585e
--- /dev/null
+++ b/media-sound/shell-fm/files/digest-shell-fm-0.4
@@ -0,0 +1,3 @@
+MD5 665943a38fd16195c092c64e3977eb00 shell-fm-0.4.tar.bz2 63665
+RMD160 59943b8db2c7dc13340b1bfd0a3060e6da99e3da shell-fm-0.4.tar.bz2 63665
+SHA256 f74a0b8b855b80c7e21bbee15ea1c6b81fc1a96bffa23dff160ec0dcadcee736 shell-fm-0.4.tar.bz2 63665
diff --git a/media-sound/shell-fm/shell-fm-0.4.ebuild b/media-sound/shell-fm/shell-fm-0.4.ebuild
new file mode 100644
index 000000000000..d0be24c88d21
--- /dev/null
+++ b/media-sound/shell-fm/shell-fm-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.4.ebuild,v 1.1 2007/11/19 22:22:25 drac Exp $
+
+inherit autotools
+
+DESCRIPTION="A lightweight console based player for Last.FM radio streams."
+HOMEPAGE="http://nex.scrapping.cc/shell-fm"
+SRC_URI="http://nex.scrapping.cc/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ao"
+
+DEPEND="media-libs/libmad
+ ao? ( media-libs/libao )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable ao)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die 'emake install failed'
+ dodoc AUTHORS NEWS TODO shell-fm.rc-example doc/*.txt
+ insinto /usr/share/doc/${PF}/scripts
+ doins scripts/{shell*,zcontrol}
+}