summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-12-27 01:16:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-12-27 01:16:44 +0000
commit8546c187880d60112ec16d28f9a1982bb5a61086 (patch)
tree77bddb23367d41c265c8c46099e12bb8a830affd /media-sound/seq24
parentAdded ~mips, bug 339641 (diff)
downloadgentoo-2-8546c187880d60112ec16d28f9a1982bb5a61086.tar.gz
gentoo-2-8546c187880d60112ec16d28f9a1982bb5a61086.tar.bz2
gentoo-2-8546c187880d60112ec16d28f9a1982bb5a61086.zip
version bump
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/seq24')
-rw-r--r--media-sound/seq24/ChangeLog9
-rw-r--r--media-sound/seq24/seq24-0.9.2.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/media-sound/seq24/ChangeLog b/media-sound/seq24/ChangeLog
index 8a6047ec417a..0fa071215b51 100644
--- a/media-sound/seq24/ChangeLog
+++ b/media-sound/seq24/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/seq24
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/ChangeLog,v 1.39 2009/08/01 06:37:56 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/ChangeLog,v 1.40 2010/12/27 01:16:44 aballier Exp $
+
+*seq24-0.9.2 (27 Dec 2010)
+
+ 27 Dec 2010; Alexis Ballier <aballier@gentoo.org> +seq24-0.9.2.ebuild:
+ version bump
01 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> seq24-0.9.0.ebuild:
Remove USE depend for media-libs/alsa-lib[midi].
diff --git a/media-sound/seq24/seq24-0.9.2.ebuild b/media-sound/seq24/seq24-0.9.2.ebuild
new file mode 100644
index 000000000000..244d3b8d0976
--- /dev/null
+++ b/media-sound/seq24/seq24-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/seq24-0.9.2.ebuild,v 1.1 2010/12/27 01:16:44 aballier Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Seq24 is a loop based MIDI sequencer with focus on live performances."
+HOMEPAGE="https://edge.launchpad.net/seq24/"
+SRC_URI="http://edge.launchpad.net/seq24/trunk/${PV}/+download/${P}.tar.bz2"
+
+IUSE="jack lash"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-libs/alsa-lib
+ >=dev-cpp/gtkmm-2.4
+ >=dev-libs/libsigc++-2.2:2
+ jack? ( >=media-sound/jack-audio-connection-kit-0.90 )
+ lash? ( >=media-sound/lash-0.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable jack) \
+ $(use_enable lash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README RTC SEQ24
+ newicon src/pixmaps/seq24_32.xpm seq24.xpm
+ make_desktop_entry seq24
+}