summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-10-03 09:58:41 +0000
committerPacho Ramos <pacho@gentoo.org>2014-10-03 09:58:41 +0000
commitedaeffaa5351d86d1fa9284987c0302ed5873257 (patch)
tree43f8794f9c5487111f01c6cc26c70589c7a7ee2f /media-sound/rhythmbox
parentSecurity bump (bug #524256). Should fix CVE-2014-6277 (diff)
downloadgentoo-2-edaeffaa5351d86d1fa9284987c0302ed5873257.tar.gz
gentoo-2-edaeffaa5351d86d1fa9284987c0302ed5873257.tar.bz2
gentoo-2-edaeffaa5351d86d1fa9284987c0302ed5873257.zip
Version bump, drop old
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog10
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.12-python-initialization.patch171
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.12.8-libnotify-0.7.patch36
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.12.8-namespace-conflict.patch48
-rw-r--r--media-sound/rhythmbox/rhythmbox-3.1.ebuild (renamed from media-sound/rhythmbox/rhythmbox-3.0.2.ebuild)12
5 files changed, 15 insertions, 262 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index dae2d67d524e..ed7c7d49e2c1 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.261 2014/07/24 18:47:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.262 2014/10/03 09:58:41 pacho Exp $
+
+*rhythmbox-3.1 (03 Oct 2014)
+
+ 03 Oct 2014; Pacho Ramos <pacho@gentoo.org> +rhythmbox-3.1.ebuild,
+ -files/rhythmbox-0.12-python-initialization.patch,
+ -files/rhythmbox-0.12.8-libnotify-0.7.patch,
+ -files/rhythmbox-0.12.8-namespace-conflict.patch, -rhythmbox-3.0.2.ebuild:
+ Version bump, drop old
24 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> rhythmbox-3.0.2.ebuild,
rhythmbox-3.0.3.ebuild:
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.12-python-initialization.patch b/media-sound/rhythmbox/files/rhythmbox-0.12-python-initialization.patch
deleted file mode 100644
index deb34c0469a4..000000000000
--- a/media-sound/rhythmbox/files/rhythmbox-0.12-python-initialization.patch
+++ /dev/null
@@ -1,171 +0,0 @@
-From 4394826f36fad0ad36ea773b6d4525dfcfcd389b Mon Sep 17 00:00:00 2001
-From: Jonathan Matthew <jonathan@d14n.org>
-Date: Wed, 05 May 2010 12:58:26 +0000
-Subject: python: fix a number of python initialization problems (bug #617587)
-
-- pygtk.require("2.8") doesn't work - it's only after a major version,
- so we should pass in "2.0" instead
-- init_pygobject() is deprecated, use pygobject_init (and pass in the
- version we require) instead
-- init_pygtk() is a macro that returns from the current function on
- error, so we need to call it from a separate function for our error
- handling to work
-- if some aspect of python initialization failed, we were still using
- the pygobject GIL macros, which were crashing
----
-diff --git a/shell/main.c b/shell/main.c
-index 1f27fee..a4dd50a 100644
---- a/shell/main.c
-+++ b/shell/main.c
-@@ -35,6 +35,7 @@
- #define NO_IMPORT_PYGOBJECT
- #define NO_IMPORT_PYGTK
- #include <pygobject.h>
-+#include "rb-python-module.h"
-
- /* make sure it's defined somehow */
- #ifndef _XOPEN_SOURCE
-@@ -327,11 +328,15 @@ main (int argc, char **argv)
-
- rb_profile_start ("mainloop");
- #ifdef ENABLE_PYTHON
-- pyg_begin_allow_threads;
--#endif
-+ if (rb_python_init_successful ()) {
-+ pyg_begin_allow_threads;
-+ gtk_main ();
-+ pyg_end_allow_threads;
-+ } else {
-+ gtk_main ();
-+ }
-+#else
- gtk_main ();
--#ifdef ENABLE_PYTHON
-- pyg_end_allow_threads;
- #endif
- rb_profile_end ("mainloop");
-
-diff --git a/shell/rb-python-module.c b/shell/rb-python-module.c
-index 9e14731..1995a42 100644
---- a/shell/rb-python-module.c
-+++ b/shell/rb-python-module.c
-@@ -84,8 +84,16 @@ extern PyMethodDef pyrb_functions[];
- /* We retreive this to check for correct class hierarchy */
- static PyTypeObject *PyRBPlugin_Type;
-
-+static gboolean python_init_successful;
-+
- G_DEFINE_TYPE (RBPythonModule, rb_python_module, G_TYPE_TYPE_MODULE);
-
-+static void
-+actually_init_pygtk (void)
-+{
-+ init_pygtk ();
-+}
-+
- void
- rb_python_module_init_python (void)
- {
-@@ -98,6 +106,7 @@ rb_python_module_init_python (void)
- char *argv[] = { "rb", "rhythmdb", NULL };
- GList *paths;
-
-+ python_init_successful = FALSE;
- if (Py_IsInitialized ()) {
- g_warning ("Python Should only be initialized once, since it's in class_init");
- g_return_if_reached ();
-@@ -130,7 +139,7 @@ rb_python_module_init_python (void)
-
- PySys_SetArgv (1, argv);
-
-- /* pygtk.require("2.8") */
-+ /* pygtk.require("2.0") */
- pygtk = PyImport_ImportModule ("pygtk");
- if (pygtk == NULL) {
- g_warning ("Could not import pygtk");
-@@ -140,11 +149,15 @@ rb_python_module_init_python (void)
-
- mdict = PyModule_GetDict (pygtk);
- require = PyDict_GetItemString (mdict, "require");
-- PyObject_CallObject (require, Py_BuildValue ("(S)", PyString_FromString ("2.8")));
-+ PyObject_CallObject (require, Py_BuildValue ("(S)", PyString_FromString ("2.0")));
-+ if (PyErr_Occurred ()) {
-+ g_warning ("pygtk.require(2.0) failed");
-+ PyErr_Print();
-+ return;
-+ }
-
- /* import gobject */
-- init_pygobject ();
-- if (PyErr_Occurred ()) {
-+ if (pygobject_init (2, 16, 0) == NULL) {
- g_warning ("Could not initialize pygobject");
- PyErr_Print();
- return;
-@@ -154,7 +167,7 @@ rb_python_module_init_python (void)
- pyg_disable_warning_redirections ();
-
- /* import gtk */
-- init_pygtk ();
-+ actually_init_pygtk ();
- if (PyErr_Occurred ()) {
- g_warning ("Could not initialize pygtk");
- PyErr_Print();
-@@ -172,7 +185,7 @@ rb_python_module_init_python (void)
-
- mdict = PyModule_GetDict (gtk);
- pygtk_version = PyDict_GetItemString (mdict, "pygtk_version");
-- pygtk_required_version = Py_BuildValue ("(iii)", 2, 4, 0);
-+ pygtk_required_version = Py_BuildValue ("(iii)", 2, 8, 0);
- if (PyObject_Compare (pygtk_version, pygtk_required_version) == -1) {
- g_warning("PyGTK %s required, but %s found.",
- PyString_AsString (PyObject_Repr (pygtk_required_version)),
-@@ -264,6 +277,8 @@ rb_python_module_init_python (void)
- gettext_args = Py_BuildValue ("ss", GETTEXT_PACKAGE, GNOMELOCALEDIR);
- PyObject_CallObject (install, gettext_args);
- Py_DECREF (gettext_args);
-+
-+ python_init_successful = TRUE;
- }
-
- static gboolean
-@@ -329,6 +344,11 @@ rb_python_module_load_with_gil (GTypeModule *module)
- PyGILState_STATE state;
- gboolean ret;
-
-+ if (python_init_successful == FALSE) {
-+ g_warning ("unable to load module as python runtime could not be initialized");
-+ return FALSE;
-+ }
-+
- state = pyg_gil_state_ensure ();
- ret = rb_python_module_load (module);
- pyg_gil_state_release (state);
-@@ -485,6 +505,12 @@ rb_python_module_new (const gchar *path,
- return result;
- }
-
-+gboolean
-+rb_python_init_successful (void)
-+{
-+ return python_init_successful;
-+}
-+
- /* --- these are not module methods, they are here out of convenience --- */
-
- #if 0
-diff --git a/shell/rb-python-module.h b/shell/rb-python-module.h
-index 5b2c152..30c1200 100644
---- a/shell/rb-python-module.h
-+++ b/shell/rb-python-module.h
-@@ -60,6 +60,8 @@ GObject *rb_python_module_new_object (RBPythonModule *module);
-
- void rb_python_module_init_python (void);
-
-+gboolean rb_python_init_successful (void);
-+
- void rb_python_garbage_collect (void);
-
- void rb_python_shutdown (void);
---
-cgit v0.8.3.1
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.12.8-libnotify-0.7.patch b/media-sound/rhythmbox/files/rhythmbox-0.12.8-libnotify-0.7.patch
deleted file mode 100644
index c7c0f4af2cba..000000000000
--- a/media-sound/rhythmbox/files/rhythmbox-0.12.8-libnotify-0.7.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- plugins/status-icon/rb-status-icon-plugin.c
-+++ plugins/status-icon/rb-status-icon-plugin.c
-@@ -394,8 +394,15 @@
- icon_name = NULL;
-
- if (plugin->priv->notification == NULL) {
-+ #ifdef NOTIFY_CHECK_VERSION
-+ #if NOTIFY_CHECK_VERSION (0, 7, 1)
-+ plugin->priv->notification = notify_notification_new (primary, secondary, icon_name);
-+ #else
- plugin->priv->notification = notify_notification_new (primary, secondary, icon_name, NULL);
--
-+ #endif
-+ #else
-+ plugin->priv->notification = notify_notification_new (primary, secondary, icon_name, NULL);
-+ #endif
- g_signal_connect_object (plugin->priv->notification,
- "closed",
- G_CALLBACK (notification_closed_cb),
---- plugins/status-icon/rb-tray-icon-gtk.c
-+++ plugins/status-icon/rb-tray-icon-gtk.c
-@@ -343,7 +343,13 @@
- void
- rb_tray_icon_attach_notification (RBTrayIcon *tray, NotifyNotification *notification)
- {
-+ #ifndef NOTIFY_CHECK_VERSION
- notify_notification_attach_to_status_icon (notification, tray->priv->icon);
-+ #else
-+ #if !NOTIFY_CHECK_VERSION (0, 7, 1)
-+ notify_notification_attach_to_status_icon (notification, tray->priv->icon);
-+ #endif
-+ #endif
- }
- #endif
-
-
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.12.8-namespace-conflict.patch b/media-sound/rhythmbox/files/rhythmbox-0.12.8-namespace-conflict.patch
deleted file mode 100644
index b32614e2030b..000000000000
--- a/media-sound/rhythmbox/files/rhythmbox-0.12.8-namespace-conflict.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From bd389d8e8a2b1f3a914dcd4bb17e75fb8837d78a Mon Sep 17 00:00:00 2001
-From: Jonathan Matthew <jonathan@d14n.org>
-Date: Tue, 01 Jun 2010 00:55:27 +0000
-Subject: rb-client: rename 'pause' to avoid conflict with pause(2) (bug #620199)
-
----
-diff --git a/remote/dbus/rb-client.c b/remote/dbus/rb-client.c
-index 648dd2f..5bb34a2 100644
---- a/remote/dbus/rb-client.c
-+++ b/remote/dbus/rb-client.c
-@@ -54,7 +54,7 @@ static gboolean previous = FALSE;
- static gboolean notify = FALSE;
-
- static gboolean play = FALSE;
--static gboolean pause = FALSE;
-+static gboolean do_pause = FALSE;
- static gboolean play_pause = FALSE;
- static gboolean stop = FALSE;
-
-@@ -91,7 +91,7 @@ static GOptionEntry args[] = {
- { "notify", 0, 0, G_OPTION_ARG_NONE, &notify, N_("Show notification of the playing song"), NULL },
-
- { "play", 0, 0, G_OPTION_ARG_NONE, &play, N_("Resume playback if currently paused"), NULL },
-- { "pause", 0, 0, G_OPTION_ARG_NONE, &pause, N_("Pause playback if currently playing"), NULL },
-+ { "pause", 0, 0, G_OPTION_ARG_NONE, &do_pause, N_("Pause playback if currently playing"), NULL },
- { "play-pause", 0, 0, G_OPTION_ARG_NONE, &play_pause, N_("Toggle play/pause mode"), NULL },
- /* { "stop", 0, 0, G_OPTION_ARG_NONE, &stop, N_("Stop playback"), NULL }, */
-
-@@ -608,7 +608,7 @@ main (int argc, char **argv)
- if (next || previous ||
- clear_queue ||
- play_uri || other_stuff ||
-- play || pause || play_pause || stop ||
-+ play || do_pause || play_pause || stop ||
- print_playing || print_playing_format || notify ||
- (set_volume > -0.01) || volume_up || volume_down || print_volume || mute || unmute || (set_rating > -0.01))
- no_present = TRUE;
-@@ -696,7 +696,7 @@ main (int argc, char **argv)
- org_gnome_Rhythmbox_Player_get_playing (player_proxy, &is_playing, &error);
- if (!annoy (&error)) {
- rb_debug ("playback state: %d", is_playing);
-- if (play || pause || play_pause) {
-+ if (play || do_pause || play_pause) {
- if (is_playing != play || play_pause) {
- rb_debug ("calling playPause to change playback state");
- org_gnome_Rhythmbox_Player_play_pause (player_proxy, FALSE, &error);
---
-cgit v0.8.3.1
diff --git a/media-sound/rhythmbox/rhythmbox-3.0.2.ebuild b/media-sound/rhythmbox/rhythmbox-3.1.ebuild
index cb5bb1de28c7..5cd3a8e15c8c 100644
--- a/media-sound/rhythmbox/rhythmbox-3.0.2.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-3.0.2.ebuild,v 1.4 2014/07/24 18:47:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-3.1.ebuild,v 1.1 2014/10/03 09:58:41 pacho Exp $
EAPI="5"
GNOME2_LA_PUNT="yes"
@@ -21,7 +21,7 @@ test +udev upnp-av visualizer webkit zeitgeist"
# Let people emerge this by default, bug #472932
IUSE+=" python_single_target_python3_2 +python_single_target_python3_3"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
REQUIRED_USE="
ipod? ( udev )
@@ -57,7 +57,7 @@ COMMON_DEPEND="
daap? (
>=net-libs/libdmapsharing-2.9.19:3.0
media-plugins/gst-plugins-soup:1.0 )
- libsecret? ( >=app-crypt/libsecret-0.14 )
+ libsecret? ( >=app-crypt/libsecret-0.18 )
html? ( >=net-libs/webkit-gtk-1.10:3 )
libnotify? ( >=x11-libs/libnotify-0.7.0 )
lirc? ( app-misc/lirc )
@@ -86,7 +86,7 @@ RDEPEND="${COMMON_DEPEND}
x11-libs/pango[introspection]
dbus? ( sys-apps/dbus )
- libsecret? ( >=app-crypt/libsecret-0.14[introspection] )
+ libsecret? ( >=app-crypt/libsecret-0.18[introspection] )
webkit? (
dev-python/mako[${PYTHON_USEDEP}]
>=net-libs/webkit-gtk-1.10:3[introspection] ) )
@@ -108,7 +108,7 @@ src_prepare() {
DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
MAINTAINERS MAINTAINERS.old NEWS README THANKS"
- rm -v lib/rb-marshal.{c,h} || die
+ rm -v lib/rb-marshal.{c,h} || die # upstream bug 737831
gnome2_src_prepare
}
@@ -145,5 +145,5 @@ src_configure() {
src_test() {
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
- Xemake check || die "test failed"
+ Xemake check
}