summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2006-06-02 19:52:36 +0000
committerJoe McCann <joem@gentoo.org>2006-06-02 19:52:36 +0000
commitb049f3124883e075ca5171b22de10095238ac5cc (patch)
treebb138836e876cc7ba1364a8f21744f722d1b0f8c /media-sound/rhythmbox
parentversion bump (diff)
downloadgentoo-2-b049f3124883e075ca5171b22de10095238ac5cc.tar.gz
gentoo-2-b049f3124883e075ca5171b22de10095238ac5cc.tar.bz2
gentoo-2-b049f3124883e075ca5171b22de10095238ac5cc.zip
New bugfix release, update python use deps, only support gstreamer-0.10 as it is prefered by upstream and gst-0.8 is depreciated by gstreamer upstream
(Portage version: 2.1_rc3-r5)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog11
-rw-r--r--media-sound/rhythmbox/files/digest-rhythmbox-0.9.4.13
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.9.4_p1-libnotify.patch2
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.9.4.1.ebuild102
4 files changed, 116 insertions, 2 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index b7767bc46988..048fdff3d7c9 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.72 2006/05/17 03:07:41 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.73 2006/06/02 19:52:36 joem Exp $
+
+*rhythmbox-0.9.4.1 (02 Jun 2006)
+
+ 02 Jun 2006; Joe McCann <joem@gentoo.org>
+ files/rhythmbox-0.9.4_p1-libnotify.patch, -rhythmbox-0.9.2.ebuild,
+ -rhythmbox-0.9.3.1.ebuild, -rhythmbox-0.9.3.1_p1.ebuild,
+ +rhythmbox-0.9.4.1.ebuild:
+ New bugfix release, update python use deps, only support gstreamer-0.10 as
+ it is prefered by upstream and gst-0.8 is depreciated by gstreamer upstream
17 May 2006; Daniel Gryniewicz <dang@gentoo.org>
+files/rhythmbox-0.9.4_p1-libnotify.patch, rhythmbox-0.9.4_p1.ebuild:
diff --git a/media-sound/rhythmbox/files/digest-rhythmbox-0.9.4.1 b/media-sound/rhythmbox/files/digest-rhythmbox-0.9.4.1
new file mode 100644
index 000000000000..c2a29f9daff2
--- /dev/null
+++ b/media-sound/rhythmbox/files/digest-rhythmbox-0.9.4.1
@@ -0,0 +1,3 @@
+MD5 d725eb7134d1997efe28285715ebc05e rhythmbox-0.9.4.1.tar.bz2 2155482
+RMD160 5ce11aeae6631650cc4edfdbf46a7a13162d246f rhythmbox-0.9.4.1.tar.bz2 2155482
+SHA256 2d2305d575c7cc3a366ea9075efcb23b215da49b82b5b81ad3f8649a6cca80f6 rhythmbox-0.9.4.1.tar.bz2 2155482
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.9.4_p1-libnotify.patch b/media-sound/rhythmbox/files/rhythmbox-0.9.4_p1-libnotify.patch
index 23803551c0ad..2601fdd90a58 100644
--- a/media-sound/rhythmbox/files/rhythmbox-0.9.4_p1-libnotify.patch
+++ b/media-sound/rhythmbox/files/rhythmbox-0.9.4_p1-libnotify.patch
@@ -1,6 +1,6 @@
--- rhythmbox-0.9.4-old/widgets/eggtrayicon.c 2006-04-29 19:37:20.000000000 +0100
+++ rhythmbox-0.9.4/widgets/eggtrayicon.c 2006-04-29 19:11:50.000000000 +0100
-@@ -571,7 +571,7 @@
+@@ -574,7 +574,7 @@
if (pixbuf)
{
diff --git a/media-sound/rhythmbox/rhythmbox-0.9.4.1.ebuild b/media-sound/rhythmbox/rhythmbox-0.9.4.1.ebuild
new file mode 100644
index 000000000000..0993066351e3
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.9.4.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.4.1.ebuild,v 1.1 2006/06/02 19:52:36 joem Exp $
+
+inherit gnome2 eutils
+
+MY_P="${P%%_*}"
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="http://www.rhythmbox.org/"
+SRC_URI="http://ftp.gnome.org/pub/gnome/sources/rhythmbox/0.9/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+RESTRICT=nomirror
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="vorbis flac aac mad ipod avahi howl daap dbus libnotify musicbrainz
+tagwriting python"
+#I want tagwriting to be on by default in the future. It is just a local flag
+#now because it is still considered experimental by upstream and doesn't work
+#well with all formats
+
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.5.4
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-vfs-2.7.4
+ >=gnome-base/libbonobo-2
+ >=gnome-extra/nautilus-cd-burner-2.9.0
+ >=media-video/totem-1.1.5
+ musicbrainz? ( >=media-libs/musicbrainz-2.1 )
+ >=net-libs/libsoup-2.2
+ ipod? ( >=media-libs/libgpod-0.2.0
+ >=sys-apps/hal-0.5 )
+ avahi? ( >=net-dns/avahi-0.6 )
+ !avahi? ( howl? ( >=net-misc/howl-0.9.8 ) )
+ dbus? ( >=sys-apps/dbus-0.35 )
+ >=media-libs/gst-plugins-base-0.10
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10
+ >=media-plugins/gst-plugins-ogg-0.10 )
+ mad? ( >=media-plugins/gst-plugins-mad-0.10 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10 )
+ aac? ( >=media-plugins/gst-plugins-faad-0.10 )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ python? ( >=dev-lang/python-2.4.2
+ >=dev-python/pygtk-2.6 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ app-text/scrollkeeper"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+
+ if ! use avahi && ! use howl; then
+ if use daap ; then
+ ewarn "Daap support requires either howl or avahi"
+ ewarn "to be installed. Please remerge with either"
+ ewarn "USE=avahi or USE=howl"
+ fi
+ fi
+ if use howl || use avahi ; then
+ G2CONF="${G2CONF} $(use_enable daap)"
+ fi
+
+ if use howl ; then
+ G2CONF="${G2CONF} --with-mdns=howl"
+ fi
+
+ if use avahi ; then
+ G2CONF="${G2CONF} --with-mdns=avahi"
+ fi
+
+ G2CONF="${G2CONF} \
+ $(use_enable tagwriting tag-writing) \
+ $(use_enable ipod) \
+ $(use_enable musicbrainz) \
+ $(use_with dbus) \
+ $(use_enable python) \
+ $(use_enable libnotify) \
+ --with-playback=gstreamer-0-10 \
+ --enable-mmkeys \
+ --enable-audioscrobbler \
+ --with-metadata-helper \
+ --disable-schemas-install"
+
+DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \
+ MAINTAINERS NEWS README README.iPod THANKS TODO"
+
+export GST_INSPECT=/bin/true
+USE_DESTDIR=1
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/rhythmbox-0.9.4_p1-libnotify.patch
+ }