summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-04-12 19:13:50 +0000
committerRémi Cardona <remi@gentoo.org>2008-04-12 19:13:50 +0000
commit6e9c02bf1d46a330aaed994a3529b7fbc416ffc2 (patch)
treebb0e351a22af27ebe2654f8ac55c79edbecfae5b /media-sound/rhythmbox
parentppc stable, bug #216265 (diff)
downloadgentoo-2-6e9c02bf1d46a330aaed994a3529b7fbc416ffc2.tar.gz
gentoo-2-6e9c02bf1d46a330aaed994a3529b7fbc416ffc2.tar.bz2
gentoo-2-6e9c02bf1d46a330aaed994a3529b7fbc416ffc2.zip
media-sound/rhythmbox: fix build when USE='doc python', fixes bug #215454
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog6
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.11.5-fix_gtk_doc.patch61
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.11.5.ebuild8
3 files changed, 72 insertions, 3 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 638baa38a47a..bd3766c4ff26 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.118 2008/03/27 00:17:18 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.119 2008/04/12 19:13:50 remi Exp $
+
+ 12 Apr 2008; Rémi Cardona <remi@gentoo.org>
+ +files/rhythmbox-0.11.5-fix_gtk_doc.patch, rhythmbox-0.11.5.ebuild:
+ fix build when USE='doc python', fixes bug #215454
*rhythmbox-0.11.5 (27 Mar 2008)
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.11.5-fix_gtk_doc.patch b/media-sound/rhythmbox/files/rhythmbox-0.11.5-fix_gtk_doc.patch
new file mode 100644
index 000000000000..419a5c3f4ded
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.11.5-fix_gtk_doc.patch
@@ -0,0 +1,61 @@
+Index: doc/reference/Makefile.am
+===================================================================
+--- doc/reference/Makefile.am (revision 5621)
++++ doc/reference/Makefile.am (revision 5622)
+@@ -39,17 +39,23 @@
+ $(IPOD_CFLAGS) \
+ $(RHYTHMBOX_CFLAGS)
+
++if ENABLE_PYTHON
++BINDING_LIBS = $(top_builddir)/bindings/python/rb.la
++MORE_GTKDOC_LIBS = $(PYTHON_LIBS)
++endif
++
+ GTKDOC_LIBS=\
+ $(top_builddir)/shell/librbshell.la \
+ $(top_builddir)/sources/libsources.la \
+ $(top_builddir)/sources/libsourcesimpl.la \
+- $(top_builddir)/rhythmdb/librhythmdb.la \
+ $(top_builddir)/podcast/librbpodcast.la \
+ $(top_builddir)/metadata/librbmetadata.la \
+ $(top_builddir)/widgets/librbwidgets.la \
+- $(top_builddir)/lib/librb.la \
+ $(top_builddir)/plugins/librbplugins.la \
++ $(BINDING_LIBS) \
++ $(top_builddir)/rhythmdb/librhythmdb.la \
+ $(top_builddir)/backends/librbbackends.la \
++ $(top_builddir)/lib/librb.la \
+ $(TOTEM_PLPARSER_LIBS) \
+ $(HAL_LIBS) \
+ $(LIBNAUTILUS_BURN_LIBS) \
+@@ -58,15 +64,13 @@
+ $(MDNS_LIBS) \
+ $(IPOD_LIBS) \
+ $(NOTIFY_LIBS) \
+- $(RHYTHMBOX_LIBS)
++ $(RHYTHMBOX_LIBS) \
++ $(MORE_GTKDOC_LIBS)
+
+ if ENABLE_TRACK_TRANSFER
+ GTKDOC_LIBS += $(GNOME_MEDIA_PROFILES_LIBS)
+ endif
+
+-if ENABLE_PYTHON
+-GTKDOC_LIBS += $(PYTHON_LIBS) $(top_builddir)/bindings/python/rb.la
+-endif
+
+ content_files =
+ HTML_IMAGES =
+Index: ChangeLog
+===================================================================
+--- ChangeLog (revision 5621)
++++ ChangeLog (revision 5622)
+@@ -1,3 +1,8 @@
++2008-03-17 Jonathan Matthew <jonathan@d14n.org>
++
++ * doc/reference/Makefile.am:
++ Fix gtk-doc build (I hate link order problems), #522821.
++
+ ============ Version 0.11.5
+
+ 2008-03-17 James Livingston <doclivingston@gmail.com>
diff --git a/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild b/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild
index 3aa1afc0db9d..1a9ae953a5bb 100644
--- a/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild,v 1.1 2008/03/27 00:17:18 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.11.5.ebuild,v 1.2 2008/04/12 19:13:50 remi Exp $
EAPI="1"
-inherit gnome2 eutils python
+inherit gnome2 eutils python autotools
DESCRIPTION="Music management and playback software for GNOME"
HOMEPAGE="http://www.rhythmbox.org/"
@@ -104,6 +104,10 @@ pkg_setup() {
src_unpack() {
gnome2_src_unpack
+ # backport from svn HEAD, 0.11.6 shouldn't need it
+ epatch "${FILESDIR}/${PN}-0.11.5-fix_gtk_doc.patch"
+ eautomake
+
# disable pyc compiling
mv py-compile py-compile.orig
ln -s $(type -P true) py-compile