summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-15 18:11:56 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-15 18:11:56 +0000
commit550ff64a6b97ef5c07a2c725ac3bf99753c25bb0 (patch)
treeef7a89c9957e55660fc869d30485b2a754df22d8 /media-sound/rhythmbox
parentadded s390 to keywords (Manifest recommit) (diff)
downloadgentoo-2-550ff64a6b97ef5c07a2c725ac3bf99753c25bb0.tar.gz
gentoo-2-550ff64a6b97ef5c07a2c725ac3bf99753c25bb0.tar.bz2
gentoo-2-550ff64a6b97ef5c07a2c725ac3bf99753c25bb0.zip
Filter out -ffast-math. Closes bug #47183.
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog6
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild12
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.6.8.ebuild9
3 files changed, 21 insertions, 6 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 0139837de97a..a0ea11a730eb 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.36 2004/04/03 00:54:49 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.37 2004/04/15 18:11:56 eradicator Exp $
+
+ 15 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ rhythmbox-0.6.1-r1.ebuild, rhythmbox-0.6.8.ebuild:
+ Filter out -ffast-math. Closes bug #47183.
03 Apr 2004; foser <foser@gentoo.org> rhythmbox-0.6.{1,8}.ebuild :
Fix gst deps
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
index 633decf2499e..58afd52f657f 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild,v 1.4 2004/04/03 00:54:49 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.1-r1.ebuild,v 1.5 2004/04/15 18:11:56 eradicator Exp $
-inherit gnome2
+inherit gnome2 flag-o-matic
DESCRIPTION="Music management and playback software for GNOME"
HOMEPAGE="http://web.rhythmbox.org/"
@@ -52,7 +52,6 @@ G2CONF="${G2CONF} \
--disable-schemas-install"
src_unpack( ) {
-
unpack ${A}
cd ${S}
@@ -65,3 +64,10 @@ DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \
MAINTAINERS NEWS README THANKS TODO"
export GST_INSPECT=/bin/true
+
+src_compile() {
+ filter-flags "-ffast-math"
+ gnome2_src_compile
+}
+
+
diff --git a/media-sound/rhythmbox/rhythmbox-0.6.8.ebuild b/media-sound/rhythmbox/rhythmbox-0.6.8.ebuild
index f806821c4ad0..d7c1dc1e4acf 100644
--- a/media-sound/rhythmbox/rhythmbox-0.6.8.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.6.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.8.ebuild,v 1.5 2004/04/03 00:54:49 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.6.8.ebuild,v 1.6 2004/04/15 18:11:56 eradicator Exp $
-inherit gnome2
+inherit gnome2 flag-o-matic
DESCRIPTION="Music management and playback software for GNOME"
HOMEPAGE="http://web.rhythmbox.org/"
@@ -82,6 +82,11 @@ DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \
export GST_INSPECT=/bin/true
+src_compile() {
+ filter-flags "-ffast-math"
+ gnome2_src_compile
+}
+
src_install() {
gnome2_src_install
insinto /etc/gconf/schemas