summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-01-06 13:01:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-01-06 13:01:22 +0000
commit212cae0759e90cc47602df927e86cd3652c59e29 (patch)
tree4bf38320eb02b092f03e43e50c04236e82d378a9 /media-sound/qtractor
parentStable for AMD64, wrt bug #397125 (diff)
downloadgentoo-2-212cae0759e90cc47602df927e86cd3652c59e29.tar.gz
gentoo-2-212cae0759e90cc47602df927e86cd3652c59e29.tar.bz2
gentoo-2-212cae0759e90cc47602df927e86cd3652c59e29.zip
version bump, use lilv instead of slv2 for lv2 plugins, slv2 will be deprecated at some point and lilv is smaller and faster, migrate to qt4-r2
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qtractor')
-rw-r--r--media-sound/qtractor/ChangeLog10
-rw-r--r--media-sound/qtractor/qtractor-0.5.3.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/media-sound/qtractor/ChangeLog b/media-sound/qtractor/ChangeLog
index e0ea5870d72d..202bffbab00a 100644
--- a/media-sound/qtractor/ChangeLog
+++ b/media-sound/qtractor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/qtractor
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qtractor/ChangeLog,v 1.37 2011/12/18 14:52:37 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtractor/ChangeLog,v 1.38 2012/01/06 13:01:22 aballier Exp $
+
+*qtractor-0.5.3 (06 Jan 2012)
+
+ 06 Jan 2012; Alexis Ballier <aballier@gentoo.org> +qtractor-0.5.3.ebuild:
+ version bump, use lilv instead of slv2 for lv2 plugins, slv2 will be
+ deprecated at some point and lilv is smaller and faster, migrate to qt4-r2
*qtractor-0.5.2 (18 Dec 2011)
diff --git a/media-sound/qtractor/qtractor-0.5.3.ebuild b/media-sound/qtractor/qtractor-0.5.3.ebuild
new file mode 100644
index 000000000000..dfc2e31a13f0
--- /dev/null
+++ b/media-sound/qtractor/qtractor-0.5.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qtractor/qtractor-0.5.3.ebuild,v 1.1 2012/01/06 13:01:22 aballier Exp $
+
+EAPI=2
+
+inherit qt4-r2 flag-o-matic
+
+DESCRIPTION="Qtractor is an Audio/MIDI multi-track sequencer."
+HOMEPAGE="http://qtractor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qtractor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="debug dssi libsamplerate mad osc rubberband vorbis sse zlib"
+
+RDEPEND=">=x11-libs/qt-core-4.2:4
+ || (
+ >=x11-libs/qt-gui-4.7:4[gtkstyle]
+ <x11-libs/qt-gui-4.7:4[gtk]
+ )
+ media-libs/alsa-lib
+ media-libs/libsndfile
+ media-sound/jack-audio-connection-kit
+ media-libs/ladspa-sdk
+ dssi? ( media-libs/dssi )
+ mad? ( media-libs/libmad )
+ libsamplerate? ( media-libs/libsamplerate )
+ media-libs/lilv
+ osc? ( media-libs/liblo )
+ rubberband? ( media-libs/rubberband )
+ vorbis? ( media-libs/libvorbis )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="README ChangeLog TODO AUTHORS"
+
+src_configure() {
+ append-flags "-DQT_STYLE_GTK"
+ econf \
+ $(use_enable mad libmad) \
+ $(use_enable libsamplerate) \
+ $(use_enable vorbis libvorbis) \
+ $(use_enable osc liblo) \
+ --enable-ladspa \
+ $(use_enable dssi) \
+ --enable-lilv \
+ $(use_enable rubberband librubberband) \
+ $(use_enable sse) \
+ $(use_enable zlib libz) \
+ $(use_enable debug)
+ eqmake4 qtractor.pro -o qtractor.mak
+}