summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-11 17:20:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-11 17:20:53 +0000
commit82ef1522c9b605ce1595af8195cc7dd469981610 (patch)
treea7856c9b6cfafa48289f41e993943cd269d4aae5 /media-sound/qsynth
parentremove old/broken openssl-blacklist versions (diff)
downloadgentoo-2-82ef1522c9b605ce1595af8195cc7dd469981610.tar.gz
gentoo-2-82ef1522c9b605ce1595af8195cc7dd469981610.tar.bz2
gentoo-2-82ef1522c9b605ce1595af8195cc7dd469981610.zip
version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'media-sound/qsynth')
-rw-r--r--media-sound/qsynth/ChangeLog7
-rw-r--r--media-sound/qsynth/qsynth-0.3.3.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/media-sound/qsynth/ChangeLog b/media-sound/qsynth/ChangeLog
index 2fb462b1a78c..902fbbc00760 100644
--- a/media-sound/qsynth/ChangeLog
+++ b/media-sound/qsynth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qsynth
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.40 2008/04/28 18:07:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.41 2008/07/11 17:20:53 aballier Exp $
+
+*qsynth-0.3.3 (11 Jul 2008)
+
+ 11 Jul 2008; Alexis Ballier <aballier@gentoo.org> +qsynth-0.3.3.ebuild:
+ version bump
28 Apr 2008; Raúl Porcel <armin76@gentoo.org> qsynth-0.3.2.ebuild:
sparc stable wrt #217727
diff --git a/media-sound/qsynth/qsynth-0.3.3.ebuild b/media-sound/qsynth/qsynth-0.3.3.ebuild
new file mode 100644
index 000000000000..63b27053ce28
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.3.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.3.ebuild,v 1.1 2008/07/11 17:20:53 aballier Exp $
+
+EAPI=1
+
+inherit qt4 eutils flag-o-matic
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="debug jack alsa"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="
+ || ( (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ ) >=x11-libs/qt-4.2:4 )
+ >=media-sound/fluidsynth-1.0.7a"
+
+pkg_setup() {
+ if use jack; then
+ if ! built_with_use media-sound/fluidsynth jack; then
+ eerror "To use Qsynth with JACK, you need to build media-sound/fluidsynth"
+ eerror "with the jack USE flag enabled."
+ die "Missing jack USE flag on media-sound/fluidsynth"
+ fi
+ einfo "Enabling default JACK output."
+ elif use alsa; then
+ if ! built_with_use media-sound/fluidsynth alsa; then
+ eerror "To use Qsynth with ALSA, you need to build media-sound/fluidsynth"
+ eerror "with the alsa USE flag enabled."
+ die "Missing alsa USE flag on media-sound/fluidsynth"
+ fi
+ einfo "Enabling non-default ALSA output."
+ else
+ if ! built_with_use media-sound/fluidsynth oss; then
+ eerror "If you don't want to use either JACK or ALSA on Qsynth"
+ eerror "you need to enable the oss USE flag on media-sound/fluidsynth"
+ die "Missing oss USE flag on media-sound/fluidsynth"
+ fi
+ einfo "Enabling non-default OSS output."
+ fi
+}
+
+src_compile() {
+ # Stupidly, qsynth's configure does *not* use pkg-config to
+ # discover the presence of Qt4, but uses fixed paths; as they
+ # don't really work that well for our case, let's just use this
+ # nasty hack and be done with it. *NOTE*: this hinders
+ # cross-compile.
+ append-flags -I/usr/include/qt4
+ append-ldflags -L/usr/$(get_libdir)/qt4
+
+ econf \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm -rf "${D}/usr/share/applications/qsynth.desktop"
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}