summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-06-15 19:14:44 +0000
committerChristoph Mende <angelos@gentoo.org>2011-06-15 19:14:44 +0000
commit1671f6e8e1b522ece864aba0c4ffcdc3d2d594c1 (patch)
tree5f81f68496984b8fb3300dfe7f39748cfcae8cfc /media-sound/qmpdclient/qmpdclient-1.2.2.ebuild
parentRetire gpixpod for bugs 221277 and 351307. (diff)
downloadgentoo-2-1671f6e8e1b522ece864aba0c4ffcdc3d2d594c1.tar.gz
gentoo-2-1671f6e8e1b522ece864aba0c4ffcdc3d2d594c1.tar.bz2
gentoo-2-1671f6e8e1b522ece864aba0c4ffcdc3d2d594c1.zip
Version bump
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qmpdclient/qmpdclient-1.2.2.ebuild')
-rw-r--r--media-sound/qmpdclient/qmpdclient-1.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/qmpdclient/qmpdclient-1.2.2.ebuild b/media-sound/qmpdclient/qmpdclient-1.2.2.ebuild
new file mode 100644
index 000000000000..97f3b9fdaaea
--- /dev/null
+++ b/media-sound/qmpdclient/qmpdclient-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.2.2.ebuild,v 1.1 2011/06/15 19:14:44 angelos Exp $
+
+EAPI=4
+inherit fdo-mime cmake-utils
+
+DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
+HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
+SRC_URI="http://dump.bitcheese.net/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-webkit:4
+ x11-libs/qt-xmlpatterns:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS README THANKSTO )
+
+src_prepare() {
+ sed -i -e "/^Categories/s/Network/AudioVideo/" ${PN}.desktop || die
+}
+
+src_configure() {
+ local mycmakeargs=( "-DVERSION=${PV}" )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }