summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-10-08 11:28:50 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-10-08 11:28:50 +0000
commit8080e881edf5a264e4c535192f55125e07b05e1d (patch)
tree3f7da3df069d0cbae3dd9bfc5d5282cb8b432fde /media-sound/pulseaudio
parentamd64 stable wrt #385915 (diff)
downloadgentoo-2-8080e881edf5a264e4c535192f55125e07b05e1d.tar.gz
gentoo-2-8080e881edf5a264e4c535192f55125e07b05e1d.tar.bz2
gentoo-2-8080e881edf5a264e4c535192f55125e07b05e1d.zip
Add a patch to revert to a 3-number versioning system. Fixes pre-1.0 32-bit libpulse compatibility and phonon build.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/pulseaudio')
-rw-r--r--media-sound/pulseaudio/ChangeLog9
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-1.0-version-fix.patch47
-rw-r--r--media-sound/pulseaudio/pulseaudio-1.0-r2.ebuild210
3 files changed, 265 insertions, 1 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index e0afa115d398..a2ef8ac701ea 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.249 2011/09/28 14:31:56 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.250 2011/10/08 11:28:50 ford_prefect Exp $
+
+*pulseaudio-1.0-r2 (08 Oct 2011)
+
+ 08 Oct 2011; Arun Raghavan <ford_prefect@gentoo.org>
+ +pulseaudio-1.0-r2.ebuild, +files/pulseaudio-1.0-version-fix.patch:
+ Add a patch to revert to a 3-number versioning system. Fixes pre-1.0 32-bit
+ libpulse compatibility and phonon build.
*pulseaudio-1.0-r1 (28 Sep 2011)
diff --git a/media-sound/pulseaudio/files/pulseaudio-1.0-version-fix.patch b/media-sound/pulseaudio/files/pulseaudio-1.0-version-fix.patch
new file mode 100644
index 000000000000..13378db01851
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-1.0-version-fix.patch
@@ -0,0 +1,47 @@
+From 7563e0bbb54fbac54e77f3a62d9761a70f3a559c Mon Sep 17 00:00:00 2001
+From: Colin Guthrie <colin@mageia.org>
+Date: Sat, 1 Oct 2011 12:03:44 +0100
+Subject: [PATCH] libpulse: Always return a three part version number in API
+ calls.
+
+For both the headers and the library we should provide clean, three part
+strings as this has been what we've previously done in the past
+and some external systems apparently rely on this format. While it's not
+something we've officially commented on before, there is no real advantage
+to us to change it so let's not try to tidy things up too much
+considering some third party apps (e.g. Skype) seem to dislike a two
+part version string.
+---
+ src/pulse/context.c | 2 +-
+ src/pulse/version.h.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/pulse/context.c b/src/pulse/context.c
+index 25d04a1..af144aa 100644
+--- a/src/pulse/context.c
++++ b/src/pulse/context.c
+@@ -1281,7 +1281,7 @@ pa_operation* pa_context_set_name(pa_context *c, const char *name, pa_context_su
+ }
+
+ const char* pa_get_library_version(void) {
+- return PACKAGE_VERSION;
++ return pa_get_headers_version();
+ }
+
+ const char* pa_context_get_server(pa_context *c) {
+diff --git a/src/pulse/version.h.in b/src/pulse/version.h.in
+index 7e00c5e..1be4c75 100644
+--- a/src/pulse/version.h.in
++++ b/src/pulse/version.h.in
+@@ -35,7 +35,7 @@ PA_C_DECL_BEGIN
+ /** Return the version of the header files. Keep in mind that this is
+ a macro and not a function, so it is impossible to get the pointer of
+ it. */
+-#define pa_get_headers_version() ("@PACKAGE_VERSION@")
++#define pa_get_headers_version() ("@PA_MAJOR@.@PA_MINOR@.0")
+
+ /** Return the version of the library the current application is
+ * linked to. */
+--
+1.7.6.1
+
diff --git a/media-sound/pulseaudio/pulseaudio-1.0-r2.ebuild b/media-sound/pulseaudio/pulseaudio-1.0-r2.ebuild
new file mode 100644
index 000000000000..2c008395bd98
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-1.0-r2.ebuild
@@ -0,0 +1,210 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-1.0-r2.ebuild,v 1.1 2011/10/08 11:28:50 ford_prefect Exp $
+
+EAPI=4
+
+inherit eutils libtool flag-o-matic versionator
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="http://www.pulseaudio.org/"
+
+SRC_URI="http://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+alsa avahi +caps equalizer jack lirc oss tcpd +X dbus libsamplerate gnome bluetooth +asyncns +glib test doc +udev ipv6 system-wide realtime +orc"
+
+RDEPEND="app-admin/eselect-esd
+ X? (
+ >=x11-libs/libX11-1.4.0
+ >=x11-libs/libxcb-1.6
+ >=x11-libs/xcb-util-0.3.1
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXtst
+ )
+ caps? ( sys-libs/libcap )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.1-r1 )
+ alsa? ( >=media-libs/alsa-lib-1.0.19 )
+ glib? ( >=dev-libs/glib-2.4.0 )
+ avahi? ( >=net-dns/avahi-0.6.12[dbus] )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.117 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ lirc? ( app-misc/lirc )
+ dbus? ( >=sys-apps/dbus-1.0.0 )
+ gnome? ( >=gnome-base/gconf-2.4.0 )
+ bluetooth? (
+ >=net-wireless/bluez-4
+ >=sys-apps/dbus-1.0.0
+ )
+ asyncns? ( net-libs/libasyncns )
+ udev? ( || ( >=sys-fs/udev-171[hwdb] >=sys-fs/udev-143[extras] ) )
+ realtime? ( sys-auth/rtkit )
+ equalizer? ( sci-libs/fftw:3.0 )
+ orc? ( >=dev-lang/orc-0.4.9 )
+ >=media-libs/audiofile-0.2.6-r1
+ >=media-libs/speex-1.2_rc1
+ >=media-libs/libsndfile-1.0.20
+ sys-libs/gdbm
+ dev-libs/json-c
+ >=sys-devel/libtool-2.2.4" # it's a valid RDEPEND, libltdl.so is used
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ X? (
+ x11-proto/xproto
+ >=x11-libs/libXtst-1.0.99.2
+ )
+ dev-libs/libatomic_ops
+ dev-util/pkgconfig
+ system-wide? ( || ( dev-util/unifdef sys-freebsd/freebsd-ubin ) )
+ dev-util/intltool"
+
+# alsa-utils dep is for the alsasound init.d script (see bug #155707)
+# bluez dep is for the bluetooth init.d script
+RDEPEND="${RDEPEND}
+ X? ( gnome-extra/gnome-audio )
+ system-wide? (
+ sys-apps/openrc
+ alsa? ( media-sound/alsa-utils )
+ bluetooth? ( >=net-wireless/bluez-4 )
+ )"
+
+pkg_setup() {
+ enewgroup audio 18 # Just make sure it exists
+ enewgroup pulse-access
+ enewgroup pulse
+ enewuser pulse -1 -1 /var/run/pulse pulse,audio
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-version-fix.patch"
+}
+
+src_configure() {
+ # It's a binutils bug, once I can find time to fix that I'll add a
+ # proper dependency and fix this up. — flameeyes
+ append-ldflags $(no-as-needed)
+
+ econf \
+ --enable-largefile \
+ $(use_enable glib glib2) \
+ --disable-solaris \
+ $(use_enable asyncns) \
+ $(use_enable oss oss-output) \
+ $(use_enable alsa) \
+ $(use_enable lirc) \
+ $(use_enable tcpd tcpwrap) \
+ $(use_enable jack) \
+ $(use_enable lirc) \
+ $(use_enable avahi) \
+ --disable-hal \
+ $(use_enable dbus) \
+ $(use_enable gnome gconf) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable bluetooth bluez) \
+ $(use_enable X x11) \
+ $(use_enable test default-build-tests) \
+ $(use_enable udev) \
+ $(use_enable ipv6) \
+ $(use_with caps) \
+ $(use_with equalizer fftw) \
+ --localstatedir="${EPREFIX}"/var \
+ --with-database=gdbm \
+ --with-udev-rules-dir="${EPREFIX}/lib/udev/rules.d"
+
+ if use doc; then
+ pushd doxygen
+ doxygen doxygen.conf
+ popd
+ fi
+}
+
+src_test() {
+ # We avoid running the toplevel check target because that will run
+ # po/'s tests too, and they are broken. Officially, it should work
+ # with intltool 0.41, but that doesn't look like a stable release.
+ emake -C src check
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ # Drop the script entirely if X is disabled
+ use X || rm "${ED}"/usr/bin/start-pulseaudio-x11
+
+ if use system-wide; then
+ newconfd "${FILESDIR}/pulseaudio.conf.d" pulseaudio
+
+ use_define() {
+ local define=${2:-$(echo $1 | tr '[:lower:]' '[:upper:]')}
+
+ use "$1" && echo "-D$define" || echo "-U$define"
+ }
+
+ unifdef $(use_define avahi) \
+ $(use_define alsa) \
+ $(use_define bluetooth) \
+ $(use_define udev) \
+ "${FILESDIR}/pulseaudio.init.d-5" \
+ > "${T}/pulseaudio"
+
+ doinitd "${T}/pulseaudio"
+ fi
+
+ use avahi && sed -i -e '/module-zeroconf-publish/s:^#::' "${ED}/etc/pulse/default.pa"
+
+ dodoc README todo
+
+ if use doc; then
+ pushd doxygen/html
+ dohtml *
+ popd
+ fi
+
+ # Create the state directory
+ use prefix || diropts -o pulse -g pulse -m0755
+ keepdir /var/run/pulse
+
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ if use system-wide; then
+ elog "PulseAudio in Gentoo can use a system-wide pulseaudio daemon."
+ elog "This support is enabled by starting the pulseaudio init.d ."
+ elog "To be able to access that you need to be in the group pulse-access."
+ elog "If you choose to use this feature, please make sure that you"
+ elog "really want to run PulseAudio this way:"
+ elog " http://pulseaudio.org/wiki/WhatIsWrongWithSystemMode"
+ elog "For more information about system-wide support, please refer to:"
+ elog " http://pulseaudio.org/wiki/SystemWideInstance"
+ if use gnome ; then
+ elog
+ elog "By enabling gnome USE flag, you enabled gconf support. Please note"
+ elog "that you might need to remove the gnome USE flag or disable the"
+ elog "gconf module on /etc/pulse/system.pa to be able to use PulseAudio"
+ elog "with a system-wide instance."
+ fi
+ fi
+ if use bluetooth; then
+ elog
+ elog "The Bluetooth proximity module is not enabled in the default"
+ elog "configuration file. If you do enable it, you'll have to have"
+ elog "your Bluetooth controller enabled and inserted at bootup or"
+ elog "PulseAudio will refuse to start."
+ fi
+ if use alsa; then
+ local pkg="media-plugins/alsa-plugins"
+ if has_version ${pkg} && ! has_version "${pkg}[pulseaudio]"; then
+ elog
+ elog "You have alsa support enabled so you probably want to install"
+ elog "${pkg} with pulseaudio support to have"
+ elog "alsa using applications route their sound through pulseaudio"
+ fi
+ fi
+
+ eselect esd update --if-unset
+}