summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2014-10-14 20:16:30 +0000
committerPatrick McLean <chutzpah@gentoo.org>2014-10-14 20:16:30 +0000
commit05e8fd9211b29dce1c93b79bc9343e770268303a (patch)
treee138e53caf17955756444292d96246cd055d1bd2 /media-sound/pithos
parentremove old (diff)
downloadgentoo-2-05e8fd9211b29dce1c93b79bc9343e770268303a.tar.gz
gentoo-2-05e8fd9211b29dce1c93b79bc9343e770268303a.tar.bz2
gentoo-2-05e8fd9211b29dce1c93b79bc9343e770268303a.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'media-sound/pithos')
-rw-r--r--media-sound/pithos/ChangeLog7
-rw-r--r--media-sound/pithos/pithos-1.0.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/media-sound/pithos/ChangeLog b/media-sound/pithos/ChangeLog
index 3c3beca91441..c20fda3a28fa 100644
--- a/media-sound/pithos/ChangeLog
+++ b/media-sound/pithos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/pithos
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pithos/ChangeLog,v 1.6 2014/09/22 18:20:08 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pithos/ChangeLog,v 1.7 2014/10/14 20:16:30 chutzpah Exp $
+
+*pithos-1.0.1 (14 Oct 2014)
+
+ 14 Oct 2014; Patrick McLean <chutzpah@gentoo.org> +pithos-1.0.1.ebuild:
+ Version bump.
*pithos-1.0.0 (22 Sep 2014)
diff --git a/media-sound/pithos/pithos-1.0.1.ebuild b/media-sound/pithos/pithos-1.0.1.ebuild
new file mode 100644
index 000000000000..be511062eca2
--- /dev/null
+++ b/media-sound/pithos/pithos-1.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pithos/pithos-1.0.1.ebuild,v 1.1 2014/10/14 20:16:30 chutzpah Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python3_3)
+inherit eutils distutils-r1
+
+if [[ ${PV} =~ [9]{4,} ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/pithos/pithos.git
+ https://github.com/pithos/pithos.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Pandora.com client for the GNOME desktop"
+HOMEPAGE="http://pithos.github.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify appindicator +keybinder"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pylast[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12[${PYTHON_USEDEP}]
+ media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
+ >=x11-libs/gtk+-3.12:3[introspection]
+ libnotify? ( x11-libs/libnotify[introspection] )
+ appindicator? ( dev-libs/libappindicator:3[introspection] )
+ keybinder? ( dev-libs/keybinder:3[introspection] )"
+
+PATCHES=("${FILESDIR}/${PN}-1.0.0-icons.patch")
+
+python_test() {
+ esetup.py test || die
+}