summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-21 13:50:35 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-21 13:50:35 +0000
commitc818a8b2630486cc060f389a864c8d42d1fdb041 (patch)
tree5373edea58bae1752c2684fe3fa760c68c5843b6 /media-sound/pd
parentReal networks RealSDK license added (diff)
downloadgentoo-2-c818a8b2630486cc060f389a864c8d42d1fdb041.tar.gz
gentoo-2-c818a8b2630486cc060f389a864c8d42d1fdb041.tar.bz2
gentoo-2-c818a8b2630486cc060f389a864c8d42d1fdb041.zip
repoman'd
Diffstat (limited to 'media-sound/pd')
-rw-r--r--media-sound/pd/pd-0.35_pre24.ebuild35
1 files changed, 11 insertions, 24 deletions
diff --git a/media-sound/pd/pd-0.35_pre24.ebuild b/media-sound/pd/pd-0.35_pre24.ebuild
index 29ca12b176ff..aae9db3c8d0e 100644
--- a/media-sound/pd/pd-0.35_pre24.ebuild
+++ b/media-sound/pd/pd-0.35_pre24.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.6 2002/05/07 03:58:19 drobbins Exp
-
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
-# if you omit this line.
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/pd-0.35_pre24.ebuild,v 1.2 2002/07/21 13:50:33 seemant Exp $
# Miller Puckette uses nonstandard versioning scheme that we have to crunch
-PD_VER=`echo ${PV} | sed 's:_pre:-test:'`
-S=${WORKDIR}/${PN}-${PD_VER}
+MY_P=${P/_pre/-test}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="real-time music and multimedia environment"
-SRC_URI="http://www-crca.ucsd.edu/~msp/Software/${PN}-${PD_VER}.linux.tar.gz"
+SRC_URI="http://www-crca.ucsd.edu/~msp/Software/${MY_P}.linux.tar.gz"
HOMEPAGE="http://www-crca.ucsd.edu/~msp/software.html"
-LICENSE=""
+
+SLOT="0"
+LICENSE="BSD | as-is"
+KEYWORDS="x86"
#
# need to do something with alsa here:
@@ -21,15 +20,12 @@ LICENSE=""
# automagicly
#
DEPEND=">=dev-lang/tcl-8.3.3
- >=dev-lang/tk-8.3.3"
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
+ >=dev-lang/tk-8.3.3"
src_unpack() {
unpack ${A}
cd ${S} || die
- patch -p1 < ${FILESDIR}/${PN}-${PD_VER}-gentoo.patch || die
+ patch -p1 < ${FILESDIR}/${MY_P}-gentoo.patch || die
cd src || die
autoconf || die
}
@@ -37,20 +33,11 @@ src_unpack() {
src_compile() {
cd src
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf || die "./configure failed"
emake || die
}
src_install () {
cd src
make DESTDIR=${D} install || die
- #make \
- # prefix=${D}/usr \
- # mandir=${D}/usr/share/man \
- # infodir=${D}/usr/share/info \
- # install || die
}