summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-10-22 17:52:20 +0000
committerSamuli Suominen <drac@gentoo.org>2007-10-22 17:52:20 +0000
commitac3266975e0ea40b9e2722179cc3fc3abd301fa2 (patch)
tree366132fabe160eaf556e6c9135c2257cdff9d460 /media-sound/muine
parentStable for HPPA (bug #196715). Fixed quoting issues. (diff)
downloadgentoo-2-ac3266975e0ea40b9e2722179cc3fc3abd301fa2.tar.gz
gentoo-2-ac3266975e0ea40b9e2722179cc3fc3abd301fa2.tar.bz2
gentoo-2-ac3266975e0ea40b9e2722179cc3fc3abd301fa2.zip
Version bump.
(Portage version: 2.1.3.15)
Diffstat (limited to 'media-sound/muine')
-rw-r--r--media-sound/muine/ChangeLog7
-rw-r--r--media-sound/muine/files/digest-muine-0.8.83
-rw-r--r--media-sound/muine/muine-0.8.8.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/media-sound/muine/ChangeLog b/media-sound/muine/ChangeLog
index 14709ca1501b..b3bc6f4c805c 100644
--- a/media-sound/muine/ChangeLog
+++ b/media-sound/muine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/muine
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.42 2007/07/12 14:51:16 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.43 2007/10/22 17:52:19 drac Exp $
+
+*muine-0.8.8 (22 Oct 2007)
+
+ 22 Oct 2007; Samuli Suominen <drac@gentoo.org> +muine-0.8.8.ebuild:
+ Version bump.
12 Jul 2007; Samuli Suominen <drac@gentoo.org>
+files/muine-0.8.7-flac.patch, muine-0.8.7.ebuild:
diff --git a/media-sound/muine/files/digest-muine-0.8.8 b/media-sound/muine/files/digest-muine-0.8.8
new file mode 100644
index 000000000000..6bf5b942ac04
--- /dev/null
+++ b/media-sound/muine/files/digest-muine-0.8.8
@@ -0,0 +1,3 @@
+MD5 0bf318424d35241525df701e107dd6b1 muine-0.8.8.tar.gz 833148
+RMD160 56a1ab77fc4d99c254547efe29fd1f8cd214d7a2 muine-0.8.8.tar.gz 833148
+SHA256 92288652db03588b57fe87b089dfc2560702934b5c08cd80164b4cdade44798a muine-0.8.8.tar.gz 833148
diff --git a/media-sound/muine/muine-0.8.8.ebuild b/media-sound/muine/muine-0.8.8.ebuild
new file mode 100644
index 000000000000..5249f219f1ee
--- /dev/null
+++ b/media-sound/muine/muine-0.8.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/muine-0.8.8.ebuild,v 1.1 2007/10/22 17:52:19 drac Exp $
+
+inherit gnome2 mono eutils multilib autotools
+
+DESCRIPTION="A music player for GNOME"
+HOMEPAGE="http://muine-player.org"
+SRC_URI="http://muine-player.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="aac flac mad vorbis xine"
+
+RDEPEND=">=dev-lang/mono-1.1
+ >=x11-libs/gtk+-2.6
+ >=dev-dotnet/gtk-sharp-2.6
+ >=dev-dotnet/glade-sharp-2.6
+ >=dev-dotnet/gnome-sharp-2.6
+ >=dev-dotnet/gconf-sharp-2.6
+ >=dev-dotnet/gnomevfs-sharp-2.6
+ sys-libs/gdbm
+ >=media-libs/flac-1.1.2
+ >=media-libs/libvorbis-1
+ >=media-libs/libid3tag-0.15.0b
+ aac? ( >=media-libs/faad2-2.0-r4 )
+ xine? ( >=media-libs/xine-lib-1 )
+ !xine? (
+ =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-base-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-gconf-0.10*
+ =media-plugins/gst-plugins-gnomevfs-0.10*
+ aac? ( =media-plugins/gst-plugins-faad-0.10* )
+ flac? ( =media-plugins/gst-plugins-flac-0.10* )
+ mad? ( =media-plugins/gst-plugins-mad-0.10* )
+ vorbis? ( =media-plugins/gst-plugins-ogg-0.10*
+ =media-plugins/gst-plugins-vorbis-0.10* )
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-text/scrollkeeper
+ gnome-base/gnome-common
+ >=dev-util/intltool-0.29
+ >=dev-util/monodoc-1.1.9"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS PLUGINS README TODO"
+
+# The build is not parallel safe
+MAKEOPTS="${MAKEOPTS} -j1"
+
+G2CONF="$(use_enable aac faad2) $(use_enable xine)"
+
+src_install() {
+ gnome2_src_install
+ insinto /usr/$(get_libdir)/${PN}/plugins
+ doins "${S}"/plugins/TrayIcon.dll
+}
+
+pkg_postinst() {
+ elog
+ elog "Upstream no longer packages the tray icon plugin by default."
+ elog "The Gentoo ebuilds will continue to install the plugin, if you don't"
+ elog "want to use the plugin, remove TrayIcon.dll from"
+ elog "/usr/$(get_libdir)/muine/plugins/"
+ elog
+}