summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-08-22 22:12:31 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-08-22 22:12:31 +0000
commit4bdd5489e10d0e7db948b02c0a5bac4b8cbf62ef (patch)
tree13791c546ff92f038a9201cfb4c98e4fc48d5bd8 /media-sound/muine
parentRemove ruby16 from USE_RUBY. (diff)
downloadgentoo-2-4bdd5489e10d0e7db948b02c0a5bac4b8cbf62ef.tar.gz
gentoo-2-4bdd5489e10d0e7db948b02c0a5bac4b8cbf62ef.tar.bz2
gentoo-2-4bdd5489e10d0e7db948b02c0a5bac4b8cbf62ef.zip
Fix bug 272651, bugzilla.gnome.org bug 584702. Patch by Iain Lane.
(Portage version: 2.2_rc39/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/muine')
-rw-r--r--media-sound/muine/ChangeLog10
-rw-r--r--media-sound/muine/files/muine-0.8.10-gtk-sharp-2.12.9.patch19
-rw-r--r--media-sound/muine/muine-0.8.10-r1.ebuild91
3 files changed, 118 insertions, 2 deletions
diff --git a/media-sound/muine/ChangeLog b/media-sound/muine/ChangeLog
index 112e2d3c097a..ebf2d4a37017 100644
--- a/media-sound/muine/ChangeLog
+++ b/media-sound/muine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/muine
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.53 2009/04/05 17:19:23 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/ChangeLog,v 1.54 2009/08/22 22:12:31 loki_val Exp $
+
+*muine-0.8.10-r1 (22 Aug 2009)
+
+ 22 Aug 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +muine-0.8.10-r1.ebuild, +files/muine-0.8.10-gtk-sharp-2.12.9.patch:
+ Fix bug 272651, bugzilla.gnome.org bug 584702. Patch by Iain Lane.
05 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> muine-0.8.10.ebuild:
Remove -Werror from build, bug 260915. Also drop aac use-flag, since faad2
diff --git a/media-sound/muine/files/muine-0.8.10-gtk-sharp-2.12.9.patch b/media-sound/muine/files/muine-0.8.10-gtk-sharp-2.12.9.patch
new file mode 100644
index 000000000000..2e318aaa52bf
--- /dev/null
+++ b/media-sound/muine/files/muine-0.8.10-gtk-sharp-2.12.9.patch
@@ -0,0 +1,19 @@
+diff --git a/src/HandleModel.cs b/src/HandleModel.cs
+index 285d160..b0fc106 100644
+--- a/src/HandleModel.cs
++++ b/src/HandleModel.cs
+@@ -489,12 +489,10 @@ namespace Muine
+ }
+
+ [DllImport("libgtk-2.0-0.dll")]
+- static extern void gtk_tree_model_rows_reordered(IntPtr raw, IntPtr path, ref Gtk.TreeIter iter, out int new_order);
++ static extern void gtk_tree_model_rows_reordered(IntPtr raw, IntPtr path, ref Gtk.TreeIter iter, out int[] new_order);
+
+- public int EmitRowsReordered(Gtk.TreePath path, Gtk.TreeIter iter) {
+- int new_order;
++ public void EmitRowsReordered(Gtk.TreePath path, Gtk.TreeIter iter, int[] new_order) {
+ gtk_tree_model_rows_reordered(Handle, path.Handle, ref iter, out new_order);
+- return new_order;
+ }
+
+ [DllImport("libgtk-2.0-0.dll")]
diff --git a/media-sound/muine/muine-0.8.10-r1.ebuild b/media-sound/muine/muine-0.8.10-r1.ebuild
new file mode 100644
index 000000000000..266c55ddff8a
--- /dev/null
+++ b/media-sound/muine/muine-0.8.10-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muine/muine-0.8.10-r1.ebuild,v 1.1 2009/08/22 22:12:31 loki_val Exp $
+
+EAPI=2
+
+inherit base gnome2 mono eutils multilib flag-o-matic
+
+DESCRIPTION="A music player for GNOME"
+HOMEPAGE="http://muine-player.org"
+SRC_URI="http://download.gnome.org/sources/muine/0.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="flac mad vorbis xine"
+
+RDEPEND="x11-themes/gnome-icon-theme
+ >=dev-lang/mono-2
+ >=x11-libs/gtk+-2.6
+ >=dev-dotnet/gtk-sharp-2.12.9
+ >=dev-dotnet/glade-sharp-2.12.6
+ >=dev-dotnet/gnome-sharp-2.6
+ >=dev-dotnet/gconf-sharp-2.6
+ >=dev-dotnet/gnomevfs-sharp-2.6
+ >=dev-dotnet/dbus-sharp-0.4
+ >=dev-dotnet/dbus-glib-sharp-0.3
+ sys-libs/gdbm
+ >=media-libs/flac-1.1.2
+ >=media-libs/libvorbis-1
+ >=media-libs/libid3tag-0.15.0b
+ xine? ( >=media-libs/xine-lib-1 )
+ !xine? (
+ =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-base-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-gconf-0.10*
+ =media-plugins/gst-plugins-gnomevfs-0.10*
+ flac? ( =media-plugins/gst-plugins-flac-0.10* )
+ mad? ( =media-plugins/gst-plugins-mad-0.10* )
+ vorbis? ( =media-plugins/gst-plugins-ogg-0.10*
+ =media-plugins/gst-plugins-vorbis-0.10* )
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-text/scrollkeeper
+ gnome-base/gnome-common
+ >=dev-util/intltool-0.29
+ virtual/monodoc"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS PLUGINS README TODO"
+
+PATCHES=(
+ "${FILESDIR}/${P}-buttons.patch"
+ "${FILESDIR}/${P}-gtk-sharp-2.12.9.patch"
+ )
+
+# The build is not parallel safe
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ gnome2_src_unpack
+}
+
+src_prepare() {
+ base_src_prepare
+
+}
+
+src_configure() {
+ gnome2_src_configure --enable-compile-warnings=yes --disable-faad2 $(use_enable xine)
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ gnome2_src_install
+ insinto /usr/$(get_libdir)/${PN}/plugins
+ doins "${S}"/plugins/TrayIcon.dll
+}
+
+pkg_postinst() {
+ elog
+ elog "Upstream no longer packages the tray icon plugin by default."
+ elog "The Gentoo ebuilds will continue to install the plugin, if you don't"
+ elog "want to use the plugin, remove TrayIcon.dll from"
+ elog "/usr/$(get_libdir)/muine/plugins/"
+ elog
+}