summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-13 15:02:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-13 15:02:12 +0000
commit7f0b0c099bee8b4f9e5effa944a4b0e6c6bf1b36 (patch)
tree795cd17975fbada37f293265297021e20cfc490b /media-sound/mt-daapd
parent1.02.00 updated to current stable. (diff)
downloadgentoo-2-7f0b0c099bee8b4f9e5effa944a4b0e6c6bf1b36.tar.gz
gentoo-2-7f0b0c099bee8b4f9e5effa944a4b0e6c6bf1b36.tar.bz2
gentoo-2-7f0b0c099bee8b4f9e5effa944a4b0e6c6bf1b36.zip
New nightlie, remove old version.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'media-sound/mt-daapd')
-rw-r--r--media-sound/mt-daapd/ChangeLog9
-rw-r--r--media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre13033
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.3.0_pre1303.ebuild143
3 files changed, 154 insertions, 1 deletions
diff --git a/media-sound/mt-daapd/ChangeLog b/media-sound/mt-daapd/ChangeLog
index f11f9d8385ca..48a8672cabd9 100644
--- a/media-sound/mt-daapd/ChangeLog
+++ b/media-sound/mt-daapd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/mt-daapd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.39 2006/07/03 07:19:04 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.40 2006/07/13 15:02:12 flameeyes Exp $
+
+*mt-daapd-0.3.0_pre1303 (13 Jul 2006)
+
+ 13 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -mt-daapd-0.2.1.1.ebuild, -mt-daapd-0.3.0_pre1281.ebuild,
+ +mt-daapd-0.3.0_pre1303.ebuild:
+ New nightlie, remove old version.
03 Jul 2006; Simon Stelling <blubb@gentoo.org> mt-daapd-0.2.4.ebuild:
stable on amd64
diff --git a/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1303 b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1303
new file mode 100644
index 000000000000..5433350d1ad2
--- /dev/null
+++ b/media-sound/mt-daapd/files/digest-mt-daapd-0.3.0_pre1303
@@ -0,0 +1,3 @@
+MD5 313e57ab6ece969583ed731bbe715861 mt-daapd-svn-1303.tar.gz 1127798
+RMD160 71de62ad3554ff5e59b26ad1ec5a1e086eabd663 mt-daapd-svn-1303.tar.gz 1127798
+SHA256 b8bf6a74808cb36e6744f2218493f397166a802d9fadca768172a0893053760f mt-daapd-svn-1303.tar.gz 1127798
diff --git a/media-sound/mt-daapd/mt-daapd-0.3.0_pre1303.ebuild b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1303.ebuild
new file mode 100644
index 000000000000..4bd668dce9d3
--- /dev/null
+++ b/media-sound/mt-daapd/mt-daapd-0.3.0_pre1303.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.3.0_pre1303.ebuild,v 1.1 2006/07/13 15:02:12 flameeyes Exp $
+
+inherit eutils flag-o-matic base
+
+SVN="${PV#*pre}"
+
+if [[ -n ${SVN} ]] ; then
+ MY_P="${PN}-svn-${SVN}"
+ SRC_URI="http://nightlies.mt-daapd.org/${MY_P}.tar.gz"
+else
+ MY_P="${P/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
+HOMEPAGE="http://www.mt-daapd.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sh ~sparc ~x86"
+IUSE="howl vorbis avahi sqlite3 flac ffmpeg"
+
+DEPEND="sys-libs/zlib
+ media-libs/libid3tag
+ !sqlite3? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )
+ howl? ( !avahi? ( >=net-misc/howl-0.9.2 )
+ avahi? ( net-dns/avahi ) )
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )
+ ffmpeg? ( media-video/ffmpeg )"
+
+pkg_setup() {
+ if use howl && use avahi && ! built_with_use net-dns/avahi howl-compat; then
+ eerror "You requested avahi support, but this package requires"
+ eerror "the howl-compat support enabled in net-dns/avahi to work"
+ eerror "with it."
+ eerror
+ eerror "Please recompile net-dns/avahi with +howl-compat."
+ die "Missing howl-compat support in avahi."
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ local howlincludes
+
+ append-flags -fno-strict-aliasing
+
+ # howl support?
+ if use howl; then
+ use avahi && \
+ howlincludes="/usr/include/avahi-compat-howl" || \
+ howlincludes="/usr/include/howl"
+
+ myconf="${myconf}
+ --enable-howl
+ --with-howl-libs=/usr/$(get_libdir)
+ --with-howl-includes=${howlincludes}"
+ fi
+
+ # Bug 65723
+ if use vorbis; then
+ myconf="${myconf} --enable-oggvorbis"
+ fi
+
+ econf \
+ $(use_enable vorbis oggvorbis) \
+ $(use_enable flac) \
+ $(use_enable !sqlite3 sqlite) \
+ $(use_enable sqlite3) \
+ $(use_enable ffmpeg) \
+ --with-ffmpeg-includes=${ROOT}/usr/include/ffmpeg \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+
+ cp ${FILESDIR}/${PN}.init.2 ${WORKDIR}/initd
+ if ! use howl; then
+ sed -i -e '/#USEHOWL/d' ${WORKDIR}/initd
+ elif ! use avahi; then
+ sed -i -e 's:#USEHOWL ::' ${WORKDIR}/initd
+ else
+ sed -i -e 's:#USEHOWL ::; s:mDNSResponder:avahi-daemon:' ${WORKDIR}/initd
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ insinto /etc
+ newins ${FILESDIR}/mt-daapd.conf.example mt-daapd.conf.example
+ doins contrib/mt-daapd.playlist
+
+ newinitd ${WORKDIR}/initd ${PN}
+
+ keepdir /var/cache/mt-daapd /etc/mt-daapd.d
+
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You have to configure your mt-daapd.conf following"
+ einfo "/etc/mt-daapd.conf.example file."
+ einfo
+
+ if use howl; then
+ use avahi && \
+ howlservice="avahi-daemon" || \
+ howlservice="mDNSResponder"
+
+ einfo
+ einfo "Since you want to use howl instead of the internal mdnsd"
+ einfo "you need to make sure that you have ${howlservice} configured"
+ einfo "and running to use mt-daapd."
+ einfo
+
+ if use avahi; then
+ einfo "Avahi support is currently experimental, it does not work"
+ einfo "as intended when using more than one mt-daapd instance."
+ einfo "If you want to run more than one mt-daapd, just use the"
+ einfo "internal mdnsd by building with -howl flag."
+ fi
+ fi
+
+ if use vorbis; then
+ einfo
+ einfo "You need to edit you extensions list in /etc/mt-daapd.conf"
+ einfo "if you want your mt-daapd to serve ogg files."
+ einfo
+ fi
+
+ einfo
+ einfo "If you want to start more than one ${PN} service, symlink"
+ einfo "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
+ einfo "load the data from /etc/${PN}.d/<name>.conf."
+ einfo "Make sure that you have different cache directories for them."
+ einfo
+}