summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-11 17:55:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-11 17:55:35 +0000
commit7af5c58b574b671ea8a1ccbbda05bb26e6cd2709 (patch)
treefb911cbbd34d6d293f4d1bceab4775b11e594f1f /media-sound/mt-daapd
parentActually add the patch files. Nice wildcard handling, CVS! (diff)
downloadgentoo-2-7af5c58b574b671ea8a1ccbbda05bb26e6cd2709.tar.gz
gentoo-2-7af5c58b574b671ea8a1ccbbda05bb26e6cd2709.tar.bz2
gentoo-2-7af5c58b574b671ea8a1ccbbda05bb26e6cd2709.zip
Apply patch to fix compile with USE -vorbis wrt #200629.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mt-daapd')
-rw-r--r--media-sound/mt-daapd/ChangeLog8
-rw-r--r--media-sound/mt-daapd/files/mt-daapd-0.2.4.2-oggvorbis.patch18
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild36
3 files changed, 36 insertions, 26 deletions
diff --git a/media-sound/mt-daapd/ChangeLog b/media-sound/mt-daapd/ChangeLog
index 3be322194f7e..488afa70366e 100644
--- a/media-sound/mt-daapd/ChangeLog
+++ b/media-sound/mt-daapd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mt-daapd
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.63 2008/09/27 16:25:25 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.64 2009/05/11 17:55:35 ssuominen Exp $
+
+ 11 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ mt-daapd-0.2.4.2.ebuild, +files/mt-daapd-0.2.4.2-oggvorbis.patch:
+ Apply patch to fix compile with USE -vorbis wrt #200629.
27 Sep 2008; Raúl Porcel <armin76@gentoo.org> mt-daapd-0.2.4.2.ebuild:
arm/sh stable wrt #217986
diff --git a/media-sound/mt-daapd/files/mt-daapd-0.2.4.2-oggvorbis.patch b/media-sound/mt-daapd/files/mt-daapd-0.2.4.2-oggvorbis.patch
new file mode 100644
index 000000000000..8131b6cd53fc
--- /dev/null
+++ b/media-sound/mt-daapd/files/mt-daapd-0.2.4.2-oggvorbis.patch
@@ -0,0 +1,18 @@
+--- configure.in.orig 2009-03-11 08:15:14.000000000 -0500
++++ configure.in 2009-03-11 08:25:36.000000000 -0500
+@@ -63,9 +63,14 @@
+ AC_SUBST(AVAHI_LIBS)
+
+ AC_ARG_ENABLE(oggvorbis,[ --enable-oggvorbis Enable Ogg/Vorbis support],
++ [ case "${enabledval}" in
++ yes)
+ use_oggvorbis=true;
+ # LDFLAGS="${LDFLAGS} -logg -lvorbis";
+- CPPFLAGS="${CPPFLAGS} -DOGGVORBIS")
++ CPPFLAGS="${CPPFLAGS} -DOGGVORBIS"
++ esac
++ ]
++ )
+
+ AM_CONDITIONAL(COND_REND_HOWL, test x$rend_howl = xtrue)
+ AM_CONDITIONAL(COND_REND_AVAHI, test x$rend_avahi = xtrue)
diff --git a/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild b/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
index 60e12724e1e2..266aa45e590f 100644
--- a/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
+++ b/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild,v 1.5 2008/09/27 16:25:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild,v 1.6 2009/05/11 17:55:35 ssuominen Exp $
+EAPI=2
inherit autotools eutils
DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
@@ -11,29 +12,17 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm ~mips ppc sh sparc x86"
-IUSE="avahi vorbis"
+IUSE="+avahi vorbis"
RDEPEND="media-libs/libid3tag
sys-libs/gdbm
- avahi? ( net-dns/avahi )
+ avahi? ( net-dns/avahi[dbus] )
!avahi? ( net-misc/mDNSResponder )
vorbis? ( media-libs/libvorbis )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- local fail="Re-emerge net-dns/avahi with USE dbus."
-
- if use avahi && ! built_with_use net-dns/avahi dbus; then
- eerror "${fail}"
- die "${fail}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
cp "${FILESDIR}"/${PN}.init.2 initd
if use avahi; then
@@ -42,14 +31,15 @@ src_unpack() {
sed -i -e 's:#USEHOWL ::' initd
fi
- epatch "${FILESDIR}"/${PN}-0.2.3-sparc.patch
- epatch "${FILESDIR}"/${PN}-0.2.4.1-libsorder.patch
- epatch "${FILESDIR}"/${PN}-0.2.4.1-pidfile.patch
- epatch "${FILESDIR}"/${P}-maintainer-mode.patch
+ epatch "${FILESDIR}"/${PN}-0.2.3-sparc.patch \
+ "${FILESDIR}"/${PN}-0.2.4.1-libsorder.patch \
+ "${FILESDIR}"/${PN}-0.2.4.1-pidfile.patch \
+ "${FILESDIR}"/${P}-maintainer-mode.patch \
+ "${FILESDIR}"/${P}-oggvorbis.patch
eautoreconf
}
-src_compile() {
+src_configure() {
local myconf
if use avahi; then
@@ -61,8 +51,6 @@ src_compile() {
econf $(use_enable vorbis oggvorbis) \
--disable-maintainer-mode \
${myconf}
-
- emake || die "emake failed."
}
src_install() {