summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-12 09:40:41 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-12 09:40:41 +0000
commite2b55a9a3058f3a422615f7bfd3dc19f97f31847 (patch)
tree2fd24238decec7f82741d2ca475e9cb5e5209553 /media-sound/mpg123
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-e2b55a9a3058f3a422615f7bfd3dc19f97f31847.tar.gz
gentoo-2-e2b55a9a3058f3a422615f7bfd3dc19f97f31847.tar.bz2
gentoo-2-e2b55a9a3058f3a422615f7bfd3dc19f97f31847.zip
Support for more nas and esd added. Alsa is broken. Closes bug #47269.
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/ChangeLog8
-rw-r--r--media-sound/mpg123/Manifest6
-rw-r--r--media-sound/mpg123/files/digest-mpg123-0.59s-r31
-rw-r--r--media-sound/mpg123/mpg123-0.59s-r3.ebuild127
4 files changed, 139 insertions, 3 deletions
diff --git a/media-sound/mpg123/ChangeLog b/media-sound/mpg123/ChangeLog
index 4da96541a279..43d0965cf0e8 100644
--- a/media-sound/mpg123/ChangeLog
+++ b/media-sound/mpg123/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mpg123
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.36 2004/02/18 17:40:01 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.37 2004/04/12 09:40:41 eradicator Exp $
+
+*mpg123-0.59s-r3 (12 Apr 2004)
+
+ 12 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ mpg123-0.59s-r3.ebuild:
+ Support for more nas and esd added. Alsa is broken. Closes bug #47269.
18 Feb 2004; Martin Schlemmer <azarah@gentoo.org> mpg123-0.59s-r2.ebuild:
Remove -m486 based on patch from Thomas Veith <th_veith@web.de>, closing bug
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index 550d4e0339b3..c241202f3133 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,8 +1,10 @@
+MD5 0d35fdd81de50c39850acde35b127e93 mpg123-0.59s-r3.ebuild 1865
MD5 0d35fdd81de50c39850acde35b127e93 mpg123-0.59s-r2.ebuild 1865
MD5 757a3d0bd9922ecad30a1f42e64bab44 ChangeLog 6875
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-MD5 a80297615f6515bb5631c177511c989a files/mpg123-0.59s-security.diff 1075
MD5 7d563752464873b664d7d242e9d06bbd files/mpg123-0.59s-amd64.patch 2680
-MD5 7130077c0324ee5b3cfd58e291976a0e files/mpg123-0.59s-heapfix.diff 337
MD5 7c93b2634ad65c23562f86f6e0b051e2 files/0.59s-generic.patch 532
MD5 78e5e78b54876dbecebb45acec8fb449 files/digest-mpg123-0.59s-r2 67
+MD5 78e5e78b54876dbecebb45acec8fb449 files/digest-mpg123-0.59s-r3 67
+MD5 a80297615f6515bb5631c177511c989a files/mpg123-0.59s-security.diff 1075
+MD5 7130077c0324ee5b3cfd58e291976a0e files/mpg123-0.59s-heapfix.diff 337
diff --git a/media-sound/mpg123/files/digest-mpg123-0.59s-r3 b/media-sound/mpg123/files/digest-mpg123-0.59s-r3
new file mode 100644
index 000000000000..88b7f6bafc5b
--- /dev/null
+++ b/media-sound/mpg123/files/digest-mpg123-0.59s-r3
@@ -0,0 +1 @@
+MD5 a63675b0ea7990d4a7d7e7e14f23a3e4 mpg123-pre0.59s.tar.gz 244899
diff --git a/media-sound/mpg123/mpg123-0.59s-r3.ebuild b/media-sound/mpg123/mpg123-0.59s-r3.ebuild
new file mode 100644
index 000000000000..060e47a6597b
--- /dev/null
+++ b/media-sound/mpg123/mpg123-0.59s-r3.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.59s-r3.ebuild,v 1.1 2004/04/12 09:40:41 eradicator Exp $
+
+inherit eutils
+
+IUSE="mmx 3dnow esd nas"
+
+DESCRIPTION="Real Time mp3 player"
+HOMEPAGE="http://www.mpg123.de/"
+SRC_URI="http://www.mpg123.de/mpg123/${PN}-pre${PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ia64 amd64 ppc sparc alpha hppa -mips"
+
+RDEPEND="virtual/glibc
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )"
+
+# alsa-1 b0rks and it's not a simple fix
+# alsa? ( media-libs/alsa-lib )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+PROVIDE="virtual/mpg123"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A} && cd ${S} || die "unpack failed"
+
+ # Apply security fixes
+ epatch ${FILESDIR}/${P}-security.diff
+ epatch ${FILESDIR}/${P}-heapfix.diff
+
+ # Add linux-generic target
+ epatch ${FILESDIR}/${PV}-generic.patch
+
+ # Always apply this patch, even though it's particularly for
+ # amd64. It's good to understand the distinction between int and
+ # long: ANSI says that int should be 32-bits, long should be the
+ # native size of the CPU (usually the same as a pointer).
+ epatch ${FILESDIR}/mpg123-0.59s-amd64.patch
+
+ # Don't force gcc since icc/ccc might be possible
+ sed -i -e "s|CC=gcc||" Makefile
+
+ # Fix a glitch in the x86 related section of the Makefile
+ sed -i -e "s:-m486::g" Makefile
+ # Fix a glitch in the ppc-related section of the Makefile
+ sed -i -e "s:-mcpu=ppc::" Makefile
+ # Make sure we use our CFLAGS
+ sed -i -e "s:-O2::g" Makefile
+}
+
+src_compile() {
+ mkdir gentoo-bin
+
+ # The last one in $styles is the default
+ local styles
+
+ use nas && styles="${styles} -nas"
+ use oss && styles="${styles} -generic"
+
+ case $ARCH in
+ ppc*)
+ use esd && styles="${styles} -ppc-esd"
+ use oss && styles="${styles} -ppc"
+
+ [ -z "${styles}" ] && die "You need atleast one of these USE flags set: esd nas oss."
+ ;;
+ x86)
+ use esd && styles="${styles} -esd"
+ use esd && use 3dnow && styles="${styles} -3dnow-esd"
+ use oss && styles="${styles} -i486"
+ use oss && use mmx && styles="${styles} -mmx"
+ use oss && use 3dnow && styles="${styles} -3dnow"
+ # use alsa && styles="${styles} -alsa"
+ # use alsa && use 3dnow && styles="${styles} -3dnow-alsa"
+
+ [ -z "${styles}" ] && die "You need atleast one of these USE flags set: esd nas oss."
+ ;;
+ sparc*)
+ use esd && styles="${styles} -sparc-esd"
+ styles="${styles} -sparc"
+ ;;
+ amd64)
+ use esd && styles="${styles} -x86_64-esd"
+ use oss && styles="${styles} -x86_64"
+ # use alsa && styles="${styles} -x86_64-alsa"
+
+ [ -z "${styles}" ] && die "You need atleast one of these USE flags set: esd nas oss."
+ ;;
+ alpha)
+ use esd && styles="${styles} -alpha-esd"
+ use oss && styles="${styles} -alpha"
+ # use alsa && styles="${styles} -alpha-alsa"
+
+ [ -z "${styles}" ] && die "You need atleast one of these USE flags set: esd nas oss alsa."
+ ;;
+# mips)
+# use alsa && styles="${styles} -mips-alsa"
+#
+# [ -z "${styles}" ] && die "You need atleast one of these USE flags set: esd nas oss alsa."
+# ;;
+ esac
+
+ [ -z "${styles}" ] && die "You need atleast one of these USE flags set: nas oss."
+
+
+ for style in ${styles};
+ do
+ make clean linux${style} CFLAGS="${CFLAGS}" || die
+ mv mpg123 gentoo-bin/mpg123${style}
+ [ -L "gentoo-bin/mpg123" ] && rm gentoo-bin/mpg123
+ ln -s mpg123${style} gentoo-bin/mpg123
+ done
+}
+
+src_install() {
+ dodir /usr
+ cp -dR gentoo-bin ${D}/usr/bin
+ doman mpg123.1
+ dodoc BENCHMARKING BUGS CHANGES COPYING JUKEBOX README* TODO
+}