summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2007-01-06 14:08:04 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2007-01-06 14:08:04 +0000
commit64674af04182574d8d601fa64f508d7596f46803 (patch)
tree96589612836b6a6b17352cd59c5bcd1fe2382c5f /media-sound/mpg123
parentVersion bump (diff)
downloadgentoo-2-64674af04182574d8d601fa64f508d7596f46803.tar.gz
gentoo-2-64674af04182574d8d601fa64f508d7596f46803.tar.bz2
gentoo-2-64674af04182574d8d601fa64f508d7596f46803.zip
Fix dependencies; bug 159693; thanks to jakub
(Portage version: 2.1.2_rc4-r3)
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/ChangeLog8
-rw-r--r--media-sound/mpg123/mpg123-0.61.ebuild58
2 files changed, 43 insertions, 23 deletions
diff --git a/media-sound/mpg123/ChangeLog b/media-sound/mpg123/ChangeLog
index be03009f8223..1ad655657ad2 100644
--- a/media-sound/mpg123/ChangeLog
+++ b/media-sound/mpg123/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mpg123
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.105 2006/10/22 19:04:52 genstef Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.106 2007/01/06 14:08:04 masterdriverz Exp $
+
+ 06 Jan 2007; Charlie Shepherd <masterdriverz@gentoo.org>
+ mpg123-0.61.ebuild:
+ Fix dependencies; bug 159693; thanks to jakub
*mpg123-0.61 (22 Oct 2006)
diff --git a/media-sound/mpg123/mpg123-0.61.ebuild b/media-sound/mpg123/mpg123-0.61.ebuild
index b8dbb13d9049..b8f4739d4b69 100644
--- a/media-sound/mpg123/mpg123-0.61.ebuild
+++ b/media-sound/mpg123/mpg123-0.61.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.61.ebuild,v 1.2 2006/10/22 19:09:49 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.61.ebuild,v 1.3 2007/01/06 14:08:04 masterdriverz Exp $
+
+inherit eutils
DESCRIPTION="Real Time mp3 player"
HOMEPAGE="http://www.mpg123.de/"
@@ -10,39 +12,53 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
-IUSE="mmx 3dnow esd nas oss alsa sdl"
+IUSE="mmx 3dnow alsa oss sdl esd nas jack portaudio"
-RDEPEND="esd? ( media-sound/esound )
- nas? ( media-libs/nas )
- alsa? ( media-libs/alsa-lib )
- sdl? ( media-libs/libsdl )"
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ sdl? ( !alsa? ( !oss? ( media-libs/libsdl ) ) )
+ esd? ( !alsa? ( !oss? ( !sdl? ( media-sound/esound ) ) ) )
+ nas? ( !alsa? ( !oss? ( !sdl? ( !esd? ( media-libs/nas ) ) ) ) )
+ jack? ( !alsa? ( !oss? ( !sdl? ( !esd? ( !nas? ( media-sound/jack-audio-connection-kit ) ) ) ) ) )
+ portaudio? ( !alsa? ( !oss? ( !sdl? ( !esd? ( !nas? ( !jack? ( media-libs/portaudio ) ) ) ) ) ) )"
DEPEND="${RDEPEND}"
PROVIDE="virtual/mpg123"
src_compile() {
+ local audiodev
if use alsa; then
- audiodev="alsa"
- elif use oss; then
- audiodev="oss"
- elif use sdl; then
- audiodev="sdl"
- elif use esd; then
- audiodev="esd"
- elif use ppc-macos; then
- audiodev="macosx";
- elif use nas; then
- audiodev="nas"
- else die "no audio device selected"
+ audiodev="alsa"
+ elif use oss; then
+ audiodev="oss"
+ elif use sdl; then
+ audiodev="sdl"
+ elif use esd; then
+ audiodev="esd"
+ elif use nas; then
+ audiodev="nas"
+ elif use jack; then
+ audiodev="jack"
+ elif use portaudio; then
+ audiodev="portaudio"
+ elif use ppc-macos; then
+ audiodev="macosx";
+ else audiodev="dummy"
fi
if use 3dnow; then
- myconf="--with-cpu=3dnow"
+ myconf="--with-cpu=3dnow"
elif use mmx; then
- myconf="--with-cpu=mmx"
+ myconf="--with-cpu=mmx"
fi
+ einfo "Compiling with ${audiodev} audio output."
+ einfo "If that is not what you want, then select exactly ONE"
+ einfo "of the following USE flags:"
+ einfo "alsa oss sdl esd nas jack portaudio"
+ einfo "and recompile ${PN}."
+ epause 5
+
econf \
--with-optimization=0 \
--with-audio=$audiodev \