summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-03-09 03:35:27 +0000
committerSteve Dibb <beandog@gentoo.org>2007-03-09 03:35:27 +0000
commit963c0b0dcec2f63200c8eff0d6846b08b9d38a03 (patch)
tree04a2e50c0a7fd4674bdfc644c818d43e99d91a88 /media-sound/mpfc/mpfc-1.3.7-r1.ebuild
parentAdd cdaudio, wav to media-sound/mpfc (diff)
downloadgentoo-2-963c0b0dcec2f63200c8eff0d6846b08b9d38a03.tar.gz
gentoo-2-963c0b0dcec2f63200c8eff0d6846b08b9d38a03.tar.bz2
gentoo-2-963c0b0dcec2f63200c8eff0d6846b08b9d38a03.zip
Add cdaudio, wav, nls use flags, bug 98576
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-sound/mpfc/mpfc-1.3.7-r1.ebuild')
-rw-r--r--media-sound/mpfc/mpfc-1.3.7-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/mpfc/mpfc-1.3.7-r1.ebuild b/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
new file mode 100644
index 000000000000..71b434d05ac1
--- /dev/null
+++ b/media-sound/mpfc/mpfc-1.3.7-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpfc/mpfc-1.3.7-r1.ebuild,v 1.1 2007/03/09 03:35:27 beandog Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Music Player For Console"
+HOMEPAGE="http://mpfc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa gpm mad vorbis oss wav cdaudio nls"
+RDEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ mad? ( media-libs/libmad )
+ vorbis? ( media-libs/libvorbis )"
+
+src_unpack() {
+ unpack ${A}
+
+ # $(get_libdir) fixes
+ cd "${S}"
+ find . -name 'Makefile.in' |
+ xargs grep ^libdir |
+ cut -f1 -d: |
+ xargs sed -i "s:^\(libdir.*\)/lib/\(.*\)$:\1/$(get_libdir)/\2:" || die
+ epatch "${FILESDIR}/${PN}-gcc4.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable alsa) \
+ $(use_enable gpm) \
+ $(use_enable mad mp3) \
+ $(use_enable vorbis ogg) \
+ $(use_enable oss) \
+ $(use_enable wav) \
+ $(use_enable cdaudio audiocd) \
+ $(use_enable nls) \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ insinto /etc; doins mpfcrc
+
+ dodoc AUTHORS ChangeLog NEWS README
+}