summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-20 14:55:13 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-20 14:55:13 +0000
commit2f2db5725a2de2244d914bf7a52c331b2e706187 (patch)
treeb9dc4989f6fcac14fad69184326b96562d1ec014 /media-sound/mpdscribble
parentstable amd64, bug 251735 (diff)
downloadgentoo-2-2f2db5725a2de2244d914bf7a52c331b2e706187.tar.gz
gentoo-2-2f2db5725a2de2244d914bf7a52c331b2e706187.tar.bz2
gentoo-2-2f2db5725a2de2244d914bf7a52c331b2e706187.zip
Version bump and taking maintainership
(Portage version: 2.2_rc17/cvs/Linux 2.6.28-rc9 x86_64)
Diffstat (limited to 'media-sound/mpdscribble')
-rw-r--r--media-sound/mpdscribble/ChangeLog8
-rw-r--r--media-sound/mpdscribble/metadata.xml4
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.13.ebuild33
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.2.12.ebuild4
4 files changed, 46 insertions, 3 deletions
diff --git a/media-sound/mpdscribble/ChangeLog b/media-sound/mpdscribble/ChangeLog
index cb302994ebc6..d3368ff03dc3 100644
--- a/media-sound/mpdscribble/ChangeLog
+++ b/media-sound/mpdscribble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mpdscribble
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.20 2008/01/29 20:55:42 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.21 2008/12/20 14:55:13 angelos Exp $
+
+*mpdscribble-0.13 (20 Dec 2008)
+
+ 20 Dec 2008; Christoph Mende <angelos@gentoo.org> metadata.xml,
+ mpdscribble-0.2.12.ebuild, +mpdscribble-0.13.ebuild:
+ Version bump and taking maintainership
29 Jan 2008; Samuli Suominen <drac@gentoo.org> -mpdscribble-0.2.6.ebuild,
-mpdscribble-0.2.7.ebuild, -mpdscribble-0.2.9.ebuild,
diff --git a/media-sound/mpdscribble/metadata.xml b/media-sound/mpdscribble/metadata.xml
index 792d26f8e42a..ad471e80db3e 100644
--- a/media-sound/mpdscribble/metadata.xml
+++ b/media-sound/mpdscribble/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sound</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
<longdescription lang="en">
A client for the Music Player Daemon that sends information to
Audioscrobbler -- a website (www.last.fm) displaying what various people
diff --git a/media-sound/mpdscribble/mpdscribble-0.13.ebuild b/media-sound/mpdscribble/mpdscribble-0.13.ebuild
new file mode 100644
index 000000000000..2610ff69c06a
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.13.ebuild,v 1.1 2008/12/20 14:55:13 angelos Exp $
+
+EAPI=1
+
+DESCRIPTION="An MPD client that submits information to audioscrobbler."
+HOMEPAGE="http://www.frob.nl/scribble.html"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ net-libs/libsoup:2.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ dodoc AUTHORS NEWS README
+ rm -r -f "${D}"/usr/share/doc/${PN}
+ dodir /var/cache/mpdscribble
+}
+
+pkg_postinst() {
+ elog "If you are going to use the init script shipped with this script, you"
+ elog "will have to create a config file (/etc/${PN}.conf), see the man page"
+ elog "for instructions on how to write one."
+}
diff --git a/media-sound/mpdscribble/mpdscribble-0.2.12.ebuild b/media-sound/mpdscribble/mpdscribble-0.2.12.ebuild
index 2e93b9c642b9..9b3b2305f902 100644
--- a/media-sound/mpdscribble/mpdscribble-0.2.12.ebuild
+++ b/media-sound/mpdscribble/mpdscribble-0.2.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.2.12.ebuild,v 1.8 2008/01/29 20:55:42 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.2.12.ebuild,v 1.9 2008/12/20 14:55:13 angelos Exp $
EAPI=1
@@ -18,7 +18,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die "emake install failed."
exeinto /usr/share/mpdscribble
doexe setup.sh