summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-05-02 14:47:58 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-05-02 14:47:58 +0000
commit5d86bd496e2e7fc997ca0f4645463bb70d1c9822 (patch)
tree9f24f80aa4872004c9796c9b953a05da4d98ced0 /media-sound/mp3gain
parentld64-95 (as in binutils-apple-3.2-r1) needs gcc-apple-4.2.1 to be compiled, a... (diff)
downloadgentoo-2-5d86bd496e2e7fc997ca0f4645463bb70d1c9822.tar.gz
gentoo-2-5d86bd496e2e7fc997ca0f4645463bb70d1c9822.tar.bz2
gentoo-2-5d86bd496e2e7fc997ca0f4645463bb70d1c9822.zip
Version bump as requested by Daniel Pinto dos Santos in bug #285794. Dropped long options support as I was unable to rebase it. Addressed format string vulnerability with a patch.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/mp3gain')
-rw-r--r--media-sound/mp3gain/ChangeLog10
-rw-r--r--media-sound/mp3gain/files/1.5.1-format-string.patch12
-rw-r--r--media-sound/mp3gain/mp3gain-1.5.1.ebuild38
3 files changed, 59 insertions, 1 deletions
diff --git a/media-sound/mp3gain/ChangeLog b/media-sound/mp3gain/ChangeLog
index 745212d14d0a..ee170a621fec 100644
--- a/media-sound/mp3gain/ChangeLog
+++ b/media-sound/mp3gain/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/mp3gain
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3gain/ChangeLog,v 1.41 2010/01/07 14:38:48 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3gain/ChangeLog,v 1.42 2010/05/02 14:47:58 chainsaw Exp $
+
+*mp3gain-1.5.1 (02 May 2010)
+
+ 02 May 2010; <chainsaw@gentoo.org> +files/1.5.1-format-string.patch,
+ +mp3gain-1.5.1.ebuild:
+ Version bump as requested by Daniel Pinto dos Santos in bug #285794.
+ Dropped long options support as I was unable to rebase it. Addressed
+ format string vulnerability with a patch.
07 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
mp3gain-1.4.6-r3.ebuild:
diff --git a/media-sound/mp3gain/files/1.5.1-format-string.patch b/media-sound/mp3gain/files/1.5.1-format-string.patch
new file mode 100644
index 000000000000..a91d82f404f5
--- /dev/null
+++ b/media-sound/mp3gain/files/1.5.1-format-string.patch
@@ -0,0 +1,12 @@
+diff -uNr work.ORIG//rg_error.c work/rg_error.c
+--- work.ORIG//rg_error.c 2010-05-02 15:42:47.056116105 +0100
++++ work/rg_error.c 2010-05-02 15:43:26.851999890 +0100
+@@ -40,7 +40,7 @@
+ {
+ #ifndef asWIN32DLL
+ gSuccess = 0;
+- fprintf(stdout, localerrstr);
++ fprintf(stdout, "%s", localerrstr);
+ #else
+ //send message to DLL's parent
+ mp3gainerr = localerrnum;
diff --git a/media-sound/mp3gain/mp3gain-1.5.1.ebuild b/media-sound/mp3gain/mp3gain-1.5.1.ebuild
new file mode 100644
index 000000000000..ef0c68da4a18
--- /dev/null
+++ b/media-sound/mp3gain/mp3gain-1.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3gain/mp3gain-1.5.1.ebuild,v 1.1 2010/05/02 14:47:58 chainsaw Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE=""
+
+MY_P=${P//./_}
+S=${WORKDIR}
+
+DESCRIPTION="MP3Gain automatically adjusts mp3s so that they all have the same volume"
+HOMEPAGE="http://mp3gain.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.zip"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ filter-flags -O*
+ sed -i -e "s:CC=.*:CC=$(tc-getCC):" \
+ -e "s:CFLAGS= -Wall -O3 -DHAVE_MEMCPY:CFLAGS+= -Wall -DHAVE_MEMCPY:" \
+ -e "s:LIBS=.*:LIBS= ${LDFLAGS} -lm:" \
+ "${S}"/Makefile \
+ || die "Unable to adjust build system compiler/flags."
+ epatch "${FILESDIR}"/${PV}-format-string.patch
+}
+
+src_install () {
+ dobin mp3gain
+}