summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-16 20:32:08 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-16 20:32:08 +0000
commit921ade93fe2937c0a2d9e755263525a77192a995 (patch)
tree5cbcf6ef2156b79bfcfa637fc38e509b238155ef /media-sound/mp3check
parentEbuild submitted by Elias Probst <elias.probst@gmx.de> with fixes by Christia... (diff)
downloadgentoo-2-921ade93fe2937c0a2d9e755263525a77192a995.tar.gz
gentoo-2-921ade93fe2937c0a2d9e755263525a77192a995.tar.bz2
gentoo-2-921ade93fe2937c0a2d9e755263525a77192a995.zip
initial import. Ebuild submitted by <kavol@email.cz> and adapted to meet gentoo ebuild policies by <cparpart@surakware.net>
Diffstat (limited to 'media-sound/mp3check')
-rw-r--r--media-sound/mp3check/ChangeLog9
-rw-r--r--media-sound/mp3check/Manifest5
-rw-r--r--media-sound/mp3check/files/digest-mp3check-0.8.01
-rw-r--r--media-sound/mp3check/files/mp3check-0.8.0-gcc34.diff45
-rw-r--r--media-sound/mp3check/mp3check-0.8.0.ebuild27
5 files changed, 87 insertions, 0 deletions
diff --git a/media-sound/mp3check/ChangeLog b/media-sound/mp3check/ChangeLog
new file mode 100644
index 000000000000..6f93241749de
--- /dev/null
+++ b/media-sound/mp3check/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-sound/kstreamripper
+# Copyright 2004-2004 Gentoo Technologies, Inc.; Distributed under the GPL
+
+*mp3check-0.8.0 (16 Sep 2004)
+
+ 16 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/mp3check-0.8.0-gcc34.diff, +mp3check-0.8.0.ebuild:
+ initial import. Ebuild submitted by <kavol@email.cz> and adapted to meet
+ gentoo ebuild policies by <cparpart@surakware.net>
diff --git a/media-sound/mp3check/Manifest b/media-sound/mp3check/Manifest
new file mode 100644
index 000000000000..39ae3a6a1230
--- /dev/null
+++ b/media-sound/mp3check/Manifest
@@ -0,0 +1,5 @@
+MD5 b77093e6f1c43db8d90d7be6127e335d ChangeLog 310
+MD5 63cede719e22d2767ab1567461f311a9 README 515
+MD5 f03343b99e5a95456103948b1299ad1f mp3check-0.8.0.ebuild 602
+MD5 0e4355f7afa9cfc73b2c06420a9923b5 files/digest-mp3check-0.8.0 66
+MD5 738499728009660d6d5d4f50515c6ff7 files/mp3check-0.8.0-gcc34.diff 2675
diff --git a/media-sound/mp3check/files/digest-mp3check-0.8.0 b/media-sound/mp3check/files/digest-mp3check-0.8.0
new file mode 100644
index 000000000000..d00248922244
--- /dev/null
+++ b/media-sound/mp3check/files/digest-mp3check-0.8.0
@@ -0,0 +1 @@
+MD5 ebf7eef7c956ce452fe36f9bc70ed134 mp3check-0.8.0.tar.gz 119644
diff --git a/media-sound/mp3check/files/mp3check-0.8.0-gcc34.diff b/media-sound/mp3check/files/mp3check-0.8.0-gcc34.diff
new file mode 100644
index 000000000000..5ce41b4abb31
--- /dev/null
+++ b/media-sound/mp3check/files/mp3check-0.8.0-gcc34.diff
@@ -0,0 +1,45 @@
+diff -ur mp3check-0.8.0/tmap.h mp3check-0.8.0.gcc34/tmap.h
+--- mp3check-0.8.0/tmap.h 2002-12-03 23:00:57.000000000 +0100
++++ mp3check-0.8.0.gcc34/tmap.h 2004-09-15 19:20:24.727493932 +0200
+@@ -54,7 +54,7 @@
+ // new functionality
+
+ /// return whether an element with key is contained or not
+- bool contains(const K& key) const { return find(key) != end(); }
++ bool contains(const K& key) const { return find(key) != this->end(); }
+ /// access element read only (const)
+ // g++ 2.95.2 does not allow this:
+ // const T& operator[](const K& key) const { const_iterator i = find(key); if(i != end()) return i->second; else throw TNotFoundException(); } // throw(TNotFoundException)
+diff -ur mp3check-0.8.0/tstring.cc mp3check-0.8.0.gcc34/tstring.cc
+--- mp3check-0.8.0/tstring.cc 2003-01-27 22:21:17.000000000 +0100
++++ mp3check-0.8.0.gcc34/tstring.cc 2004-09-15 19:31:52.383825721 +0200
+@@ -714,7 +714,7 @@
+
+ void tstring::replaceUnprintable(bool only_ascii) {
+ for(size_t i = 0; i < rep->len; i++) {
+- unsigned char& c = (unsigned char)(*rep)[i];
++ unsigned char& c = (unsigned char&)(*rep)[i];
+ if(!isprint(c)) {
+ if(c < ' ') {
+ c = '!';
+diff -ur mp3check-0.8.0/tvector.h mp3check-0.8.0.gcc34/tvector.h
+--- mp3check-0.8.0/tvector.h 2002-12-03 23:00:57.000000000 +0100
++++ mp3check-0.8.0.gcc34/tvector.h 2004-09-15 19:22:32.756649251 +0200
+@@ -60,13 +60,13 @@
+ /// append an element to the end
+ const tvector& operator += (const T& a) { push_back(a); return *this; }
+ /// append another tvector to the end
+- const tvector& operator += (const tvector& a) { insert(end(), a.begin(), a.end()); return *this; }
++ const tvector& operator += (const tvector& a) { insert(this->end(), a.begin(), a.end()); return *this; }
+ /// direct read only access, safe
+- const T& operator[](size_t i) const { if(i < size()) return tvector_base<T>::operator[](i); else throw TZeroBasedIndexOutOfRangeException(i, size()); } // throw(TZeroBasedIndexOutOfRangeException);
++ const T& operator[](size_t i) const { if(i < this->size()) return tvector_base<T>::operator[](i); else throw TZeroBasedIndexOutOfRangeException(i, this->size()); } // throw(TZeroBasedIndexOutOfRangeException);
+ /// direct read/write access, automatically create new elements
+- T& operator[](size_t i) { if(i >= size()) operator+=(tvector(i - size() + 1)); return tvector_base<T>::operator[](i); }
++ T& operator[](size_t i) { if(i >= this->size()) operator+=(tvector(i - this->size() + 1)); return tvector_base<T>::operator[](i); }
+ /// clear vector
+- void clear() { erase(begin(), end()); }
++ void clear() { erase(this->begin(), this->end()); }
+ };
+
+
diff --git a/media-sound/mp3check/mp3check-0.8.0.ebuild b/media-sound/mp3check/mp3check-0.8.0.ebuild
new file mode 100644
index 000000000000..1e68496ea8fc
--- /dev/null
+++ b/media-sound/mp3check/mp3check-0.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3check/mp3check-0.8.0.ebuild,v 1.1 2004/09/16 20:32:08 eradicator Exp $
+
+IUSE=""
+
+inherit eutils
+
+DESCRIPTION="Checks mp3 files for consistency and prints several errors and warnings."
+HOMEPAGE="http://jo.ath.cx/soft/mp3check/mp3check.html"
+SRC_URI="http://jo.ath.cx/soft/mp3check/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz || die
+ cd ${S} || die
+ epatch "${FILESDIR}/mp3check-0.8.0-gcc34.diff" || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ChangeLog FAQ HISTORY THANKS TODO
+}