summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-10 18:24:32 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-10 18:24:32 +0000
commit34f147455321536c84742dc9cddb8f730f9c58a0 (patch)
tree94f1f22f1c3963ffd8f2c92b5f0070bc480fe905 /media-sound/mp3blaster
parentNew package. Submitted by Robert Coie. Fixes #4732 (diff)
downloadgentoo-2-34f147455321536c84742dc9cddb8f730f9c58a0.tar.gz
gentoo-2-34f147455321536c84742dc9cddb8f730f9c58a0.tar.bz2
gentoo-2-34f147455321536c84742dc9cddb8f730f9c58a0.zip
New version. Submitted by Christoph Lameter. Fixes #4373
Diffstat (limited to 'media-sound/mp3blaster')
-rw-r--r--media-sound/mp3blaster/ChangeLog8
-rw-r--r--media-sound/mp3blaster/files/digest-mp3blaster-3.1.11
-rw-r--r--media-sound/mp3blaster/files/mp3blaster-3.1.1-gcc3.1-fixes_cl.patch24
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.1.1.ebuild42
4 files changed, 74 insertions, 1 deletions
diff --git a/media-sound/mp3blaster/ChangeLog b/media-sound/mp3blaster/ChangeLog
index cf5374b9cd31..4585fd1b02fb 100644
--- a/media-sound/mp3blaster/ChangeLog
+++ b/media-sound/mp3blaster/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mp3blaster
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.2 2002/03/28 23:00:28 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.3 2002/07/10 18:24:32 rphillips Exp $
+
+*mp3blaster-3.1 (10 Jun 2002)
+
+ 10 Jun 2002; Ryan Phillips <rphillips@gentoo.org> mp3blaster-3.1.ebuild :
+
+ New versionn
*mp3blaster-3.0_p8 (28 Mar 2002)
diff --git a/media-sound/mp3blaster/files/digest-mp3blaster-3.1.1 b/media-sound/mp3blaster/files/digest-mp3blaster-3.1.1
new file mode 100644
index 000000000000..091e8292a26c
--- /dev/null
+++ b/media-sound/mp3blaster/files/digest-mp3blaster-3.1.1
@@ -0,0 +1 @@
+MD5 6713385086fdfdb91ba08e536f5db12e mp3blaster-3.1.1.tar.gz 286621
diff --git a/media-sound/mp3blaster/files/mp3blaster-3.1.1-gcc3.1-fixes_cl.patch b/media-sound/mp3blaster/files/mp3blaster-3.1.1-gcc3.1-fixes_cl.patch
new file mode 100644
index 000000000000..3d9b28001cea
--- /dev/null
+++ b/media-sound/mp3blaster/files/mp3blaster-3.1.1-gcc3.1-fixes_cl.patch
@@ -0,0 +1,24 @@
+--- main.cc~ Sat Mar 16 11:41:15 2002
++++ main.cc Sun Jun 30 18:22:59 2002
+@@ -3945,7 +3945,7 @@
+
+ /* called when someone presses '/' in filemanager */
+ void
+-fw_start_search(int timeout=2)
++fw_start_search(int timeout)
+ {
+ signal(SIGALRM, &fw_search_timeout);
+ fw_set_search_timeout(timeout);
+
+--- history.h~ Wed Sep 19 13:47:15 2001
++++ history.h Sun Jun 30 18:23:55 2002
+@@ -21,7 +21,7 @@
+ const char *element();
+
+ private:
+- vector<char *> v;
++ std::vector<char *> v;
+ unsigned int curpos;
+ std::vector<char *>::iterator it;
+ };
+
diff --git a/media-sound/mp3blaster/mp3blaster-3.1.1.ebuild b/media-sound/mp3blaster/mp3blaster-3.1.1.ebuild
new file mode 100644
index 000000000000..af116c630194
--- /dev/null
+++ b/media-sound/mp3blaster/mp3blaster-3.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+# Updated by Christoph Lameter <christoph@lameter.com>, June 30, 2002 (C) 2002 TelemetryBox Corporation.
+# /space/gentoo/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.0_p8.ebuild,v 1.4 2002/03/28 23:00:28 seemant Exp
+
+A=${PN}-3.1.1.tar.gz
+S=${WORKDIR}/${PN}-3.1.1
+DESCRIPTION="MP3 command line player"
+SRC_URI="ftp://mud.stack.nl/pub/mp3blaster/${A}"
+HOMEPAGE="http://www.stack.nl/~brama/mp3blaster"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nas? ( >=media-libs/nas-1.4.1 )
+ mysql? ( >=dev-db/mysql-3.23.36 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta1 )"
+
+src_compile() {
+ local myconf
+ use nas && myconf="${myconf} --with-nas"
+ use mysql && myconf="${myconf} --with-mysql"
+ use oggvorbis || myconf="${myconf} --without-oggvorbis"
+
+ (cd src;patch -l <${FILESDIR}/mp3blaster-3.1.1-gcc3.1-fixes_cl.patch)
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf} || die
+
+ if [ "`use nas`" ] ; then
+ cd src
+ sed -e "s:^INCLUDES =:INCLUDES = -I/usr/X11R6/include:" \
+ -e "s:^splay_LDADD =:splay_LDADD = \$(NAS_LIBS):" Makefile | cat > Makefile
+ cd ..
+ fi
+
+ # parallel make does not work
+ make CC="gcc ${CFLAGS}" CXX="c++ ${CXXFLAGS}" || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ANNOUNCE AUTHORS COPYING CREDITS ChangeLog FAQ NEWS README TODO
+}