summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-28 19:52:42 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-28 19:52:42 +0000
commita4b62fc3e68e60e83bf0b9a53c3dd5bd92aa2c49 (patch)
tree05ef061da7edb02bb467cf58a9c5623ab75f6353 /media-sound/mp32ogg/mp32ogg-0.11-r5.ebuild
parentAdd epiphany flag for app-misc/beagle (diff)
downloadgentoo-2-a4b62fc3e68e60e83bf0b9a53c3dd5bd92aa2c49.tar.gz
gentoo-2-a4b62fc3e68e60e83bf0b9a53c3dd5bd92aa2c49.tar.bz2
gentoo-2-a4b62fc3e68e60e83bf0b9a53c3dd5bd92aa2c49.zip
Added patch for bug #208017 (thanks to Mathias Hablützel, patch originally from Ubuntu).
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound/mp32ogg/mp32ogg-0.11-r5.ebuild')
-rw-r--r--media-sound/mp32ogg/mp32ogg-0.11-r5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/mp32ogg/mp32ogg-0.11-r5.ebuild b/media-sound/mp32ogg/mp32ogg-0.11-r5.ebuild
new file mode 100644
index 000000000000..a85f2ba31dfa
--- /dev/null
+++ b/media-sound/mp32ogg/mp32ogg-0.11-r5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp32ogg/mp32ogg-0.11-r5.ebuild,v 1.1 2008/02/28 19:52:41 dev-zero Exp $
+
+inherit eutils
+
+DESCRIPTION="A perl script to convert MP3 files to Ogg Vorbis files."
+HOMEPAGE="http://faceprint.com/code/"
+SRC_URI="ftp://ftp.faceprint.com/pub/software/scripts/mp32ogg"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/mpg123
+ dev-perl/MP3-Info
+ dev-perl/String-ShellQuote
+ media-sound/vorbis-tools"
+
+S="${WORKDIR}/"
+
+src_unpack(){
+ cp "${DISTDIR}/${A}" "${S}"
+ epatch \
+ "${FILESDIR}/${P}-r4-mpg321.patch" \
+ "${FILESDIR}/${P}-r4-quality.patch" \
+ "${FILESDIR}/${PF}-german_umlaut.patch"
+}
+
+src_install() {
+ dobin mp32ogg
+}