summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-12-20 17:02:48 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-12-20 17:02:48 +0000
commit88d691bb720d8e11bdb86807712fd05633410035 (patch)
treef7666311f4380e9e54d7bcb87dd57451901e835a /media-sound/mac
parentStable for PPC (bug #294573). (diff)
downloadgentoo-2-88d691bb720d8e11bdb86807712fd05633410035.tar.gz
gentoo-2-88d691bb720d8e11bdb86807712fd05633410035.tar.bz2
gentoo-2-88d691bb720d8e11bdb86807712fd05633410035.zip
Add a newer patched version of mac. This one is recommended by the developers of aqualung, an application which uses mac for decoding of Monkey's Audio files.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-sound/mac')
-rw-r--r--media-sound/mac/ChangeLog9
-rw-r--r--media-sound/mac/mac-3.99.4.5.4.ebuild56
2 files changed, 64 insertions, 1 deletions
diff --git a/media-sound/mac/ChangeLog b/media-sound/mac/ChangeLog
index 46a5f17de8ac..900cb84c6ae7 100644
--- a/media-sound/mac/ChangeLog
+++ b/media-sound/mac/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/mac
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/ChangeLog,v 1.6 2009/10/06 16:41:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/ChangeLog,v 1.7 2009/12/20 17:02:48 billie Exp $
+
+*mac-3.99.4.5.4 (20 Dec 2009)
+
+ 20 Dec 2009; Daniel Pielmeier <billie@gentoo.org> +mac-3.99.4.5.4.ebuild:
+ Add a newer patched version of mac. This one is recommended by the
+ developers of aqualung, an application which uses mac for decoding of
+ Monkey's Audio files.
06 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> mac-3.99.4.5.ebuild:
RESTRICT="mirror" because the license doesn't explicitely grant permission
diff --git a/media-sound/mac/mac-3.99.4.5.4.ebuild b/media-sound/mac/mac-3.99.4.5.4.ebuild
new file mode 100644
index 000000000000..be2630088e1d
--- /dev/null
+++ b/media-sound/mac/mac-3.99.4.5.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/mac-3.99.4.5.4.ebuild,v 1.1 2009/12/20 17:02:48 billie Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic multilib versionator
+
+MY_PV=$(get_version_component_range 1-2)-u$(get_version_component_range 3)-b$(get_version_component_range 4)
+PATCH=s$(get_version_component_range 5)
+MY_P=${PN}-${MY_PV}-${PATCH}
+
+DESCRIPTION="Monkey's Audio Codecs"
+HOMEPAGE="http://etree.org/shnutils/shntool/"
+SRC_URI="http://etree.org/shnutils/shntool/support/formats/ape/unix/${MY_PV}/${PATCH}/${MY_P}.tar.gz"
+
+LICENSE="mac"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mmx"
+
+RDEPEND=""
+DEPEND="sys-apps/sed
+ mmx? ( dev-lang/yasm )"
+
+S=${WORKDIR}/${MY_P}
+
+RESTRICT="mirror"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ sed -i -e 's:-O3::' configure || die
+}
+
+pkg_setup() {
+ append-cppflags -DSHNTOOL
+ use mmx && append-ldflags -Wl,-z,noexecstack
+}
+
+src_configure() {
+ local mmx=no
+ use mmx && mmx=yes
+
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ --enable-assembly=${mmx}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog ChangeLog.shntool NEWS README TODO src/Credits.txt \
+ src/History.txt || die
+ dohtml src/Readme.htm || die
+ find "${D}"/usr/$(get_libdir) -name '*.la' -delete || die
+}