summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-02-02 08:33:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-02-02 08:33:25 +0000
commitfee5bd574386d52b577608bf73c915c7d4194ee1 (patch)
tree5aae27450942e10bae1671053198b4203b5f85df /media-sound/lmms
parentDrop -Werror, bug 260948 (diff)
downloadgentoo-2-fee5bd574386d52b577608bf73c915c7d4194ee1.tar.gz
gentoo-2-fee5bd574386d52b577608bf73c915c7d4194ee1.tar.bz2
gentoo-2-fee5bd574386d52b577608bf73c915c7d4194ee1.zip
version bump, by Nikos Chantziaras <realnc@gmail.com>, bug #301358
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lmms')
-rw-r--r--media-sound/lmms/ChangeLog9
-rw-r--r--media-sound/lmms/lmms-0.4.6.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/media-sound/lmms/ChangeLog b/media-sound/lmms/ChangeLog
index 95c75dbe27cc..22a3fd1aa5dc 100644
--- a/media-sound/lmms/ChangeLog
+++ b/media-sound/lmms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lmms
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/ChangeLog,v 1.11 2009/10/06 17:06:06 ayoy Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/ChangeLog,v 1.12 2010/02/02 08:33:25 aballier Exp $
+
+*lmms-0.4.6 (02 Feb 2010)
+
+ 02 Feb 2010; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.6.ebuild:
+ version bump, by Nikos Chantziaras <realnc@gmail.com>, bug #301358
06 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> lmms-0.4.5.ebuild:
Removed alternative dependency on Qt metapackage
diff --git a/media-sound/lmms/lmms-0.4.6.ebuild b/media-sound/lmms/lmms-0.4.6.ebuild
new file mode 100644
index 000000000000..d2eb02a9249f
--- /dev/null
+++ b/media-sound/lmms/lmms-0.4.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/lmms-0.4.6.ebuild,v 1.1 2010/02/02 08:33:25 aballier Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="free alternative to popular programs such as Fruityloops, Cubase and Logic"
+HOMEPAGE="http://lmms.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa debug fftw fluidsynth jack ogg pulseaudio sdl stk vst"
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4[accessibility]
+ >=media-libs/libsndfile-1.0.11
+ >=media-libs/libsamplerate-0.1.7
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( =sci-libs/fftw-3* )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.99.0 )
+ ogg? ( media-libs/libvorbis
+ media-libs/libogg )
+ fluidsynth? ( media-sound/fluidsynth )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl
+ >=media-libs/sdl-sound-1.0.1 )
+ stk? ( media-libs/stk )
+ vst? ( app-emulation/wine )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.5"
+
+DOCS="README AUTHORS TODO"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWANT_SYSTEM_SR=TRUE
+ -DWANT_CAPS=TRUE
+ -DWANT_TAP=TRUE
+ -DWANT_CALF=TRUE
+ $(cmake-utils_use_want alsa ALSA)
+ $(cmake-utils_use_want fftw FFTW3F)
+ $(cmake-utils_use_want jack JACK)
+ $(cmake-utils_use_want ogg OGGVORBIS)
+ $(cmake-utils_use_want pulseaudio PULSEAUDIO)
+ $(cmake-utils_use_want sdl SDL)
+ $(cmake-utils_use_want stk STK)
+ $(cmake-utils_use_want vst VST)
+ $(cmake-utils_use_want fluidsynth SF2)"
+ cmake-utils_src_configure
+}