summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-08-15 11:25:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-08-15 11:25:05 +0000
commitc2d46fd1b53a56dac5a30aaf0845d13fe49d9df4 (patch)
tree59ff8593d8c3650137021daecf0e0b73d942528b /media-sound/lmms
parentDrop alpha (diff)
downloadgentoo-2-c2d46fd1b53a56dac5a30aaf0845d13fe49d9df4.tar.gz
gentoo-2-c2d46fd1b53a56dac5a30aaf0845d13fe49d9df4.tar.bz2
gentoo-2-c2d46fd1b53a56dac5a30aaf0845d13fe49d9df4.zip
version bump, thanks to
Lomaxx <thelomaxx@web.de> for the notification (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lmms')
-rw-r--r--media-sound/lmms/ChangeLog8
-rw-r--r--media-sound/lmms/lmms-0.4.7.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/media-sound/lmms/ChangeLog b/media-sound/lmms/ChangeLog
index 22a3fd1aa5dc..73ce6f614819 100644
--- a/media-sound/lmms/ChangeLog
+++ b/media-sound/lmms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/lmms
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/ChangeLog,v 1.12 2010/02/02 08:33:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/ChangeLog,v 1.13 2010/08/15 11:25:05 aballier Exp $
+
+*lmms-0.4.7 (15 Aug 2010)
+
+ 15 Aug 2010; Alexis Ballier <aballier@gentoo.org> +lmms-0.4.7.ebuild:
+ version bump, thanks to
+ Lomaxx <thelomaxx@web.de> for the notification
*lmms-0.4.6 (02 Feb 2010)
diff --git a/media-sound/lmms/lmms-0.4.7.ebuild b/media-sound/lmms/lmms-0.4.7.ebuild
new file mode 100644
index 000000000000..b02eea5daa4c
--- /dev/null
+++ b/media-sound/lmms/lmms-0.4.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lmms/lmms-0.4.7.ebuild,v 1.1 2010/08/15 11:25:05 aballier Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="free alternative to popular programs such as Fruityloops, Cubase and Logic"
+HOMEPAGE="http://lmms.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa debug fftw fluidsynth jack ogg pulseaudio sdl stk vst"
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4[accessibility]
+ >=media-libs/libsndfile-1.0.11
+ >=media-libs/libsamplerate-0.1.7
+ x11-libs/libXinerama
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( =sci-libs/fftw-3* )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.99.0 )
+ ogg? ( media-libs/libvorbis
+ media-libs/libogg )
+ fluidsynth? ( media-sound/fluidsynth )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl
+ >=media-libs/sdl-sound-1.0.1 )
+ stk? ( media-libs/stk )
+ vst? ( app-emulation/wine )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.5"
+
+DOCS="README AUTHORS TODO"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWANT_SYSTEM_SR=TRUE
+ -DWANT_CAPS=TRUE
+ -DWANT_TAP=TRUE
+ -DWANT_CALF=TRUE
+ $(cmake-utils_use_want alsa ALSA)
+ $(cmake-utils_use_want fftw FFTW3F)
+ $(cmake-utils_use_want jack JACK)
+ $(cmake-utils_use_want ogg OGGVORBIS)
+ $(cmake-utils_use_want pulseaudio PULSEAUDIO)
+ $(cmake-utils_use_want sdl SDL)
+ $(cmake-utils_use_want stk STK)
+ $(cmake-utils_use_want vst VST)
+ $(cmake-utils_use_want fluidsynth SF2)"
+ cmake-utils_src_configure
+}