summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-09 08:43:05 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-09 08:43:05 +0000
commit0ee90e917a1d546d79726c7f2d0c5ef7bb2cfcf3 (patch)
tree9f915aedd129717cac499d6970d558904bf3b7a3 /media-sound/lingot
parentVersion bump. Fix examples documentation install location. (diff)
downloadgentoo-2-0ee90e917a1d546d79726c7f2d0c5ef7bb2cfcf3.tar.gz
gentoo-2-0ee90e917a1d546d79726c7f2d0c5ef7bb2cfcf3.tar.bz2
gentoo-2-0ee90e917a1d546d79726c7f2d0c5ef7bb2cfcf3.zip
Version bump. Update to EAPI 4.
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/lingot')
-rw-r--r--media-sound/lingot/ChangeLog9
-rw-r--r--media-sound/lingot/lingot-0.9.0.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/media-sound/lingot/ChangeLog b/media-sound/lingot/ChangeLog
index afdfae4ede4f..eae63d2296fc 100644
--- a/media-sound/lingot/ChangeLog
+++ b/media-sound/lingot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lingot
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lingot/ChangeLog,v 1.6 2010/04/13 16:46:44 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lingot/ChangeLog,v 1.7 2011/06/09 08:43:05 radhermit Exp $
+
+*lingot-0.9.0 (09 Jun 2011)
+
+ 09 Jun 2011; Tim Harder <radhermit@gentoo.org> +lingot-0.9.0.ebuild:
+ Version bump. Update to EAPI 4.
*lingot-0.8.1 (13 Apr 2010)
diff --git a/media-sound/lingot/lingot-0.9.0.ebuild b/media-sound/lingot/lingot-0.9.0.ebuild
new file mode 100644
index 000000000000..ae850eeb519a
--- /dev/null
+++ b/media-sound/lingot/lingot-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lingot/lingot-0.9.0.ebuild,v 1.1 2011/06/09 08:43:05 radhermit Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="LINGOT Is Not a Guitar-Only Tuner"
+HOMEPAGE="http://www.nongnu.org/lingot"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa jack"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libglade-2
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.102 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7.6-clean-install.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable alsa) \
+ $(use_enable jack)
+}
+
+src_install() {
+ emake DESTDIR="${D}" lingotdocdir="/usr/share/doc/${PF}" install
+}