summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-03-21 03:41:47 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-03-21 03:41:47 +0000
commita7aa8c24e598721cdb1ac2637c9b23f6f13492ea (patch)
tree3c57e198928f1f87ab4bcefbb7154aa1be786cbd /media-sound/line6usb
parentamd64 stable, bug #212649 (diff)
downloadgentoo-2-a7aa8c24e598721cdb1ac2637c9b23f6f13492ea.tar.gz
gentoo-2-a7aa8c24e598721cdb1ac2637c9b23f6f13492ea.tar.bz2
gentoo-2-a7aa8c24e598721cdb1ac2637c9b23f6f13492ea.zip
initial ebuild for Line6 USB driver with POD and Variax support
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound/line6usb')
-rw-r--r--media-sound/line6usb/ChangeLog11
-rw-r--r--media-sound/line6usb/Manifest5
-rw-r--r--media-sound/line6usb/line6usb-0.7.3.ebuild102
-rw-r--r--media-sound/line6usb/metadata.xml14
4 files changed, 132 insertions, 0 deletions
diff --git a/media-sound/line6usb/ChangeLog b/media-sound/line6usb/ChangeLog
new file mode 100644
index 000000000000..cfe01bbceda8
--- /dev/null
+++ b/media-sound/line6usb/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/line6usb
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/line6usb/ChangeLog,v 1.1 2008/03/21 03:41:47 nerdboy Exp $
+
+*line6usb-0.7.3 (21 Mar 2008)
+
+ 21 Mar 2008; Steve Arnold <nerdboy@gentoo.org> +metadata.xml,
+ +line6usb-0.7.3.ebuild:
+ Initial ebuild for Line6 USB driver; somewhat experimental but has
+ history and should work on any arch's that support usb and alsa.
+
diff --git a/media-sound/line6usb/Manifest b/media-sound/line6usb/Manifest
new file mode 100644
index 000000000000..6c9551f10833
--- /dev/null
+++ b/media-sound/line6usb/Manifest
@@ -0,0 +1,5 @@
+DIST driverdocs.pdf 139499 RMD160 71d6a5da001bc726df620b9085f1ef73276493fc SHA1 0119f5925139df29b0df639b0dbbab3f62af6596 SHA256 14cba5afb7bf39ba2dcbf76f095287d35f1542131631d5dc68f6a25648a36a9d
+DIST line6usb-0.7.3.tar.bz2 35600 RMD160 8bd73ec12fd045ec2b956293430edbc800640f54 SHA1 07d223884e69dce7ff0afd2ce640e8ec091ffe19 SHA256 70f66608bee71e6d9b15e9467961cdfa85bacc3616cec7f0b6758d4d1c90e8e4
+EBUILD line6usb-0.7.3.ebuild 2721 RMD160 090c16c516e95facab7bbd63d7dfb8124262caed SHA1 823d2469c483145da1251375f9bfc24034de3691 SHA256 7c76ed2378d512d6e9a6d960252ec7a8b3caff0d5ba2384d370bd9ba81e9de08
+MISC ChangeLog 380 RMD160 7bd488ba1c5d3c18b9d235e20b355818485cbbf8 SHA1 1a01754f16170c6eef2093ea2759deac65ebacbe SHA256 a213d259fba08eede868bdc302336333aac546666e9c10f33cecbff43a6d88cc
+MISC metadata.xml 476 RMD160 fc95f23530882331e9ba2b753415e295c8a17aae SHA1 7fc39d818154998be85419d26534f8ee675f11c5 SHA256 f15e9c7d7b0dfe88b2e19994a427784f00e4e3e759ce4718ab928f690afe474d
diff --git a/media-sound/line6usb/line6usb-0.7.3.ebuild b/media-sound/line6usb/line6usb-0.7.3.ebuild
new file mode 100644
index 000000000000..8bbfc6882be2
--- /dev/null
+++ b/media-sound/line6usb/line6usb-0.7.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/line6usb/line6usb-0.7.3.ebuild,v 1.1 2008/03/21 03:41:47 nerdboy Exp $
+
+inherit linux-mod eutils multilib linux-info
+
+DESCRIPTION="Experimental USB driver for Line6 PODs and the Variax workbench."
+HOMEPAGE="http://www.tanzband-scream.at/line6/"
+SRC_URI="http://www.tanzband-scream.at/line6/download/${P}.tar.bz2
+ doc? ( http://www.tanzband-scream.at/line6/driverdocs.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+# needs testing/keywording with 2.6 kernels on ~ppc/ppc64 (should work)
+IUSE="doc"
+
+CONFIG_CHECK="USB SOUND"
+MODULE_NAMES="line6usb(usb:${S}:${S})"
+ERROR_PODXTPRO="${P} requires the podxtpro driver to be removed first."
+
+RDEPEND="virtual/modutils
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ virtual/alsa
+ virtual/linux-sources
+ sys-apps/debianutils"
+
+pkg_setup() {
+ ABI="${KERNEL_ABI}"
+ linux-mod_pkg_setup
+ BUILD_PARAMS="LINUX_DIR=${KV_DIR} OUTPUT_DIR=${KV_OUT_DIR}"
+ check_upgrade
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ convert_to_m Makefile
+
+ sed -i -e "s:\$\(shell uname -r\):${KV_FULL}:g" \
+ Makefile || die "sed failed!"
+ sed -i -e "s:\$\(shell pwd\):${S}:g" \
+ Makefile || die "sed failed!"
+}
+
+src_compile() {
+ # linux-mod_src_compile doesn't work here
+ set_arch_to_kernel
+ cd "${S}"
+ emake KERNEL_LOCATION="${KERNEL_DIR}" || die "emake failed."
+}
+
+src_install() {
+ DESTDIR="${D}" make install-only || die "make install failed"
+
+ # remove some cruft
+ rm "${D}"usr/bin/remove_old_podxtpro_driver.sh
+
+ dodoc INSTALL
+ if use doc; then
+ insinto /usr/share/doc/${P}
+ doins "${DISTDIR}"/driverdocs.pdf
+ fi
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ elog
+ elog "This is an experimental driver. Not responsible for runaway dogs,"
+ elog "hair-loss, or sterility. You have been warned..."
+ elog
+}
+
+check_upgrade() {
+ local old="podxtpro.${KV_OBJ}"
+ local new="line6usb.${KV_OBJ}"
+ if [[ -e \
+ "/lib/modules/${KV_FULL}/kernel/sound/usb/${old}" ]]; then
+ eerror "The previous version of the driver called podxtpro"
+ eerror "exists on your system."
+ eerror
+ eerror "Please completely remove the old driver before trying"
+ eerror "to install ${P}."
+ eerror
+ die "upgrade not possible with existing driver"
+ elif [[ -e \
+ "/lib/modules/${KV_FULL}/kernel/sound/usb/${new}" ]]; then
+ ewarn
+ ewarn "Collisions are expected here, if you removed the ebuild"
+ ewarn "(because kernel modules are protected by default). Use"
+ ewarn "FEATURES=-collision-protect emerge ... for this package,"
+ ewarn "or remove the old kernel module (${new}) manually first"
+ ewarn "from /lib/modules/${KV_FULL}/kernel/sound/usb/"
+ ewarn
+ has collision-protect "${FEATURES}" &&
+ die 'incompatible with FEATURES=collision-protect'
+ fi
+}
+
diff --git a/media-sound/line6usb/metadata.xml b/media-sound/line6usb/metadata.xml
new file mode 100644
index 000000000000..b1fa34ab498a
--- /dev/null
+++ b/media-sound/line6usb/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+</maintainer>
+<longdescription>
+ This is an experimental Linux driver for the guitar amp, cab, and effects
+ modeller PODxt Pro by Line6 (and similar devices) including preliminary
+ support for the Variax Workbench.
+</longdescription>
+</pkgmetadata>