summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-10-09 23:45:39 +0000
committerAron Griffis <agriffis@gentoo.org>2001-10-09 23:45:39 +0000
commite617ab5294b208b9854e87ea37bd4d1eee8c315e (patch)
treed670d16f2d4f19ba48072fe653469797f24e7d68 /media-sound/lilypond
parentmake esd conditional on use esd (diff)
downloadgentoo-2-e617ab5294b208b9854e87ea37bd4d1eee8c315e.tar.gz
gentoo-2-e617ab5294b208b9854e87ea37bd4d1eee8c315e.tar.bz2
gentoo-2-e617ab5294b208b9854e87ea37bd4d1eee8c315e.zip
Added ebuild for lilypond.
Diffstat (limited to 'media-sound/lilypond')
-rw-r--r--media-sound/lilypond/files/digest-lilypond-1.5.151
-rw-r--r--media-sound/lilypond/lilypond-1.5.15.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/lilypond/files/digest-lilypond-1.5.15 b/media-sound/lilypond/files/digest-lilypond-1.5.15
new file mode 100644
index 000000000000..4790821da6b1
--- /dev/null
+++ b/media-sound/lilypond/files/digest-lilypond-1.5.15
@@ -0,0 +1 @@
+MD5 f14379ded1f1d85bacbb52309ad48e4a lilypond-1.5.15.tar.gz
diff --git a/media-sound/lilypond/lilypond-1.5.15.ebuild b/media-sound/lilypond/lilypond-1.5.15.ebuild
new file mode 100644
index 000000000000..9c71ba22ea2c
--- /dev/null
+++ b/media-sound/lilypond/lilypond-1.5.15.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Aron Griffis <agriffis@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-1.5.15.ebuild,v 1.1 2001/10/09 23:45:39 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Music Typesetter"
+SRC_URI="http://www.lilypond.org/ftp/LilyPond/development/$P.tar.gz"
+HOMEPAGE="http://lilypond.org/"
+
+DEPEND=">=dev-lang/python-2.0-r4
+ >=dev-util/guile-1.4-r3
+ >=sys-devel/flex-2.5.4a-r4
+ >=sys-devel/bison-1.28-r3
+ >=sys-apps/texinfo-4.0-r3
+ >=app-text/tetex-1.0.7-r2"
+
+src_compile() {
+ ./configure \
+ --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr \
+ --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+}