summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-03-28 00:11:13 +0000
committerAron Griffis <agriffis@gentoo.org>2006-03-28 00:11:13 +0000
commit5b5a45c0f50d10847833e97d0f939a6dc78572af (patch)
treea72a30f453dc566d9d63e9ab2f9ebc69ebef7b02 /media-sound/lilypond/lilypond-2.2.6.ebuild
parentMark 3.5.2 3.5.1 3.5.0 ~ia64 (diff)
downloadgentoo-2-5b5a45c0f50d10847833e97d0f939a6dc78572af.tar.gz
gentoo-2-5b5a45c0f50d10847833e97d0f939a6dc78572af.tar.bz2
gentoo-2-5b5a45c0f50d10847833e97d0f939a6dc78572af.zip
Restrict older lilyponds to tetex-2 which provides /usr/bin/inimf #92040.
sed makefiles so that mftrace-1.1.x can be used in place of mftrace-1.0.x #90334 (Portage version: 2.1_pre5-r4)
Diffstat (limited to 'media-sound/lilypond/lilypond-2.2.6.ebuild')
-rw-r--r--media-sound/lilypond/lilypond-2.2.6.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/media-sound/lilypond/lilypond-2.2.6.ebuild b/media-sound/lilypond/lilypond-2.2.6.ebuild
index 7a23268b1873..2fa6188a91bf 100644
--- a/media-sound/lilypond/lilypond-2.2.6.ebuild
+++ b/media-sound/lilypond/lilypond-2.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.2.6.ebuild,v 1.4 2006/03/26 21:51:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.2.6.ebuild,v 1.5 2006/03/28 00:11:13 agriffis Exp $
inherit versionator
@@ -19,7 +19,7 @@ KEYWORDS="~alpha ~x86 ~ppc ~sparc -amd64"
RDEPEND=">=dev-util/guile-1.6.4
virtual/ghostscript
- virtual/tetex
+ =virtual/tetex-2*
>=dev-lang/python-2.2.3-r1"
DEPEND="${RDEPEND}
@@ -29,13 +29,19 @@ DEPEND="${RDEPEND}
>=sys-devel/flex-2.5.4a-r5
>=sys-devel/gcc-3.1-r8
>=sys-devel/make-3.80
- =app-text/mftrace-1.0*
+ >=app-text/mftrace-1.1.16
sys-devel/bison !=sys-devel/bison-1.75
doc? ( media-gfx/imagemagick
>=media-libs/netpbm-9.12-r4 )"
src_unpack() {
- unpack ${A} || die "unpack failed"
+ unpack ${A}
+ # Fix makefiles to work with recent mftrace #90334
+ grep -rlZ 'MFTRACE.*--pf[ab]' --include=GNUmakefile --include=\*.make ${S} | \
+ xargs -0r sed -i '
+ s/--pfa --pfb/--formats=PFA,PFB/;
+ s/--pfa/--formats=PFA/;
+ s/--pfa/--formats=PFA/'
}
src_compile() {
@@ -43,6 +49,7 @@ src_compile() {
# this package. See bug 21305
PATH="$(echo ":${PATH}:" | sed 's/:[^:]*ccache[^:]*:/:/;s/^://;s/:$//;')"
+ addwrite /root/.PfaEdit # fontforge, see bug 127723
addwrite /dev/stderr
addwrite /var/cache/fonts
addwrite /usr/share/texmf/fonts