summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2006-09-11 03:06:22 +0000
committerLuis Medinas <metalgod@gentoo.org>2006-09-11 03:06:22 +0000
commit55322c1948b2212aa19b62c46f1267d0c1016eb1 (patch)
treef6284f35ce38b61fe0c2dd3f78e7f1cdb6701426 /media-sound/lame
parentStable on SPARC wrt bug #146912. (diff)
downloadgentoo-2-55322c1948b2212aa19b62c46f1267d0c1016eb1.tar.gz
gentoo-2-55322c1948b2212aa19b62c46f1267d0c1016eb1.tar.bz2
gentoo-2-55322c1948b2212aa19b62c46f1267d0c1016eb1.zip
Version Bump. Thanks to Kai <gentoo@altkai.ml1.net> closes bug #145286.
(Portage version: 2.1.1)
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog7
-rw-r--r--media-sound/lame/files/digest-lame-3.97_beta33
-rw-r--r--media-sound/lame/lame-3.97_beta3.ebuild75
3 files changed, 84 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 4869f3f45378..f6b75c587185 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lame
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.70 2006/05/30 10:01:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.71 2006/09/11 03:06:22 metalgod Exp $
+
+*lame-3.97_beta3 (11 Sep 2006)
+
+ 11 Sep 2006; Luis Medinas <metalgod@gentoo.org> +lame-3.97_beta3.ebuild:
+ Version Bump. Thanks to Kai <gentoo@altkai.ml1.net> closes bug #145286.
*lame-3.97_beta2 (30 May 2006)
diff --git a/media-sound/lame/files/digest-lame-3.97_beta3 b/media-sound/lame/files/digest-lame-3.97_beta3
new file mode 100644
index 000000000000..551cce85e535
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.97_beta3
@@ -0,0 +1,3 @@
+MD5 4fbdad5d4203e75125cf5b875b171ac0 lame-3.97b3_.tar.gz 1328041
+RMD160 ae3041acfe3e0e120faf5dc02a38ebb35f58aee9 lame-3.97b3_.tar.gz 1328041
+SHA256 ff13fca5d2816a9e807bda5da7ccdf7009978988467270d82d9d1b94c53d2576 lame-3.97b3_.tar.gz 1328041
diff --git a/media-sound/lame/lame-3.97_beta3.ebuild b/media-sound/lame/lame-3.97_beta3.ebuild
new file mode 100644
index 000000000000..740b9f2aad5b
--- /dev/null
+++ b/media-sound/lame/lame-3.97_beta3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.97_beta3.ebuild,v 1.1 2006/09/11 03:06:22 metalgod Exp $
+
+inherit flag-o-matic toolchain-funcs eutils autotools
+
+MY_P="${P/_beta/b}"
+S="${WORKDIR}/${P%%_beta*}"
+
+DESCRIPTION="LAME Ain't an MP3 Encoder"
+HOMEPAGE="http://lame.sourceforge.net"
+SRC_URI="mirror://sourceforge/lame/${MY_P}_.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk debug"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # The frontened tries to link staticly, but we prefer shared libs
+ epatch "${FILESDIR}"/${PN}-3.96.1-shared-frontend.patch
+
+ # If ccc (alpha compiler) is installed on the system, the default
+ # configure is broken, fix it to respect CC. This is only
+ # directly broken for ARCH=alpha but would affect anybody with a
+ # ccc binary in their PATH. Bug #41908 (26 Jul 2004 agriffis)
+ epatch "${FILESDIR}"/${PN}-3.96-ccc.patch
+
+ # Make sure -lm is linked in the library to fix other programs linking to
+ # this while using --as-needed
+ epatch "${FILESDIR}"/${PN}-3.96.1-asneeded.patch
+
+ AT_M4DIR="${S}" eautoreconf || die
+ epunt_cxx # embedded bug #74498
+}
+
+src_compile() {
+ # take out -fomit-frame-pointer from CFLAGS if k6-2
+ is-flag "-march=k6-3" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && filter-flags "-fomit-frame-pointer"
+
+ [ "`gcc-fullversion`" == "3.3.2" ] && replace-flags -march=2.0 -march=1.0
+
+ # The user sets compiler optimizations... But if you'd like
+ # lame to choose it's own... uncomment one of these (experiMENTAL)
+ # myconf="${myconf} --enable-expopt=full \
+ # myconf="${myconf} --enable-expopt=norm \
+
+ econf \
+ --enable-shared \
+ --enable-mp3rtp \
+ $(use_enable debug debug norm) \
+ $(use_enable gtk mp3x) \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" pkghtmldir="/usr/share/doc/${PF}/html" install || die
+
+ dodoc API ChangeLog HACKING PRESETS.draft README* STYLEGUIDE TODO USAGE
+ dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
+
+ dobin "${S}"/misc/mlame || die
+}