summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-28 17:04:09 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-28 17:04:09 +0000
commita3dc0183eb0f3dc677852423435343da918b1d8a (patch)
tree19dbece133b63bfb115c44bab8d0e9ac7d2cbc33 /media-sound/lame/lame-3.96.1.ebuild
parentInital import. (Manifest recommit) (diff)
downloadgentoo-2-a3dc0183eb0f3dc677852423435343da918b1d8a.tar.gz
gentoo-2-a3dc0183eb0f3dc677852423435343da918b1d8a.tar.bz2
gentoo-2-a3dc0183eb0f3dc677852423435343da918b1d8a.zip
If ccc (alpha compiler) is installed on the system, the default configure is broken, fix it to respect CC. This is only directly broken for ARCH=alpha but would affect anybody with a ccc binary in their PATH. #41908
Diffstat (limited to 'media-sound/lame/lame-3.96.1.ebuild')
-rw-r--r--media-sound/lame/lame-3.96.1.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/media-sound/lame/lame-3.96.1.ebuild b/media-sound/lame/lame-3.96.1.ebuild
index f901433a8288..d1b87c1a149d 100644
--- a/media-sound/lame/lame-3.96.1.ebuild
+++ b/media-sound/lame/lame-3.96.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.96.1.ebuild,v 1.1 2004/07/26 04:55:07 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.96.1.ebuild,v 1.2 2004/07/28 17:04:09 agriffis Exp $
IUSE="gtk debug"
inherit flag-o-matic gcc eutils
-DESCRIPTION="LAME Ain't an Mp3 Encoder"
+DESCRIPTION="LAME Ain't an MP3 Encoder"
HOMEPAGE="http://lame.sourceforge.net"
SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
@@ -18,7 +18,20 @@ RDEPEND=">=sys-libs/ncurses-5.2
gtk? ( =x11-libs/gtk+-1.2* )"
DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )"
+ x86? ( dev-lang/nasm )
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+
+ # If ccc (alpha compiler) is installed on the system, the default
+ # configure is broken, fix it to respect CC. This is only
+ # directly broken for ARCH=alpha but would affect anybody with a
+ # ccc binary in their PATH. Bug #41908 (26 Jul 2004 agriffis)
+ epatch ${FILESDIR}/lame-3.96-ccc.patch
+ autoconf || die
+}
src_compile() {
# take out -fomit-frame-pointer from CFLAGS if k6-2