summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-06-23 23:57:25 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-06-23 23:57:25 +0000
commitb6d078f650d3e786e40e17068372947ad56e7060 (patch)
treea847e80836d97e1e2e74f972130a1392495e9b93 /media-sound/kid3
parentStable for HPPA (bug #181941). (diff)
downloadgentoo-2-b6d078f650d3e786e40e17068372947ad56e7060.tar.gz
gentoo-2-b6d078f650d3e786e40e17068372947ad56e7060.tar.bz2
gentoo-2-b6d078f650d3e786e40e17068372947ad56e7060.zip
Version bump as per bug 182997. Added localisation support.
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'media-sound/kid3')
-rw-r--r--media-sound/kid3/ChangeLog7
-rw-r--r--media-sound/kid3/files/digest-kid3-0.93
-rw-r--r--media-sound/kid3/kid3-0.9.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/media-sound/kid3/ChangeLog b/media-sound/kid3/ChangeLog
index 8b8c65f11f96..b58241526a94 100644
--- a/media-sound/kid3/ChangeLog
+++ b/media-sound/kid3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/kid3
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.26 2007/02/13 10:10:09 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.27 2007/06/23 23:57:25 philantrop Exp $
+
+*kid3-0.9 (23 Jun 2007)
+
+ 23 Jun 2007; Wulf C. Krueger <philantrop@gentoo.org> +kid3-0.9.ebuild:
+ Version bump as per bug 182997. Added localisation support.
13 Feb 2007; Markus Rothe <corsair@gentoo.org> kid3-0.8.1.ebuild:
Stable on ppc64; bug #164580
diff --git a/media-sound/kid3/files/digest-kid3-0.9 b/media-sound/kid3/files/digest-kid3-0.9
new file mode 100644
index 000000000000..009b470aef56
--- /dev/null
+++ b/media-sound/kid3/files/digest-kid3-0.9
@@ -0,0 +1,3 @@
+MD5 b332c00a0bf7926085f102fe2ca115a1 kid3-0.9.tar.gz 922146
+RMD160 e02921ee9027f544f0713ec0f0f543b562637b43 kid3-0.9.tar.gz 922146
+SHA256 4720a478e7f1f5cb2551c43bc130b19904fcc54516e276aa3c3d8e5fa81c10ef kid3-0.9.tar.gz 922146
diff --git a/media-sound/kid3/kid3-0.9.ebuild b/media-sound/kid3/kid3-0.9.ebuild
new file mode 100644
index 000000000000..c8bc9d4eaa9d
--- /dev/null
+++ b/media-sound/kid3/kid3-0.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.9.ebuild,v 1.1 2007/06/23 23:57:25 philantrop Exp $
+
+inherit kde
+
+DESCRIPTION="A simple ID3 tag editor for QT/KDE."
+HOMEPAGE="http://kid3.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kid3/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="flac taglib vorbis"
+
+DEPEND=">=media-libs/id3lib-3.8.3
+ taglib? ( >=media-libs/taglib-1.4-r1 )
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )"
+
+need-kde 3
+
+LANGS="de es fr ru"
+LANGS_DOC="de en"
+
+for X in ${LANGS} ${LANGS_DOC} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${P}/po"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}.po"
+ done
+ sed -i -e "s:POFILES =.*:POFILES = ${MAKE_LANGS}:" Makefile.am
+
+ MAKE_LANGS=""
+ cd "${WORKDIR}/${P}/doc"
+ for X in ${LANGS_DOC} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ sed -i -e "s:SUBDIRS =.*:SUBDIRS = ${MAKE_LANGS}:" Makefile.am
+ rm -f ${S}/configure
+}
+
+# Support for the KDE libraries is optional,
+# but the configure step that detects them
+# cannot be avoided. So KDE support is forced on.
+
+src_compile() {
+ local myconf="--with-kde
+ $(use_with vorbis)
+ $(use_with flac)
+ $(use_with taglib)
+ --without-musicbrainz"
+
+ kde_src_compile
+}