summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-02-08 03:40:57 +0000
committerAron Griffis <agriffis@gentoo.org>2004-02-08 03:40:57 +0000
commitaf5b237052b0542f4d155e9394464cfcf9827aea (patch)
tree0a9db18de8acf2b7d2ba5181a9456e6f6a3d25c6 /media-sound/id3v2
parentFixed for non-root users hopefully. (diff)
downloadgentoo-2-af5b237052b0542f4d155e9394464cfcf9827aea.tar.gz
gentoo-2-af5b237052b0542f4d155e9394464cfcf9827aea.tar.bz2
gentoo-2-af5b237052b0542f4d155e9394464cfcf9827aea.zip
Fix bug 33814 with a patch to prevent an uninitialized variable
Diffstat (limited to 'media-sound/id3v2')
-rw-r--r--media-sound/id3v2/ChangeLog8
-rw-r--r--media-sound/id3v2/Manifest3
-rw-r--r--media-sound/id3v2/files/digest-id3v2-0.1.9-r11
-rw-r--r--media-sound/id3v2/files/id3v2-0.1.9-alpha.patch17
-rw-r--r--media-sound/id3v2/id3v2-0.1.9-r1.ebuild38
5 files changed, 66 insertions, 1 deletions
diff --git a/media-sound/id3v2/ChangeLog b/media-sound/id3v2/ChangeLog
index 5199b55f0931..adac93b6013a 100644
--- a/media-sound/id3v2/ChangeLog
+++ b/media-sound/id3v2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/id3v2
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/id3v2/ChangeLog,v 1.6 2004/01/22 22:31:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/id3v2/ChangeLog,v 1.7 2004/02/08 03:40:57 agriffis Exp $
+
+*id3v2-0.1.9-r1 (07 Feb 2004)
+
+ 07 Feb 2004; Aron Griffis <agriffis@gentoo.org> id3v2-0.1.9-r1.ebuild,
+ files/id3v2-0.1.9-alpha.patch:
+ Fix bug 33814 with a patch to prevent an uninitialized variable
22 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org> id3v2-0.1.7.ebuild,
id3v2-0.1.9.ebuild:
diff --git a/media-sound/id3v2/Manifest b/media-sound/id3v2/Manifest
index 91597cdd5246..d0b81ec52196 100644
--- a/media-sound/id3v2/Manifest
+++ b/media-sound/id3v2/Manifest
@@ -1,5 +1,8 @@
MD5 ae5f9c3485c4e0f79f5a7df43df86a09 ChangeLog 815
MD5 ae06531ebf046cae8ff977f0e262bb07 id3v2-0.1.7.ebuild 750
MD5 3512e5bd3d73e7d144b52ba0974aa8ae id3v2-0.1.9.ebuild 783
+MD5 942da9cf90a38801705bb472a4e621c6 id3v2-0.1.9-r1.ebuild 910
MD5 d99b419340bbb9a9027cbf9a6f70c0ac files/digest-id3v2-0.1.7 62
MD5 c6d37db10f48d3d1bd9a5ff283f8095d files/digest-id3v2-0.1.9 62
+MD5 735e277d7328b86d3b121b158473d939 files/id3v2-0.1.9-alpha.patch 679
+MD5 c6d37db10f48d3d1bd9a5ff283f8095d files/digest-id3v2-0.1.9-r1 62
diff --git a/media-sound/id3v2/files/digest-id3v2-0.1.9-r1 b/media-sound/id3v2/files/digest-id3v2-0.1.9-r1
new file mode 100644
index 000000000000..5906a6bd07f2
--- /dev/null
+++ b/media-sound/id3v2/files/digest-id3v2-0.1.9-r1
@@ -0,0 +1 @@
+MD5 544862d82224312595bf5a45422d1a49 id3v2-0.1.9.tar.gz 21144
diff --git a/media-sound/id3v2/files/id3v2-0.1.9-alpha.patch b/media-sound/id3v2/files/id3v2-0.1.9-alpha.patch
new file mode 100644
index 000000000000..3504efcf6d62
--- /dev/null
+++ b/media-sound/id3v2/files/id3v2-0.1.9-alpha.patch
@@ -0,0 +1,17 @@
+Prevent a segfault on alpha and any other arch that doesn't always get
+zero-initialized automatics. Frankly the code in this segment looks
+pretty broken to me, but I'm just fixing the segfault...
+
+07 Feb 2004 agriffis
+
+--- id3v2-0.1.9/id3v2.cpp.alpha 2003-02-25 11:28:20.000000000 -0500
++++ id3v2-0.1.9/id3v2.cpp 2004-02-07 22:28:39.000000000 -0500
+@@ -409,7 +409,7 @@
+ {
+ // check if there is a total track number and if we only have
+ // the track number for this file. In this case combine them.
+- char *currentTrackNum, *newTrackNum;
++ char *currentTrackNum, *newTrackNum = NULL;
+
+ if (pFrame != NULL)
+ {
diff --git a/media-sound/id3v2/id3v2-0.1.9-r1.ebuild b/media-sound/id3v2/id3v2-0.1.9-r1.ebuild
new file mode 100644
index 000000000000..0cf171380170
--- /dev/null
+++ b/media-sound/id3v2/id3v2-0.1.9-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/id3v2/id3v2-0.1.9-r1.ebuild,v 1.1 2004/02/08 03:40:57 agriffis Exp $
+
+DESCRIPTION="A command line editor for id3v2 tags."
+HOMEPAGE="http://id3v2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/id3v2/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="media-libs/id3lib"
+
+src_unpack()
+{
+ unpack ${A} && cd ${S} || die "unpack failed"
+
+ # The tarball came with a compiled binary. ;^)
+ make clean
+
+ # Use our own CXXFLAGS
+ sed -i -e "/g++/ s|-g|${CXXFLAGS}|" Makefile || die "sed failed"
+
+ # Fix segfault on alpha (and probably other architectures)
+ epatch ${FILESDIR}/id3v2-0.1.9-alpha.patch
+}
+
+src_compile()
+{
+ emake || die
+}
+
+src_install()
+{
+ dobin id3v2
+ doman id3v2.1
+ dodoc COPYING INSTALL README
+}