summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-09-26 15:56:59 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-09-26 15:56:59 +0000
commitc48a219549dcfe1a7bf299652690e11349c8145e (patch)
tree5e4c375b2f36aa55bd294a3abc8bccd606bb4d59 /media-sound/grip
parentMasking grip-3.0.3 pending unfreeze. (diff)
downloadgentoo-2-c48a219549dcfe1a7bf299652690e11349c8145e.tar.gz
gentoo-2-c48a219549dcfe1a7bf299652690e11349c8145e.tar.bz2
gentoo-2-c48a219549dcfe1a7bf299652690e11349c8145e.zip
Version 3.0.3 is masked pending unfreeze.
- Cleaned the previous ebuild moving the patching step into src_unpack(), where it belongs. - Upon further examination, it appears that the above patching is no longer needed. Hence src_unpack is commented out pending testing. - Updated to version 3.0.3.
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/ChangeLog11
-rw-r--r--media-sound/grip/files/digest-grip-3.0.31
-rw-r--r--media-sound/grip/grip-3.0.3.ebuild58
3 files changed, 69 insertions, 1 deletions
diff --git a/media-sound/grip/ChangeLog b/media-sound/grip/ChangeLog
index 768ed7172a0a..36bef67c756b 100644
--- a/media-sound/grip/ChangeLog
+++ b/media-sound/grip/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/grip
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.7 2002/06/19 14:29:07 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.8 2002/09/26 15:56:59 agenkin Exp $
+
+*grip-3.0.3 (26 Sep 2002)
+
+ 26 Sep 2002; Arcady Genkin <agenkin@gentoo.org> grip-3.0.3.ebuild :
+
+ Update to 3.0.3.
+ Moved Makefile.in mangling into src_unpack(), where it belongs.
+ Commented out src_unpack(), since the aforementioned mangling no
+ longer seems to be required.
*grip-3.0.1 (19 Jun 2002)
diff --git a/media-sound/grip/files/digest-grip-3.0.3 b/media-sound/grip/files/digest-grip-3.0.3
new file mode 100644
index 000000000000..c8ff2c6ca7ab
--- /dev/null
+++ b/media-sound/grip/files/digest-grip-3.0.3
@@ -0,0 +1 @@
+MD5 b580ca44ed12d478bb6289d09cb7ad38 grip-3.0.3.tar.gz 885333
diff --git a/media-sound/grip/grip-3.0.3.ebuild b/media-sound/grip/grip-3.0.3.ebuild
new file mode 100644
index 000000000000..e6ed4989e521
--- /dev/null
+++ b/media-sound/grip/grip-3.0.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.0.3.ebuild,v 1.1 2002/09/26 15:56:59 agenkin Exp $
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper."
+HOMEPAGE="http://www.nostatic.org/grip"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ =sys-libs/db-1*
+ media-sound/lame
+ media-sound/cdparanoia
+ media-libs/id3lib
+ gnome-base/gnome-libs
+ gnome-base/ORBit
+ gnome-base/libghttp
+ oggvorbis? ( media-sound/vorbis-tools )
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+SRC_URI="http://www.nostatic.org/grip/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+# Looks like the Makefile.in mangling is no longer required.
+# Arcady Genkin <agenkin@gentoo.org>, Sep 26, 2002.
+#
+#src_unpack() {
+#
+# unpack ${A}
+# cd ${S}
+#
+# # apply CFLAGS
+# mv Makefile.in Makefile.in.old
+# sed -e "s/CFLAGS = -g -O2/CFLAGS = ${CFLAGS}/" \
+# Makefile.in.old > Makefile.in
+#
+# # fix cdparanoia libs not linking
+# mv src/Makefile.in src/Makefile.in.orig
+# sed -e "s/LDFLAGS =/LDFLAGS = -lcdda_interface -lcdda_paranoia/" \
+# src/Makefile.in.orig > src/Makefile.in
+#}
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+
+ dodoc ABOUT-NLS AUTHORS CREDITS COPYING ChangeLog README TODO NEWS
+}