summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-02-02 02:17:53 +0000
committerTod Neidt <tod@gentoo.org>2002-02-02 02:17:53 +0000
commita890a8bc4de59940e8a33a183970c32178a229bf (patch)
treefbbd4f9671a77c23a650f36228d833beaacf7a2b /media-sound/grip
parentadded new version 2.7.7 of diffutils (diff)
downloadgentoo-2-a890a8bc4de59940e8a33a183970c32178a229bf.tar.gz
gentoo-2-a890a8bc4de59940e8a33a183970c32178a229bf.tar.bz2
gentoo-2-a890a8bc4de59940e8a33a183970c32178a229bf.zip
New version (last track crashing bugfix), just an ebuild copy.
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/files/digest-grip-2.98.51
-rw-r--r--media-sound/grip/grip-2.98.5.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/grip/files/digest-grip-2.98.5 b/media-sound/grip/files/digest-grip-2.98.5
new file mode 100644
index 000000000000..f12079412a6c
--- /dev/null
+++ b/media-sound/grip/files/digest-grip-2.98.5
@@ -0,0 +1 @@
+MD5 4577b8b13c5d5f297a8811b173fe67f3 grip-2.98.5.tar.gz 778617
diff --git a/media-sound/grip/grip-2.98.5.ebuild b/media-sound/grip/grip-2.98.5.ebuild
new file mode 100644
index 000000000000..2a1b2ca7f8d7
--- /dev/null
+++ b/media-sound/grip/grip-2.98.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-2.98.5.ebuild,v 1.1 2002/02/02 02:17:53 tod Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+ based Audio CD Ripper"
+SRC_URI="http://www.nostatic.org/grip/${P}.tar.gz"
+HOMEPAGE="http://www.nostatic.org/grip"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10
+ media-sound/lame
+ media-sound/cdparanoia
+ media-libs/id3lib
+ virtual/x11
+ gnome-base/gnome-libs
+ gnome-base/ORBit
+ gnome-base/libghttp"
+
+src_compile() {
+ local myconf=""
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ # apply CFLAGS
+ mv Makefile.in Makefile.in.old
+ sed -e "s/CFLAGS = -g -O2/CFLAGS = ${CFLAGS}/" \
+ Makefile.in.old > Makefile.in
+
+ # fix cdparanoia libs not linking
+ mv src/Makefile.in src/Makefile.in.orig
+ sed -e "s/LDFLAGS =/LDFLAGS = -lcdda_interface -lcdda_paranoia/" \
+ src/Makefile.in.orig > src/Makefile.in
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc ABOUT-NLS AUTHORS CREDITS LICENSE CHANGES README TODO
+}