summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-04-04 20:47:46 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-04-04 20:47:46 +0000
commit6a5fe4a5b74fb8a519f49748d7c2f789e60af7c6 (patch)
treea883f2bf744ee90545a78c57bde2679ba7bf868d /media-sound/google-musicmanager
parentLeave Python as the sole maintainer since I'm part of it. (diff)
downloadgentoo-2-6a5fe4a5b74fb8a519f49748d7c2f789e60af7c6.tar.gz
gentoo-2-6a5fe4a5b74fb8a519f49748d7c2f789e60af7c6.tar.bz2
gentoo-2-6a5fe4a5b74fb8a519f49748d7c2f789e60af7c6.zip
version bump
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'media-sound/google-musicmanager')
-rw-r--r--media-sound/google-musicmanager/ChangeLog9
-rw-r--r--media-sound/google-musicmanager/google-musicmanager-1.0.60.7918_beta.ebuild (renamed from media-sound/google-musicmanager/google-musicmanager-1.0.54.4672_beta.ebuild)38
2 files changed, 31 insertions, 16 deletions
diff --git a/media-sound/google-musicmanager/ChangeLog b/media-sound/google-musicmanager/ChangeLog
index 81f9ca027c5b..9ccd862c0b58 100644
--- a/media-sound/google-musicmanager/ChangeLog
+++ b/media-sound/google-musicmanager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/google-musicmanager
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/ChangeLog,v 1.30 2013/03/10 16:30:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/ChangeLog,v 1.31 2013/04/04 20:47:46 ottxor Exp $
+
+*google-musicmanager-1.0.60.7918_beta (04 Apr 2013)
+
+ 04 Apr 2013; Christoph Junghans <ottxor@gentoo.org>
+ +google-musicmanager-1.0.60.7918_beta.ebuild,
+ -google-musicmanager-1.0.54.4672_beta.ebuild:
+ version bump
10 Mar 2013; Agostino Sarubbo <ago@gentoo.org>
google-musicmanager-1.0.55.7425_beta-r2.ebuild:
diff --git a/media-sound/google-musicmanager/google-musicmanager-1.0.54.4672_beta.ebuild b/media-sound/google-musicmanager/google-musicmanager-1.0.60.7918_beta.ebuild
index d2f5801b6cea..eb198f57ed30 100644
--- a/media-sound/google-musicmanager/google-musicmanager-1.0.54.4672_beta.ebuild
+++ b/media-sound/google-musicmanager/google-musicmanager-1.0.60.7918_beta.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/google-musicmanager-1.0.54.4672_beta.ebuild,v 1.3 2013/03/02 21:55:09 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/google-musicmanager-1.0.60.7918_beta.ebuild,v 1.1 2013/04/04 20:47:46 ottxor Exp $
-EAPI=4
+EAPI=5
inherit eutils unpacker
@@ -19,11 +19,14 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="log"
-RESTRICT="fetch strip"
+RESTRICT="strip mirror"
RDEPEND="
dev-libs/expat
dev-libs/glib:2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
media-libs/flac
media-libs/fontconfig
media-libs/freetype:2
@@ -36,9 +39,6 @@ RDEPEND="
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtwebkit:4
log? ( dev-libs/log4cxx )
"
@@ -54,17 +54,20 @@ QA_FLAGS_IGNORED="${INSTALL_BASE}/.*"
S="${WORKDIR}/${INSTALL_BASE}"
pkg_nofetch() {
- elog "This version is no longer available from Google and the license prevents mirroring."
- elog "This ebuild is intended for users who already downloaded it previously and have problems"
- elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
- use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
- elog "it with google: http://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
- elog "and copy the file ${MY_PKG} to ${DISTDIR}."
+ einfo "This version is no longer available from Google."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+}
+
+pkg_setup() {
+ if type -p ifconfig > /dev/null && ! ifconfig | grep -Eq "^(eth|wlan)" ; then
+ ewarn "${PN} needs at least one network interface named eth* or wlan* (bug #455896 and bug #459816)"
+ fi
}
src_install() {
insinto "/${INSTALL_BASE}"
- doins config.xml product_logo*
+ doins config.json product_logo*
exeinto "/${INSTALL_BASE}"
chrpath -d MusicManager || die
@@ -74,6 +77,11 @@ src_install() {
dosym /"${INSTALL_BASE}"/google-musicmanager /opt/bin/google-musicmanager
- make_desktop_entry "${PN}" "Google Music Manager" \
- "/${INSTALL_BASE}/product_logo_32.xpm" "AudioVideo;Audio;Player"
+ local icon size
+ for icon in product_logo_*.png; do
+ size=${icon#product_logo_}
+ size=${size%.png}
+ newicon -s "${size}" "${icon}" ${PN}.png
+ done
+ domenu ${PN}.desktop
}