summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-03-09 01:13:48 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-03-09 01:13:48 +0000
commit18211e89d39f5fc6a0a4e0439355cc104854962e (patch)
treeaa59f9c44598be80665b3d011ec9cdf1d9d22c21 /media-sound/google-musicmanager
parentadded colorhug-client to the system (diff)
downloadgentoo-2-18211e89d39f5fc6a0a4e0439355cc104854962e.tar.gz
gentoo-2-18211e89d39f5fc6a0a4e0439355cc104854962e.tar.bz2
gentoo-2-18211e89d39f5fc6a0a4e0439355cc104854962e.zip
version bump (bug #407451)
(Portage version: 2.2.0_alpha90/cvs/Linux i686)
Diffstat (limited to 'media-sound/google-musicmanager')
-rw-r--r--media-sound/google-musicmanager/ChangeLog9
-rw-r--r--media-sound/google-musicmanager/google-musicmanager-1.0.24.7712_beta.ebuild11
-rw-r--r--media-sound/google-musicmanager/google-musicmanager-1.0.27.206_beta.ebuild75
3 files changed, 90 insertions, 5 deletions
diff --git a/media-sound/google-musicmanager/ChangeLog b/media-sound/google-musicmanager/ChangeLog
index 32586f82d9b4..42f843b8eb15 100644
--- a/media-sound/google-musicmanager/ChangeLog
+++ b/media-sound/google-musicmanager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/google-musicmanager
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/ChangeLog,v 1.8 2012/02/20 04:24:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/ChangeLog,v 1.9 2012/03/09 01:13:48 ottxor Exp $
+
+*google-musicmanager-1.0.27.206_beta (09 Mar 2012)
+
+ 09 Mar 2012; Christoph Junghans <ottxor@gentoo.org>
+ google-musicmanager-1.0.24.7712_beta.ebuild,
+ +google-musicmanager-1.0.27.206_beta.ebuild:
+ version bump (bug #407451)
20 Feb 2012; Mike Gilbert <floppym@gentoo.org> metadata.xml:
Drop no-herd.
diff --git a/media-sound/google-musicmanager/google-musicmanager-1.0.24.7712_beta.ebuild b/media-sound/google-musicmanager/google-musicmanager-1.0.24.7712_beta.ebuild
index b4d369607a43..9c1424708d94 100644
--- a/media-sound/google-musicmanager/google-musicmanager-1.0.24.7712_beta.ebuild
+++ b/media-sound/google-musicmanager/google-musicmanager-1.0.24.7712_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/google-musicmanager-1.0.24.7712_beta.ebuild,v 1.1 2012/01/28 02:37:29 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/google-musicmanager-1.0.24.7712_beta.ebuild,v 1.2 2012/03/09 01:13:48 ottxor Exp $
EAPI=4
@@ -53,9 +53,12 @@ QA_DT_HASH="${INSTALL_BASE}/.*"
S="${WORKDIR}/${INSTALL_BASE}"
pkg_nofetch() {
- einfo "This version is no longer available from Google."
- einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
- einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+ elog "This version is no longer available from Google and the license prevents mirroring."
+ elog "This ebuild is intended for users who already downloaded it previously and have problems"
+ elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
+ use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
+ elog "it with google: http://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
+ elog "and copy the file ${MY_PKG} to ${DISTDIR}."
}
src_unpack() {
diff --git a/media-sound/google-musicmanager/google-musicmanager-1.0.27.206_beta.ebuild b/media-sound/google-musicmanager/google-musicmanager-1.0.27.206_beta.ebuild
new file mode 100644
index 000000000000..e9e61e0bd729
--- /dev/null
+++ b/media-sound/google-musicmanager/google-musicmanager-1.0.27.206_beta.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/google-musicmanager-1.0.27.206_beta.ebuild,v 1.1 2012/03/09 01:13:48 ottxor Exp $
+
+EAPI=4
+
+inherit eutils unpacker
+
+MY_URL="http://dl.google.com/linux/musicmanager/deb/pool/main/${P:0:1}/${PN}-beta"
+MY_PKG="${PN}-beta_${PV/_beta}-r0_i386.deb"
+
+DESCRIPTION="Google Music Manager is a application for adding music to your Google Music library."
+HOMEPAGE="http://music.google.com"
+SRC_URI="x86? ( ${MY_URL}/${MY_PKG} )
+ amd64? ( ${MY_URL}/${MY_PKG/i386/amd64} )"
+
+LICENSE="google-talkplugin Apache-2.0 MIT LGPL-2.1 gSOAP BSD FDL-1.2 MPL-1.1 openssl ZLIB as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="log"
+
+RESTRICT="strip mirror"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/glib:2
+ media-libs/flac
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/libogg
+ media-libs/libvorbis
+ net-dns/libidn
+ sys-libs/glibc
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ log? ( dev-libs/log4cxx )
+ "
+
+DEPEND="app-arch/xz-utils
+ app-admin/chrpath"
+
+INSTALL_BASE="opt/google/musicmanager"
+
+QA_TEXTRELS="${INSTALL_BASE}/libmpgdec.so.0"
+
+QA_DT_HASH="${INSTALL_BASE}/.*"
+
+S="${WORKDIR}/${INSTALL_BASE}"
+
+pkg_nofetch() {
+ einfo "This version is no longer available from Google."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+}
+
+src_install() {
+ insinto "/${INSTALL_BASE}"
+ doins config.xml product_logo*
+
+ exeinto "/${INSTALL_BASE}"
+ chrpath -d MusicManager || die
+ doexe MusicManager google-musicmanager minidump_upload
+ #TODO unbundle this
+ doexe libaacdec.so libaudioenc.so.0 libmpgdec.so.0 libid3tag.so
+
+ dosym /"${INSTALL_BASE}"/google-musicmanager /opt/bin/google-musicmanager
+
+ make_desktop_entry "${PN}" "Google Music Manager" \
+ "/${INSTALL_BASE}/product_logo_32.xpm" "AudioVideo;Audio;Player;Music"
+}