summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-24 22:46:34 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-24 22:46:34 +0000
commit8c41803c7a25dd70af3cbad7b1f5d4236ee5c951 (patch)
treeed4c4a2f68d23de66c3c7c0b5c0f586823becc57 /media-sound/gnump3d
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-8c41803c7a25dd70af3cbad7b1f5d4236ee5c951.tar.gz
gentoo-2-8c41803c7a25dd70af3cbad7b1f5d4236ee5c951.tar.bz2
gentoo-2-8c41803c7a25dd70af3cbad7b1f5d4236ee5c951.zip
Do mp3 indexing in init file. Closes bug #48828.
Diffstat (limited to 'media-sound/gnump3d')
-rw-r--r--media-sound/gnump3d/ChangeLog6
-rw-r--r--media-sound/gnump3d/files/gnump3d.conf.d5
-rw-r--r--media-sound/gnump3d/files/gnump3d.init.d10
-rw-r--r--media-sound/gnump3d/gnump3d-2.7.ebuild6
4 files changed, 24 insertions, 3 deletions
diff --git a/media-sound/gnump3d/ChangeLog b/media-sound/gnump3d/ChangeLog
index ba01d4a56595..b686a5193815 100644
--- a/media-sound/gnump3d/ChangeLog
+++ b/media-sound/gnump3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/gnump3d
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/ChangeLog,v 1.16 2004/03/31 22:44:40 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/ChangeLog,v 1.17 2004/04/24 22:46:34 eradicator Exp $
+
+ 24 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org> gnump3d-2.7.ebuild,
+ files/gnump3d.conf.d, files/gnump3d.init.d:
+ Do mp3 indexing in init file. Closes bug #48828.
01 Apr 2004; David Holm <dholm@gentoo.org> gnump3d-2.7.ebuild:
Added to ~ppc.
diff --git a/media-sound/gnump3d/files/gnump3d.conf.d b/media-sound/gnump3d/files/gnump3d.conf.d
new file mode 100644
index 000000000000..9fe7523c1200
--- /dev/null
+++ b/media-sound/gnump3d/files/gnump3d.conf.d
@@ -0,0 +1,5 @@
+# Set this to 0 to stop the init script from indexing your mp3s.
+# It takes the longest on the first time, but after that, it only does
+# updates.
+
+DO_INDEX=1
diff --git a/media-sound/gnump3d/files/gnump3d.init.d b/media-sound/gnump3d/files/gnump3d.init.d
index d20da60d369d..d28b4b470da2 100644
--- a/media-sound/gnump3d/files/gnump3d.init.d
+++ b/media-sound/gnump3d/files/gnump3d.init.d
@@ -1,14 +1,22 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/files/gnump3d.init.d,v 1.1 2004/03/30 18:46:34 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/files/gnump3d.init.d,v 1.2 2004/04/24 22:46:34 eradicator Exp $
depend() {
need net
+ after netmount nfsmount
}
start() {
ebegin "Starting gnump3d"
+
+ if [ ${DO_INDEX} -eq 1 ]; then
+ ebegin "Updating index of music files (may take a while for the first time)"
+ /usr/bin/gnump3d-index
+ eend $?
+ fi
+
start-stop-daemon --start --quiet --exec /usr/bin/gnump3d2 --make-pidfile \
--pidfile /var/run/gnump3d.pid --background -- --quiet
eend $?
diff --git a/media-sound/gnump3d/gnump3d-2.7.ebuild b/media-sound/gnump3d/gnump3d-2.7.ebuild
index 8db76f0d714e..e761fc7f223b 100644
--- a/media-sound/gnump3d/gnump3d-2.7.ebuild
+++ b/media-sound/gnump3d/gnump3d-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/gnump3d-2.7.ebuild,v 1.2 2004/03/31 22:44:40 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnump3d/gnump3d-2.7.ebuild,v 1.3 2004/04/24 22:46:34 eradicator Exp $
DESCRIPTION="A streaming server for MP3, OGG vorbis and other streamable files"
HOMEPAGE="http://www.gnump3d.org/"
@@ -48,6 +48,10 @@ src_install() {
exeinto /etc/init.d
newexe ${FILESDIR}/${PN}.init.d gnump3d
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/${PN}.conf.d gnump3d
+
dodir /etc/env.d
cat >${D}/etc/env.d/50gnump3d <<EOF
# PERL5LIB="${LIBDIR}"