summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-29 11:55:16 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-29 11:55:16 +0000
commitb726036fef441a760a5bd4a99194f620e3532bef (patch)
treef0b2cd91721d716f2c8ddf88f3fcdf81c45a41e3 /media-sound/gnomoradio
parentUpdate gcc-4.3 patches to really fix bug #225761 (diff)
downloadgentoo-2-b726036fef441a760a5bd4a99194f620e3532bef.tar.gz
gentoo-2-b726036fef441a760a5bd4a99194f620e3532bef.tar.bz2
gentoo-2-b726036fef441a760a5bd4a99194f620e3532bef.zip
Select one libsigc++ slot wrt #228483. Fix building with GCC 4.2 (and thus also 4.3).
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc3 x86_64)
Diffstat (limited to 'media-sound/gnomoradio')
-rw-r--r--media-sound/gnomoradio/ChangeLog7
-rw-r--r--media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc42.patch22
-rw-r--r--media-sound/gnomoradio/gnomoradio-0.15.1.ebuild19
3 files changed, 45 insertions, 3 deletions
diff --git a/media-sound/gnomoradio/ChangeLog b/media-sound/gnomoradio/ChangeLog
index c03a700a0641..c28923503e9c 100644
--- a/media-sound/gnomoradio/ChangeLog
+++ b/media-sound/gnomoradio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/gnomoradio
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomoradio/ChangeLog,v 1.18 2008/01/13 16:51:36 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomoradio/ChangeLog,v 1.19 2008/06/29 11:55:15 drac Exp $
+
+ 29 Jun 2008; Samuli Suominen <drac@gentoo.org>
+ +files/gnomoradio-0.15.1-gcc42.patch, gnomoradio-0.15.1.ebuild:
+ Select one libsigc++ slot wrt #228483. Fix building with GCC 4.2 (and thus
+ also 4.3).
13 Jan 2008; Samuli Suominen <drac@gentoo.org> gnomoradio-0.15.1.ebuild:
depend on dev-util/pkgconfig wrt #205653
diff --git a/media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc42.patch b/media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc42.patch
new file mode 100644
index 000000000000..0efc60fb868f
--- /dev/null
+++ b/media-sound/gnomoradio/files/gnomoradio-0.15.1-gcc42.patch
@@ -0,0 +1,22 @@
+diff -ur gnomoradio-0.15.1.orig/roboradio/audio/prober.h gnomoradio-0.15.1/roboradio/audio/prober.h
+--- gnomoradio-0.15.1.orig/roboradio/audio/prober.h 2004-10-17 04:40:36.000000000 +0300
++++ gnomoradio-0.15.1/roboradio/audio/prober.h 2008-06-29 14:48:13.000000000 +0300
+@@ -27,6 +27,7 @@
+ {
+ namespace Audio
+ {
++ gboolean probe (gpointer s);
+ class Prober : public Audio
+ {
+ public:
+diff -ur gnomoradio-0.15.1.orig/roboradio/state.cc gnomoradio-0.15.1/roboradio/state.cc
+--- gnomoradio-0.15.1.orig/roboradio/state.cc 2004-10-24 03:24:34.000000000 +0300
++++ gnomoradio-0.15.1/roboradio/state.cc 2008-06-29 14:48:13.000000000 +0300
+@@ -28,6 +28,7 @@
+ #include <sys/stat.h>
+ #include <dirent.h>
+ #include <iostream>
++#include <cstring>
+
+ #include <map>
+ #include <set>
diff --git a/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild b/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild
index 5e0429ff34f9..31125579d139 100644
--- a/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild
+++ b/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild,v 1.8 2008/01/13 16:51:36 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnomoradio/gnomoradio-0.15.1.ebuild,v 1.9 2008/06/29 11:55:15 drac Exp $
+
+EAPI=1
+
+inherit eutils
DESCRIPTION="Finds, fetches, shares, and plays freely licensed music."
HOMEPAGE="http://gnomoradio.org"
@@ -15,12 +19,23 @@ RDEPEND=">=dev-cpp/gtkmm-2.4
>=dev-cpp/glibmm-2.4
>=dev-cpp/gconfmm-2.6
>=dev-cpp/libxmlpp-2.6
- >=dev-libs/libsigc++-2
+ dev-libs/libsigc++:2
media-libs/libao
vorbis? ( media-libs/libvorbis )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc42.patch
+}
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_enable vorbis)
+ emake || die "emake failed."
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS ChangeLog NEWS README TODO