summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-03-13 11:32:45 +0000
committerChristoph Mende <angelos@gentoo.org>2009-03-13 11:32:45 +0000
commit19fd0ea3f2b4d7c6cbcca340a02221128bd7810d (patch)
tree645195b49d2627f6f933f9282aeca0da5aa07fa7 /media-sound/gmpc
parentVersion bump (diff)
downloadgentoo-2-19fd0ea3f2b4d7c6cbcca340a02221128bd7810d.tar.gz
gentoo-2-19fd0ea3f2b4d7c6cbcca340a02221128bd7810d.tar.bz2
gentoo-2-19fd0ea3f2b4d7c6cbcca340a02221128bd7810d.zip
Version bump
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/gmpc')
-rw-r--r--media-sound/gmpc/ChangeLog7
-rw-r--r--media-sound/gmpc/gmpc-0.18.0.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/media-sound/gmpc/ChangeLog b/media-sound/gmpc/ChangeLog
index 5e6aa35b6c8f..28f4c536ff2f 100644
--- a/media-sound/gmpc/ChangeLog
+++ b/media-sound/gmpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/gmpc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/ChangeLog,v 1.53 2009/02/27 16:34:19 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/ChangeLog,v 1.54 2009/03/13 11:32:45 angelos Exp $
+
+*gmpc-0.18.0 (12 Mar 2009)
+
+ 12 Mar 2009; Christoph Mende <angelos@gentoo.org> +gmpc-0.18.0.ebuild:
+ Version bump
27 Feb 2009; Tiago Cunha <tcunha@gentoo.org> gmpc-0.17.0.ebuild:
stable amd64/sparc, bug 259793
diff --git a/media-sound/gmpc/gmpc-0.18.0.ebuild b/media-sound/gmpc/gmpc-0.18.0.ebuild
new file mode 100644
index 000000000000..e78e70e402c7
--- /dev/null
+++ b/media-sound/gmpc/gmpc-0.18.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/gmpc-0.18.0.ebuild,v 1.1 2009/03/13 11:32:45 angelos Exp $
+
+EAPI=1
+
+inherit gnome2-utils
+
+DESCRIPTION="A GTK+2 client for the Music Player Daemon"
+HOMEPAGE="http://gmpcwiki.sarine.nl/index.php/GMPC"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls session"
+
+RDEPEND=">=dev-libs/glib-2.10:2
+ dev-perl/XML-Parser
+ >=gnome-base/libglade-2.3
+ >=media-libs/libmpd-0.17.1
+ net-libs/libsoup:2.4
+ net-misc/curl
+ >=x11-libs/gtk+-2.12:2
+ x11-libs/libsexy
+ session? ( x11-libs/libSM )
+ spiff? ( media-libs/libspiff )"
+DEPEND="${RDEPEND}
+ dev-util/gob
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_compile() {
+ econf \
+ $(use_enable session sm) \
+ $(use_enable spiff libspiff) \
+ --enable-system-libsexy \
+ --disable-shave
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}